Docker deletes Jellyfin container automatically after reboot

  • Hello everyone.

    First of all, feel free to delete or move this thread, since I've just created this account and maybe it is a duplicated thread.

    I've had this OMV 4.x. instance running for over a year or so in my Raspberry Pi 3B+, working with SMB. It was just a simple NAS where I stored my photos.

    But a week ago or so, I started to add some more functionality, and decided to use it as a place to store a wider variety of files.

    I heard of Jellyfin, and tried to install it following Technodad's video. At first, everything worked correctly, and I was able to set Jellyfin up perfectly. Indexing my files, adding the metadata... But, after some time in the app, it just stops working. I head to the Docker page, inside OMV's web GUI, and realize that the container is dead. And I can't restart it, since I get this error:

    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker start 7ff3603a3ccf 2>

    So I try to restart OMV, and then, the container is gone. The filesystem created for Jellyfin in the drive is still there; also the metadata, but as I said before, there's no container in the Docker page. Only an image with no name (The name is none:none) created "six months ago", and the same configuration data as the Jellyfin app. And obviously, I can't access Jellyfin and its services.

    It has happened three times already.

    I think it has to do with some kind of configuration I hadn't done when setting up Docker, since I'm a total beginner with this app. In addition, I haven't tried to install any other images since I don't know how to set them up, and I don't think I need any other service.

    Thanks in advance for your response.

  • KM0201

    Approved the thread.
  • I can't say what is causing your issue before the reboot.. other than Pi3's have kinda crappy USB so it's possible the drives are losing their connection for some reason, could be drive issues. I'm just not a fan of SBC's for this stuff (but I do think they have their place, just not as an always on media server)


    Regarding it being gone after reboot, There's a good chance docker is starting before your USB drives are mounted.


    To verify... Reboot your server (or if it's up now and jellyfin isn't working)

    SSH the server and as root or sudo run this command


    systemctl restart docker


    Once docker restarts, give it a second and see if everything is operating normally in jellyfin. If it is, then that's all it is, the docker service is starting before the drive is mounted. macom shared a delay script not to long ago that would delay starting docker by 30sec... which solves the problem. Basically the system reboots, and 30sec after reboot, docker starts.. by then the drives should be mounted.


    If he doesn't chime in here, I'll try to find it here in a bit.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Thanks for your response! It appears that the command does nothing when jellyfin is not working (situation shown in the picture attached), but I'll try to test it as soon as I configure it again.


    The situation appears to be the same after the jellyfin setup and reboot.

    Found it here

    The link provides useful information, due to the fact that I think that the problem the user has is somewhat relatable to mine, so I'll read it more thoroughly. I applied the script and it does its work (starts Docker later on), but as I said before, the media server app is not configured, so I'm not able to see its utility.


    EDIT: I did the same having created the container, and the results do not change.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!