Duplicati access rights

  • Hi all,


    I've tried to install Duplicati using the How to guide by @ macom as well as through Portainer in line with @ Technodad's video and the install seems to go smoothly but I seem to arrive at the same error when I attempt to run a backup which I've concluded is due to access rights. [Thanks btw guys]


    Code
    One or more errors occurred. (Access to the path "/backups/duplicati-b9c2c233aa6344a9aaef91b87676d1b6c.dblock.zip.aes" is denied. (Access to the path "/backups/duplicati-b9c2c233aa6344a9aaef91b87676d1b6c.dblock.zip.aes" is denied.) (One or more errors occurred. (Access to the path "/backups/duplicati-b9c2c233aa6344a9aaef91b87676d1b6c.dblock.zip.aes" is denied.)))


    I've tried using different users (whose id I stated during the setup) and ensuring that they have R/W/X access to the volumes through Users>Privileges, Shared folders>Privileges and Shared folders>ACL but nothing seems to work.


    I succeed in running a backup when I define the backup destination using SFTP instead but due to access problems, the content that is backed up is around 1kb.


    Can someone point me in the right direction? Btw, if not clear, I'm a Linux beginner. :)

  • Your backup folder is mounted by a line like this in the compose file


    Code
    - /srv/dev-disk-by-label-data/docker/backup:/backups

    Delete this folder /srv/dev-disk-by-label-data/docker/backup and let docker create it when you deploy the container. Ownership and permissions should be correct.

  • Your backup folder is mounted by a line like this in the compose file


    Code
    - /srv/dev-disk-by-label-data/docker/backup:/backups

    Delete this folder /srv/dev-disk-by-label-data/docker/backup and let docker create it when you deploy the container. Ownership and permissions should be correct.

    Thanks for your reply. It still doesn't work and I get the same error


  • Code
    total 8
    drwxr-xr-x 2 root root 4096 Apr 8 18:03 .
    drwxr-xr-x 3 root root 4096 Apr 8 18:03 ..


    I replaced "data" with the label of the drive that I want to back up to


    I use ext4

  • Try


    sudo chown -R docker1:users /srv/dev-disk-by-label-data/docker/backup


    with docker1 being the user that has the UID you used in the docker-compose file.


    I never did local backup with duplicati. So if this is not working, I need to make a test.

  • Thank you for your help. This time I got another type of error (see below). Don't I need to make similar priviliges-corrections to the folders with the content that I want to back up?


  • The user that is running the container must have read access to the data you want to backup.


    If you create a user in the GUI of OMV, this user will be a member of the users group.

    If you create a shared folder in the GUI of OMV the group users will have read access to that share.


    That is why the user that is running the container should be one that is created in the GUI of OMV. It just works (in most of the cases) if you do as much as possible in the GUI of OMV.


    But I am not sure if the warning is related to that. Does the folder contain files?

  • Okay, that's the way I've done. I created the user in the GUI, he belongs to the group "Users" and was the one that I specified in the docker compose-file. Likewise, the shared folder was created in the GUI. I've basically only used the GUI of OMV and the Samba-shares.


    I deleted the folder that I want to back up to per your previous instructions. The folders that I'm trying to back up all contain folders and files.

  • And that folder was also created as shared folder in OMV?


    Just to be sure, check owner and permissions of the folder and the files inside.

    Yes, I formatted the drive, mounted it, and created shared folders in OMV GUI. I filled them with content through Windows using Samba.


    In Access rights management>Privileges, Docker1 has Read and Write privileges to all discussed folders.


    In the ACL:

    Docker1 has Read/write

    Owner (Root) has Read/Write/Execute

    Group (users, which includes Docker1) has Read/Write/Execute

    Others have "None"


    I've enabled "Replace all existing permissions"


    I'm unable to persistently enable "Recursive: apply permissions to files and subfolders". Whenever I enable, apply and reopen the box, it's disabled.


    I have tried to share the volume that the folders exist in and enabled "

  • I never use ACL.

    I would use the resetperms plugin to rest the permissions of that folder.

    Thank you for the advice. I did that now and reset the permissions for each folder involved but I'm still only able to back up a few kBs



  • I am running out of ideas.


    Just made a test. Docker is running as docker 1 with uid 1002 and gid 100


    This are the permissions of the folders


    Code
    drwxrwsr-x 1 root users 17352 Apr 8 20:24 dummy
    drwxrwsr-x 1 root users 282 Apr 8 20:15 test

    test is the source and dummy is the target


    these are two files from the test folder

    Code
    -rw-r--r-- 1 root users 0 Apr 8 20:28 test.1
    -rw-r--r-- 1 root users 0 Apr 8 20:28 test.2
  • This is what I got. The first folder is the backup destination wheras the other is one of the folders that I'm trying to back up


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!