OpenMediaVault und Kodi

  • Moin miteinander


    Ich habe ein ganz großes Problem mit OMV und Kodi


    Alles ist soweit bei OMV eingerichtet und bei Kodi auch. Beide Systeme laufen auf einem Raspberry 3B+ und funktioniert an sich soweit auch.

    Auch über Windows-Zugriff, alles super. Ich schicke darüber die neuen Aufnahmen so auch auf das NAS. Und hier gehen die alle Festplatten auch, wie es auch seiene sollte in den automatischen Standby.

    Doch wenn ich über Kodi auf das NAS zugreife und ich meine aufgenommen TV shows schauen möchte (Zugriff mit SMB), bleiben die Videos einfach hängen und bekomme immer wieder zur zufälligen Zeit des abspielen verschiedener Videos die Meldung "NO ROUTE TO HOST" und danach bleibt die angesprochene Festplatte auch noch in dauerschleife im Betrieb, obwohl die sich in der Regeln selber nach 10 min grundlegend in den Standby schaltet.

    Hänge mit diesen Problem schon MONATE lang dran und finde einfach keine Lösung für dieses Problem...
    Es gibt viele im Netz, die das selbe Problem haben und keiner kennt eine Lösung..

    Da fühlt man sich wahrhaftig im stichgelassen..


    Denn ich bin hart am überlegen auf kostenlose NAS Programme zu verzichten, wenn es eh nicht funktioniert und ich meine ganze Freizeit damit vergolde das genannte Problem zu lösen oder nach Lösungen im gesamten Internet zu durchforsten...
    Hätte ich das Geld über, dann könnt ich mir auch ein System für 1000€ holen und hab zumindenstens die Garantie, dass das alles zu 100% funktioniert...

    Macht nämlich kein Spaß mehr, NUR NOCH nach Lösungen zu schauen, statt meine Aufnahmen.. Es frustriert mich jeden Tag und das schon seit über 4 Monaten...

    Und das keiner keine weiterbringene Information bieten kann ist einfach nur traurig!!!!


    Bitte bitte helft mir sonst schmeiß alles in den Müll..

  • If I was a guessing man, the drives are going to sleep and the Pi is losing it's connection SMB, and it doesn't automatically connect back when the drives wake up.


    First I would try disabling any sleep functions and see if that helps

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • While I am watching a video file disconnect the Drive..?

    I mean, i can copy Files on the drives and this works perfectly..

    The hard drives go to sleep after 10 minutes of inactivity by themself and I have not switched on the sleep function in the settings.
    it can't be because of that either

    And when I use NFS i becam this failure:

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color nfs 2>&1' with exit code '1': raspberrypi: ---------- ID: configure_default_nfs-kernel-server Function: file.managed Name: /etc/default/nfs-kernel-server Result: True Comment: File /etc/default/nfs-kernel-server is in the correct state Started: 04:27:43.224245 Duration: 312.778 ms Changes: ---------- ID: configure_nfsd_exports Function: file.managed Name: /etc/exports Result: True Comment: File /etc/exports updated Started: 04:27:43.537765 Duration: 636.102 ms Changes: ---------- diff: --- +++ @@ -7,7 +7,7 @@ /export/FILME_HD (fsid=2,ro,subtree_check,insecure) /export/SERIEN_HD_1 (fsid=3,ro,subtree_check,insecure) /export/SERIEN_HD_2 (fsid=4,ro,subtree_check,insecure) -/export/SERIEN_SD (fsid=5,ro,subtree_check,insecure) +/export/SERIEN_SD (fsid=5,rw,subtree_check,insecure) # NFSv4 - pseudo filesystem root /export (ro,fsid=0,root_squash,no_subtree_check,hide) ---------- ID: start_rpc_statd_service Function: service.running Name: rpc-statd Result: True Comment: Service rpc-statd has been enabled, and is running Started: 04:27:44.355116 Duration: 2552.219 ms Changes: ---------- rpc-statd: True ---------- ID: start_nfs_kernel_server_service Function: service.running Name: nfs-kernel-server Result: False Comment: A dependency job for nfs-server.service failed. See 'journalctl -xe' for details. Started: 04:27:47.303342 Duration: 333.702 ms Changes: Summary for raspberrypi ------------ Succeeded: 3 (changed=2) Failed: 1 ------------ Total states run: 4 Total run time: 3.835 s


    Sorry for my bad english.. is not my mother tongue ':D

  • Okay .. Just restarted OMV again and now I could activate NFS ..
    Let's see how long I can watch videos from the hard drive without interruption. Hope the error "No route to host" does not come back
    I'll get back if the error should come back ..

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!