Slow network transfer rate

  • Hi Everyone,

    This is my first OMV server and I'm having some speed issues

    i7 Gen2

    16GB Ram

    Boot drive SSD

    Storage drive 3TB WD Red NAS

    Gigabit Ether


    My download speed caps at 2MB and I am not able to stream anything. gave it a reboot and it is at max transfer speed and I am able to stream multiple devices.


    any suggestions ?

  • Couple of questions first

    - hard wired or WIFI

    - network card or integral to motherboard

    - if WIFI; 2.4 or 5G

    - router and LAN and WIFI settings (if on WIFI)

    - ISP provider and internet access speed you are paying for

    - network settings in OMV (DHCP or Static) MTU


    Do you have a capability to check internet access speed independent from OMV?.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DE

    OMV5 NAS, Fractal Design Define R5, 22TB storage

  • all connections are hard wired

    Network card

    No Wifi

    Microtik gigabit router, gigabit Cisco Managed switch.

    200Mbps/200Mbps Fibre internet


    Yes I do, internet speed is average 190Mbps



    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group defaul t qlen 1000

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether 00:22:2d:c2:0f:d7 brd ff:ff:ff:ff:ff:ff

    inet 192.168.1.80/24 brd 192.168.1.255 scope global enp7s0

    valid_lft forever preferred_lft forever

    3: br-a90ec96331e8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue sta te UP group default

  • OK, on your NAS network card enp7s0 try following settings:

    - Turn all "offload" options OFF

    - Disable Interrupt Moderation / Set Interrupt Moderation rate to OFF

    - Disable Flow Control OFF (on your router as well)

    - Disable, if you have these settings on your network card, the following: Receive Side Scaling, Adaptive Inter-Frame Spacing, set "Enable PME" to DISABLED, Packet Priority & VLAN, Jumbo Packet.


    Hope this will fix your issue.

    Edit: do the same an all your computers in your intranet.

    EndeavourOS

    Linux Mint 20.2 "Uma", Cinnamon DE

    OMV5 NAS, Fractal Design Define R5, 22TB storage

    Edited once, last by andrzejls ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!