Can't disable FTP or add/remove shares

  • Everything fails with this...


    Error #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color proftpd 2>&1' with exit code '1': hell6:
    ----------
    ID: configure_proftpd_mod_core
    Function: file.managed
    Name: /etc/proftpd/proftpd.conf
    Result: True
    Comment: File /etc/proftpd/proftpd.conf updated
    Started: 16:05:43.955376
    Duration: 283.115 ms
    Changes:
    ----------
    diff:
    ---
    +++
    @@ -43,56 +43,3 @@
    </Limit>
    </Directory>

    -<IfModule mod_auth.c>
    - DefaultRoot /srv/ftp
    - MaxClients 5
    - MaxLoginAttempts 1
    - RequireValidShell on
    - # This option is useless because this is handled via the PAM
    - # pam_listfile.so module, so set it to 'off' by default.
    - UseFtpUsers off
    -</IfModule>
    -<IfModule mod_auth_pam.c>
    - AuthPAM on
    - AuthPAMConfig proftpd
    -</IfModule>
    -<IfModule mod_ban.c>
    - BanEngine off
    - BanControlsACLs all allow user root
    - BanLog /var/log/proftpd/ban.log
    - BanMessage Host %a has been banned
    - BanTable /run/proftpd/ban.tab
    -</IfModule>
    -<IfModule mod_ctrls.c>
    - ControlsEngine on
    - ControlsMaxClients 2
    - ControlsLog /var/log/proftpd/controls.log
    - ControlsInterval 5
    - ControlsSocket /run/proftpd/proftpd.sock
    -</IfModule>
    -<IfModule mod_ctrls_admin.c>
    - AdminControlsEngine off
    -</IfModule>
    -<IfModule mod_delay.c>
    - DelayEngine on
    -</IfModule>
    -<IfModule mod_facl.c>
    - FACLEngine on
    -</IfModule>
    -<IfModule mod_quotatab.c>
    - QuotaEngine off
    -</IfModule>
    -<IfModule mod_ratio.c>
    - Ratios off
    -</IfModule>
    -LoadModule mod_vroot.c
    -<IfModule mod_vroot.c>
    - VRootEngine on
    - VRootLog /var/log/proftpd/vroot.log
    - VRootAlias "/srv/dev-disk-by-uuid-a188658e-405e-4eee-8ffd-5f8e37dc68e7/Storage/" "Storage"
    -</IfModule>
    -<IfModule mod_wrap.c>
    - TCPAccessFiles /etc/hosts.allow /etc/hosts.deny
    - TCPAccessSyslogLevels info warn
    - TCPServiceName ftpd
    -</IfModule>


    error.txt

  • do you have the directory /srv/ftp?

    No I don't, only thing in /srv/ is disk-by-uuid drives.

    Not sure why it's there, the only thing I've ever done with ftp is add one share.


    Should I manually change this to a directory that does exist? What should that directory be on a standard OMV5 installation?


    EDIT:


    Ok I just created that folder and everything appears to work now. Strange that it's the default setting, yet OMV doesn't appear to create that folder automatically, at least not for me.

  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!