Is there a guide to in place upgrade?

  • omv-salt

    rm /etc/netplan/20-openmediavault-enx001e0632bfca.yaml

    omv-salt

    no error

    nano /etc/netplan/20-openmediavault-enx001e0632bfca.yaml - file is empty

    omv-firstaid - dhcp config

    omv-upgrade:

    omv-release-upgrade

    ...

  • ...

  • reboot:

    still old version.

    • Official Post

    Post #2:


    Quote
    1. Backup the OS drive (this is allways a good idea, not only for upgrades)
    2. Make sure, you have enough free space on your os drive
    3. Check any installed plugins if they have been ported to OMV6
      If you are using plugins which have not been / will not be ported, get rid of the plugins except unionfs / mergefolderfs. These two will automatically be be converted to the newer mergerfs plugin
      (Many plugins can be replaced by docker containers. Do this before upgrading)
    4. If you installed software from foreign repos make sure they have a release for bullseye or remove the repos / software
    5. Go to the cli (Putty, ssh, keyboard) and run these commands (In case of errors stop and ask on the forum before makingthings worse)
      1. Make sure your current install is correct all configs can be deployed by running sudo omv-salt stage run deploy
      2. Get the current install up to date: sudo omv-upgrade
      3. Do the release upgrade by running sudo omv-release-upgrade
        If you see an error message from patch which says a patch has alredy been applied, ignore it. (this is the only error to be ignored)
    6. Wait for the last script to finish and reboot.
    7. Refresh/clear browser cache (Crtl-Shift R on most browsers)
    8. Check if all services and docker containers are running as you expect.
    9. If you see Linux image Updates you can not install on the UI, go to the cli and run omv-upgrade once more.

    I understood that you managed to get to point 5.1

    The omv-salt command resulted in no errors. Correct.

    But then at 5.2 you still have an error. You need to fix that first and then proceed to 5.3.

  • Still the same. I have info about "successful upgrade" after omv-release-upgrade, but after reboot armbian is stiil buster and omv v.5

  • We did it on Oct 6th 2022. Few post ago.

    If warning is not harming my upgrade, I will try clean install and config from beginning. Probably will be faster.

    Thank You very much for your help.

    I'm surrender. Maybe in few day I will try upgrade again after restoring my OMV5 backup, just to check why is upgrde not working.

  • Hi there,

    I got stuck at 5.2: sudo omv-upgrade


    I got problems updating.

    I tried changing the DSN in OMV and in router to 1.1.1.1

    tried stopping all the docker images.


    Does It fails to connect to repositories?


    Err:17 https://www.debian.org/debian buster-backport Release

    404 Not Found [IP: 130.89.148.77 443]

    Reading package lists... Done

    E: The repository 'https://debian.org/debian buster-backport Release' does not have a Release file.

    N: Updating from such a repository can't be done securely, and is therefore disabled by default.

    N: See apt-secure(8) manpage for repository creation and user configuration details.

    • Official Post

    edit

    /etc/apt/sources.list.d/openmediavault-kernel-backports.list


    and replace


    https://debian.org/debian buster-backport

    by

    http://httpredir.debian.org/debian buster-backports


    so that the content of the file reads:

    Code
    deb http://httpredir.debian.org/debian buster-backports main contrib non-free


    after that run apt update and there should be no issue.

    Then omv-upgrade again

  • It's in italian.

    I hope it's not an issue.


    I double checked with vim the [..]backport.list and it points to the correct link:

    • Official Post

    Errore:20 https://www.debian.org/debian buster-backport Release

    404 Not Found [IP: 130.89.148.77 443]

    Maybe you have it in another source.

    grep -r /etc/apt/ -e "buster-backport"


    Did you already run the omv-release-upgrade? You have now usul and shaitan repositories, which should not be the case.

  • Maybe you have it in another source.

    grep -r /etc/apt/ -e "buster-backport"


    Did you already run the omv-release-upgrade? You have now usul and shaitan repositories, which should not be the case.

    Yes, I tried the omv-release-upgrade. No success.

    here the output of

    Code
    grep -r /etc/apt/ -e "buster-backport"

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!