FTP Service not working after reboot

  • I can enable FTP and have it working on a share but after reboot the service goes down and I cannot anumore connect.

    The share is still there and the service is marked as active but the diagnostic says:

    I tried several times but the result is always the same.

  • BTW, if you are using flashmemory plugin, then make sure to shut it down correctly, otherwise the RAM drive is not synced and results in your current situation.

    Please run the command from above without uninstalling the plugin. It should work also this way.

  • Do you have installed the flashmemory plug-in?

    If so, uninstall it and run

    # omv-salt deploy run proftpd

    Sorry for the late reply.

    I do not have flashmemory plug-in because my install is on armer architecture and omv-extras are not available.

    I only managed to install resetperms.

    I tried the above command and it has restored FTP service but after reboot I still have the same issue.

  • miazza

    Changed the title of the thread from “FTP Service not working after reboot.” to “FTP Service not working after reboot”.
  • Similar problem. Already three times today reinstalled the system. Updated via CLI, launched ftp, rebooted and ftp worked. After that, I completely configured the system, rebooted again and ftp did not work. Executed the #omv-salt deploy run proftpd# command, after which ftp started working, but only until the next system restart (. And i do not have flashmemory plug-in.

  • I found what causes this bug for me. If I include any ban rules for ftp, then after rebooting the system, ftp is enabled, but not running. If I change the ban rule, then ftp is running again, but after rebooting the system, ftp is not running again. Only a complete shutdown of the ban rules for ftp helps to get rid of this bug. This is very bad. Over the past 24 hours, I have already reinstalled OMV six times, including downloading the distribution from an official source three times and writing it to a USB flash drive, and each time this bug.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!