Using omv6 on a compaq hp 300b

  • Hi everyone, I am running omv6 on an old hp compaq 300b. I use it a simple fileserver at the office, where many pc connect smoothly to it. I was thinking to expand the internal storage by adding some hard disks. Unfortunately, it is a microtower and the space inside is not that much. I have not found yet a suitable multi-bay chassis for it. I am evaluating now a change of perspective as a new (old) pc asus (tower format) is now available. It has much more space inside and a rack for internal hard disks. I cannot check the motherboard model at the moment. I can do it next week, but It has approximately the same age of the hp 300b, around 10-12 years. Also, I can say that the asus runs linux mint debian 5 (same core as omv 6) and does it perfectly. What about if I switch the hard disks? I could run omv6 in the asus, which has the right form for a server, and the mint debian on the hp. Normally, i would say that there could be issues with the drives and maybe with the bios. However, since both systems use the same debian core and it runs perfectly, i feel more encouraged to give it a try next week. Any suggestions or contraindications in the meanwhile?

    Thanks a lot in advance


    • Official Post

    I can say that the asus runs linux mint debian 5

    What is this? Linux Mint should be something like 21. And Mint is based on Ubuntu, not Debian, which is currently version 11. Or are you referring to the kernel version.

    Anyhow. It should work if you switch the drives from Server 1 to Server 2. But you have to run omv-firstaid to configure the network interface.

  • Hi, thanks for your reply. Linux mint debian edition 5 (LMDE name "Elsie") is based on Debian 11, not on Ubuntu. I choosed to install that special edition of Mint because of its great stability and compatibility with older machines, combined with Mint tools. I think, Omv 6 and Mint Lmde 5 are very similar, if not identical, at their core.

    Anyway, thanks a lot for your indications. It encourages me to give it a try. Do you mean I have to follow this procedure?

    Thanks a lot

  • Hi,

    If I understand correctly, I should first enable ssh in the GUI of the HP (Services --> SSH --> Permit root login), then switch the drives between the pcs, and then login into OMV6 (now in the Asus pc) via ssh. This should be done via the command

    ssh admin@myip

    then type


    and follow the procedure.

    Is that right?

    Thanks a lot

  • Sorry, there is something that I don't get. The guide says:

    • Login to your OMV via SSH
    • Type in omv-firstaid and hit enter.

    How do I login to OMV via display and keyboard? As root with root password? Could you please explain it?

    Thanks in advance for time and patience

  • Hi, I tried the switch. It has partially worked. I had to run as a root omv-first aid. That worked. However, the network was automatically reconfigured as DHCP server. The previous static Ip was not recognized, so I added manually the static ip address, which partly worked. I will follow up in the next days in order to see if the ethernet connection becomes stable. Otherwise, I will have to reinstall omv6. About this, I would be grateful if you could point me to an actual guide. I have seen technodad video about internal usb install, which I found elegant. Unfortunately, the devices that he employed are sold out or not available in italy. I installed omv 6 on a hard disk, then I worked with gparted, to create on the same hard disk a new partition for data. I wonder if there is a suggested procedure in order not waste hard disk space, maybe install omv6 on external usb and clone the pendrive. I have already backed up the data on the hard disk, so that I am ready for a fresh install for the case that omv6 with the static ip will not work properly. I have noticed some error messages just at system start up. Could you please tell me if by your experience this scenario would work: 1. fresh install on external usb and clone the pendrive; 2. work with gparted so that I can unmount and erase the boot-system partition of the hard disk; 3 use gparted to move left on the hard disk the data partition; 4: mount the whole hard disk as data for the new omv6 install.

    Thanks a lot

    • Official Post

    install omv6 on external usb and clone the pendrive

    Yes is possible. Many do. You want to clone the pendrive to have a backup?

    2. work with gparted so that I can unmount and erase the boot-system partition of the hard disk; 3 use gparted to move left on the hard disk the data partition; 4: mount the whole hard disk as data for the new omv6 install.

    As you plan to do a fresh install, you cannot unmount the partition. It is not mounted. However, you can delete it and move/resize the data partition with gparted.

    You messages regarding IP address might be related to IPv6. If so, you can disable IPv6. Most likely you are only using IPv4 in your network.

  • Hi thanks for your answer. I did not enable IPv6. I haven't seen it enabled yet in our network. I am confident that in the next days the situation will become more stable and the error messages at system startup will be overcome. Otherwise, I will proceed with the fresh install. Potentially, there should be another solution, i.e to install debian 11 in the system partition of the hard disk and then omv6 on the top of it. I tried this once, but the procedure was not so straightforward as I thought and the attempt failed. Better keep it simple. I was thinking of the pendrive (and a clone of it) despite of its limitations since a reinstall would be easier. We keep separated system and data. Also a small hard disk will do. In the desktop workstation asus I have plenty of available space. Thanks a lot. I will post a message in a couple of days.

  • essegi62

    Added the Label resolved
  • Hi, the case is solved. today omv6 was working just fine. For the reader of the forum, I would like to point out that the switch was a success. Probably, the fact that both pc run two variations of debian (omv6 and mint debian) and that both were in bios mode played a role. Mint was immediately recognized, omv6 experimented some turbulence at the very beginning, but in a couple of hours the situation was stable. Thanks a lot!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!