Bad Gateway error after omv-release-upgrade

  • Hi there, I did an upgrade via omv-release-upgrade (because there was no update in WebGUI available) and there was some error after the upgrade (some packages could not be loaded, as far as I remember). I assumed there was no upgrade done. But obviously some kind of upgrade was done.

    Unfortunately I cannot login to the WebGUI any more (502 - Bad Gateway). Commands like "omv-initsystem" or "omv-update" result in "Command not found"

    What is my problem with the system. Is there any possibility to repair?

    By the way: all shares are running, I can access data on the fileserver, and also docker containers (there is HomeAssistant running as container on the system) is working fine.

    Can someone help me to identify the problem?

    Thank you very much!

  • Hi, thank you for reply!

    First of all the output as requested:

    And to the script: how should I use this?

    Code
    root@openmediavault:~# fix6to7
    -bash: fix6to7: Kommando nicht gefunden.
  • And to the script: how should I use this?

    Search the forum for that term.

  • iU openmediavault

    Having a CAPITAL letter on that output is not a good sign.


    Since you ran the fix script, post the same output to see how your system is now:

    dpkg -l | grep openm

  • Hi Soma,


    system is working currently (as mentioned above), but I still have the capital letters:

    Can you explain, what iU means?

    Thank you very much!

  • Can you explain, what iU means?

    command line - What do the various dpkg flags like 'ii' 'rc' mean? - Ask Ubuntu


    It shows that it's installed and Unpacked.

    When in a "normal" status, it would show only ii


    When this happens, it usually shows a remark/warning on the output when running the update, saying that you need to run dpkg --configure -a




    I don't know what will happen by running that command.

    If you decide to do it, make sure you have a backup of the OS drive, in case it goes sideways.


    To see what apt shows, just post the output inside a CODE box of:
    sudo omv-upgrade

  • both command end up with:


  • The output shows dependencies issues which makes the packages staying in the unconfigured state and causes errors on the rest in cascade.


    I'll tag ryecoaaron hoping he can shed a light (and solution) to this.

    • Official Post

    The packages need to finish installing. Run sudo apt-get -f install

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • thank you, this happens when I run the command:

    • Official Post

    What is the output of: sudo cat /etc/default/nfs-kernel-server

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • This is the output:

    • Official Post

    On line 12, remove the last --nfs-version. Then try sudo apt-get -f install again.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    Run the fix6to7 script.

    omv 7.1.1-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.1.1-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Maybe also post the output again of:

    dpkg -l | grep openm


    To confirm that everything is correct.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!