Kodi (formerly XBMC) for OMV - test phase

  • hello
    First thank you for your work.
    I was looking for the perfect OS for an old pentium 4 to 3GHZ and 4G Ram and I think I've found.
    I followed the steps of your installation in OMV with kernel 64bit 3.16.0.0 bpo.4-a.
    Also Reproduce step 3 to start at the beginning.
    He did not give me any error during installation. XBMC starts at the beginning and runs very fluid, but it is presented as the first failure. I do not recognize the usb device. When I try to connect the USB memory to install add-ons to Kodi, this turns off and the system returns to the OMV terminal.
    The version of kodi is a beta. Is that the problem?
    Thanks again and sorry for my English translation






    Hola


    En primer lugar
    agradecer tu trabajo.


    Yo buscaba el
    sistema operativo perfecto para un viejo pentium 4 a 3GHZ y con 4G de
    Ram y creo que ya lo he encontrado.


    He seguido los pasos
    de tu instalación en OMV 64bits con kernel 3.16.0.0 bpo.4-a .


    También seguí el
    paso 3 para el arranque al inicio.


    No me dio ningún
    error durante la instalación. XBMC arranca al inicio y corre muy
    fluido, pero se me presenta ya el primer fallo. No me reconoce los
    usb del equipo. Cuando intento conectar la memoria usb para instalar
    add-ons a Kodi, este se apaga y el sistema vuelve a la terminal OMV.


    La versión de kodi
    es una beta. ¿Es ese el problema?


    Gracias nuevamente y
    disculpen mi ingles traducido

  • Thanks for your hint. I did not try that!
    I will install OMV again because I messed too much with all these repos, installs, Xorg configs etc around..
    Clean install -> Clean update to Backport Kernel (from WebUI) -> Install of the backport/experimental drivers -> Compile Kodi -> Cross my fingers -> "xinit kodi"


    Thanks for your help
    and greetings from germany


    how does it work to install the experimental drivers in backport?

  • I tried to complete the compilation in the virtual machine, but it seems it is missing the X driver, and thus the interface doesn't start although the compilation completed successfully.


    I wanted to test it virtually before compiling it on the Banana Pi.


    What would be the proper instructions for compiling X driver?

  • Hi @ All,


    great news that Kodi can be install on OMV.
    followed the guide 1:1 and there was no errors.
    But during the start I have an error showing that Xorg is is not starting or is too old.
    I have Asrock Q1900 with Intel® 7th generation (Gen 7) graphics and the lates OMV.


    Could some please advise how to update xorg?
    (Details are wellkom , cause I'm just starting to work with linux.)


    Many thanks in advance

  • HI,


    I have followed ur guide and now hit the roadblock after the ./configure step:


    checking for DRM... no
    configure: error: Could not find a required library. Please see the README for your platform.


    Can you please advise how to overcome this?


    here is the link to config.log http://pastebin.com/vyxRTbW8

    Edit - resolved it by installing libdrm and swig package.

  • /bin/bash: ../../../tools/depends/native/JsonSchemaBuilder/bin/JsonSchemaBuilder: No such file or directory
    make[1]: *** [ServiceDescription.h] Error 127
    make: *** [xbmc/interfaces/json-rpc/json-rpc.a] Error 2


    Getting this error while using this command - make


    Any ideas?

  • Hi


    I have a problem with compiling KODI on OMV.
    After using the command make I get an error:


    LD kodi.bin
    /usr/bin/ld: /usr/lib/x86_64-linux-gnu/libavformat.a(tls.o): undefined reference to symbol 'gnutls_certificate_set_x509_system_trust@@GNUTLS_DEBIAN_0_3_0_0'
    //usr/lib/x86_64-linux-gnu/libgnutls-deb0.so.28: error adding symbols: DSO missing from command line
    collect2: error: ld returned 1 exit status
    Makefile:486: polecenia dla obiektu 'kodi.bin' nie powiodły się
    make: *** [kodi.bin] Błąd 1


    I need your help.
    Thank You.

  • Hi,


    i'm having some problems following the guide.
    I have an nvidia card to start with but i don't think that's a problem (or at least no yet)
    I got to the make steps and i get the following error. Any idea as to what the problem could be?
    I'm running OMV 1.19


    Code
    root@openmediavault:~/kodi# make -C lib/taglib
    make: Entering directory `/root/kodi/lib/taglib'
    make -C taglib-1.8/build
    make[1]: Entering directory `/root/kodi/lib/taglib/taglib-1.8/build'
    make[1]: *** No targets specified and no makefile found. Stop.
    make[1]: Leaving directory `/root/kodi/lib/taglib/taglib-1.8/build'
    make: *** [libtaglib.so] Error 2
    make: Leaving directory `/root/kodi/lib/taglib'


    /root/kodi/lib/taglib/taglib-1.8/build is indeed empty but i don't know why?


    Thanks.

  • Hi, thanks for the guide to set up Kodi! Worked perfectly :) But I recently had to change routers and IP range, now Kodi cant access internet connection?? Cant work out how to change its network settings? Have tried to uninstall with apt-get remove kodi* with no luck. Any suggestions on how to completely remove so that I can re install, would be greatly appreciated. I'm assuming that re installing under the new IP range would sort out connection problems?


    Cheers.

  • Hi everyone,


    At first I would like to thanks to Aoprea75 for his work and bring us this new release of Kodi 15 beta 2.
    I'm running Debian Wheezy on my HP Microserver with OMV. I wanted XBMC so I installed the package on deb-multimedia repository. The thing is that the XBMC version on this repository is 12.3 and is pretty old...youtube plugging not updated, etc...
    So I followed this tutorial and everything worked great.


    I have some questions for you...


    1) How we are going to manage to update Kodi to the next versions from now? because we have compiled the version...so it won't be dynamic in the future for updates with apt-get update&upgrade right??


    2) I have passed from 10G to 18G on my OS...which is no great for backups....
    Once Kodi is installed, cans we delete something to free some space? Maybe the downloaded files?


    3) My CPU was about 5% utilisation on standby running XBMC, now with KODI it's more like 35% on standby.... is it normal?


    For now, because of the point number 3 I'm rolling back to XBMC 12.3...



    Thanks.


    PS: Ariplay is working for you on IOS 8.3? not for me...

  • I manage to find the solution to my problem.


    Here's what i did to get KODI working...


    GCC installation (needed for the NVIDIA driver) (I have an NVIDIA graphic card in my HP Microserver so can output directly to a TV via HDMI)
    apt-get install build-essential gcc g++ make binutils linux-headers-`uname -r`


    then for KODI :
    omv-update
    apt-get install python-software-properties pkg-config
    apt-get install software-properties-common
    apt-get install freeglut3 freeglut3-dev libdrm-dev doxygen swig git-core


    apt-get install automake autopoint bison build-essential ccache cmake curl cvs default-jre fp-compiler gawk gdc gettext gperf libasound2-dev libass-dev libavcodec-dev libavfilter-dev libavformat-dev libavutil-dev libbluetooth-dev libbluray-dev libbluray1 libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcec-dev libcec1 libcrystalhd-dev libcrystalhd3 libcurl3 libcurl4-gnutls-dev libcwiid-dev libcwiid1 libdbus-1-dev libenca-dev libflac-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev libltdl-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmp3lame-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpostproc-dev libpulse-dev libsamplerate-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libshairport-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libswscale-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libva-dev libva-egl1 libva-tpi1 libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite unzip yasm zip zlib1g-dev


    cd $HOME/kodi
    git clone -b Helix git://github.com/xbmc/xbmc.git
    cd xbmc
    ./bootstrap
    apt-get remove libtag1-dev
    make -C lib/taglib
    make -C lib/taglib install
    ./configure
    make
    make install


    apt-get install xorg


    NVIDIA DRIVER (download from nvidia website (use wget)):
    sh ./NVIDIA-Linux-x86_64-346.72.run


    CREATE a conf file for Xorg for the display:
    nvidia-xconfig
    cp XF86Config xorg.conf


    Launch Kodi
    xinit /usr/bin/kodi-standalone -- -nocursor :0


    Hope this helps someone :-)


  • Ok...now that I have used the official repo everything is great.
    Version 14.2


    Airplay still ko on IOS 8.3 but the rest is OK.


    Source:


    https://people.debian.org/~rbalint/ppa/xbmc-ffmpeg/

  • Need help!


    Here are my specs: OMV 2.1 (Deb Wheezy) on GA-A75M-UD2H board and A8-3870 (=Radeon 6550D).
    Installation seems to work fine. Then:


    xinit kodi gets me


    I get:
    X.Org X Server 1.12.4Release Date: 2012-08-27X Protocol Version 11, Revision 0Build Operating System: Linux 3.16.0-4-amd64 x86_64 DebianCurrent Operating System: Linux omv 3.2.0-4-amd64 #1 SMP Debian 3.2.68-1+deb7u2 x86_64Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-4-amd64 root=UUID=ec22f430-8da0-43d4-b649-1f21b6ea8757 ro quietBuild Date: 09 February 2015 09:46:52AMxorg-server 2:1.12.4-6+deb7u6 (Julien Cristau <jcristau@debian.org>)Current version of pixman: 0.26.0 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 30 20:06:15 2015(==) Using config directory: "/etc/X11/xorg.conf.d"(==) Using system config directory "/usr/share/X11/xorg.conf.d"(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) foundThe XKEYBOARD keymap compiler (xkbcomp) reports:> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols> Ignoring extra symbolsErrors from xkbcomp are not fatal to the X serverxinit: connection to X server lost

    waiting for X server to shut down .Server terminated successfully (0). Closing log file.


    I am a novice at all of this. Is it a driver issue? I followed the instructions at wiki.debian.


    Can anyone help?
    Best wishes, Olli

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!