Kodi (formerly XBMC) for OMV - test phase

  • Great !! Amazing !!
    XMBC in OMV is the most thing i'm waiting !

    My OMV is installed on a SSD and my datas are on a HDD, if you could give the possibility to mount and HDD on the plugin, that's would be very helpfull :)

    It would work with an APU AMD A45300 ?

    Congrats !

  • Thanks for these instructions !

    I replaced this line :
    apt-get install xorg xserver-xorg-video-intel libva-intel-vaapi-driver

    apt-get install xorg xserver-xorg-video-ati

    and i followed these instructions for the propieraty drivers AMD/ATI :

    Everything is OK but you need to correct this line:
    ./make install

    and ./make install
    sudo make install

    At the end, everything works perfectly !! :D

    But ... I don't have sound, the NAS is connected on my TV over HDMI

    Do I have to install ALSA ?


  • Hi. Thx for guide. It work like a charm.
    But i have problem with autostart kodi on my nuc.

    Omv runs.
    But i don't understand well how run kodi at startup.
    1 point from this site http://kodi.wiki/view/HOW-TO:Autostart_Kodi_for_Linux
    not work well.
    I change exec su -c "xinit /usr/bin/xbmc --standalone -- -nocursor :0" $USER
    to exec su -c "xinit /root/kodi --standalone -- -nocursor :0" $USER
    where i compile all.

    Please help me

    PS. Sorry for my english.

  • For autostart kodi at startup try only step 3 from that page 3. Add a new init script
    and change this on script

    # user


    # user

    and ofcourse

    # startup args
    DAEMON_OPTS=" /usr/local/bin/xbmc --standalone -- :0"

    with path to xbmc

  • Hi there!

    I just tried to install kodi on openmediavault but it turnoud out that after trying to start kodi with "xinit kodi" I get an error stating that there were no Screens found.
    I have an Intel HD4600 (Xeon 1225v3) iGPU. All the steps of the tutorial were completed without any errors until I came to "xinit kodi"


    Fatal server error:
    no screens found


    Does anyone have a clue why I get this?

    I tested it previously on a VM (Virtual Box). I had the same issue in a VM (Host: Win 8.1 on same Hardware) but after I installed the vm addins from the CD Image I was able to start kodi from the VM without any issues anymore.
    Did I miss something regarding any intel HD drivers? Because in the list of the Graph Chips supported in the Log File there are no Haswell iGPU Models listed! So maybe the driver doesent support the HD4600 ?

    Thank you in advance!

  • I tried to solve the issue by myself and came across that the
    standard intel dirvers from the wheezy repo doesent support haswell
    iGPUs. So I installed them from the wheezy backports with :

    apt-get install -t wheezy-backports xserver-xorg-video-intel

    Now I get following error with following Log when trying to run "xinit kodi":


    > Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
    > Ignoring extra symbols
    Errors from xkbcomp are not fatal to the X server
    Unrecognized deviceID 0x41a
    xinit: connection to X server lost

    Xorg.0.log is too long for a port here so I pasted it to pastebin. Her the Link:

    it seems that now the Intel HD4600 is stated to be supported (see at
    the beginning of the LOG) but for some reason it will not work. I also
    restarted but it didn't work.
    So I am also reading a lot that with
    Debian Testing (Jessie) it works but there should be a solution with
    wheezy. If OMV would work on Jessie I would try that..

    Thank you!
    Greetings from germany!

  • i think it's from old kernel...you need to update to backport kernel to newer version ... if its posible ...

    i don't have posibility to test now

    or try experimental xserver-xorg-video-intel to install

    You can add the experimental repo and install with:
    apt-get install xserver-xorg-video-intel/experimental

  • I updated already to the 3.16.0-0.bpo.4-amd64 before I followed the Steps in the Tutorial.
    I will definately try to install the experimental intel drivers an then recompile kodi..

    try to uninstall kodi, clean meake and compile again with newest drivers


    Thanks for your hint. I did not try that!
    I will install OMV again because I messed too much with all these repos, installs, Xorg configs etc around..
    Clean install -> Clean update to Backport Kernel (from WebUI) -> Install of the backport/experimental drivers -> Compile Kodi -> Cross my fingers -> "xinit kodi" :)

    Thanks for your help
    and greetings from germany

  • tested before this new installation old XBMC version and that is very slow ( running with CPU to 100% )

    I have installed a new OVM version ( openmediavault_0.5.48 i386 ) for running XBMC / KODI

    OVM run no problem

    for using KODI i have read thread for compile :
    The Guide to the Guides section:
    Kodi (formerly XBMC) for OMV
    omv-update ( no problem )
    apt-get install python-software-properties pkg-config ( also no problem )

    apt-get install software-properties-common ( cannot found packet )

    same error with amd64 version ( openmediavault_0.5.48_amd64.iso )

    have you info for this error ?



    After for : apt-get install automake autopoint ... i have also many errors

  • Hello.

    I have the problem to compile kodi.

    In the guide stand

    make -C lib/taglib
    make -C lib/taglib install
    make install

    But on bootstrap nothing happend.

    # ./bootstrap
    -bash: ./bootstrap: Keine Berechtigung

    and so on... whats my failur? ^^"

  • A lot of times, you get that error if the file is not executable (chmod +x) or you are not running as root (may be necessary).

    omv 5.5.6 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!