BTRFS support, mount options

  • Hi there,


    I could quite easily mount a BTRFS-formatted storage disk with OMV, after having installed a 3.16 backport kernel, and a newer btrfs-tools right outa Jessie.


    The only thing is that I'd like OMV to mount the BTRFS volume using the "noatime,compress=lzo" options, but I haven't found a way to specify this in OMV, except for manually editing fstab.


    The matter is that, if manually editing fstab, as soon as OMV will modify it again (ie when mouting an USB device from OMV), it will remove these additional mount options ?(


    So I'd like to know if there curently is any way I could specify these options, and OMV keeps it - I have no problem if it involves manual edition of a config file.


    TIA.

    • Official Post

    There use to be global environmental variables before in 0.5 to define extra options like OMV_FSTAB_MNTOPS_EXT4="noatime,noexec, etc"


    Now i don't see them any more or work, so only option i see is edit config.xml add the extra options there, then run omv-mkconf fstab, and reboot or remount the filesystem


    maybe @votdev can put it more clear if there is another clean way, because editing the config.xml the changes will get lost when you unmount the disk through the webUI

    • Official Post

    Those options are in /usr/share/php/openmediavault/globals.inc now. But that file will be overwritten when you update OMV.

    omv 7.0-32 sandworm | 64 bit | 6.5 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.7 | compose 7.0.8 | cputemp 7.0 | mergerfs 7.0.2


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I believe that, for BTRFS, you should at least use "noatime" in the OMV defaults, as it is strongly advised to always use "noatime" with BTRFS, with a penalty of terrible access times if not.
    And anyway, on a NAS volume, it's higly probable that nobody would need atime (and any BTRFS user hates it ;)
    It might be advisable to also use "compress=lzo" as a default.


    My line will read:
    OMV_FSTAB_MNTOPS_BTRFS="noatime,compress=lzo,nofail"

    • Official Post

    Adding OMV_FSTAB_MNTOPS_BTRFS to /etc/default/openmediavault should work. Additional omv-engined must be restarted and the filesystem must be mounted via WebGUI after the previous procedure.
    If this does not work, you can modify the <opts> attribute in the config.xml file for the BTRFS filesystem <mntent> entry. If config.xml is modified a 'omv-mkconf fstab' must be executed.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!