openmediavault

The open network attached storage solution

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

News

  • New

    Well, the title pretty much says it all.
    Some details:
    I have a raidz1 on top of 5x1TB LUKS encrypted disks.
    It's still a test machine, but has been working well for the last couple of weeks.
    The disks are automatically decrypted at boot time, using /etc/crypttab with a remote access-restricted keyfile. There is also a small script I wrote in order to solve github.com/OpenMediaVault-Plug…nmediavault-zfs/issues/27. Nothing fancy.
    Even tough I Installed the luks and zfs plugins, I use them basically for monitoring purposes; most, if not all, of the work is done by CLI.
    The disk usage tab shows the pool and updates correctly but I can't get the Disk I/O to show. This isn't really a deal breaker, but still...
    I did stumble upon Disk usage tab for my ZFS pool has vanished from GUI ! but, to be honest, didn't really grasp all of it.
    dmesg, journalctl -b and syslog all refuse to comment at this time...

    Any clues or troubleshooting tips?
    Best regards,
    Carlos
  • New

    I use a rotating system of 3 external drives for backups. With the upgrade from OMV3->OMV4 I migrated my data to a encrypted (LUKS), redundant ZFS-pool. I do snapshots daily, scrubs monthly, backups weekly, one of the backup diks is always out of my house to have separation.

    For backups I use the USB backup plugin. I thought about encrypting my backups as well to have theft security. Setting up a encrpted device prevents me from selecting it as backup target within USB backup plugin. Is there a solution to use encryption with the plugin?

    Want to unlock my backup drives within GUI through password, after that the rsync job of backup plugin should start.
  • New

    Hello,

    I am working on making my server be automated without needing much attention and I am trying to get the S.M.A.R.T notification to work but I am having issues.

    Attached is my configuration of the notification config, I followed OMV's official guide using the Google SMTP server. (obviously I've added my information in where the generic information is shown)


    Attached are the issues I am seeing in the syslog.

    Any suggestions/ides would be greatly appreciated.

Unread Threads

Topic Replies Last Reply

Permission / user issues and syncthing/plex

6

GTvert90

Encrypted Backup

2

jcd

Sonarr And NZBGet Stopped Talking - JSonRPC ReceiveFailure

2

bbddpp

Receiving Mount/Unmount Errors When Changing Shared Folders Settings - Help?

0

Folder Permissions

13

Currymunster

Recent Activities

  • utamav -

    Liked ryecoaaron’s post in the thread OMV 3.x Resolved How to restore from backup.

    Like (Post)
    Quote from utamav: “I don't see fsarchive on OMV 4.x. After installing the extra's for OMV 4.x, I only see OPENMEDIAVAULT-BACKUP 3.11. I am missing anything? I am planning to setting up a new server and want to be plan it better than my current setup.…
  • GTvert90 -

    Replied to the thread OMV 3.x Permission / user issues and syncthing/plex.

    Post
    Quote from ryecoaaron: “sudo usermod -a -G users plex should work ” DIdn't work. Still have to change permission on the file to give others read access
  • jcd -

    Replied to the thread OMV 4.x Encrypted Backup.

    Post
    It isn't that hard to build a own script! I wanted to backup my data to a overlay filesystem (mergerfs), but that didn't work with the USB Backup plugin. So I had to build something on my own. (Backup to multiple disks) You would have to: 1) create…
  • bbddpp -

    Replied to the thread Sonarr And NZBGet Stopped Talking - JSonRPC ReceiveFailure.

    Post
    Still having this issue, bumping in case anyone else is as well. Radarr is fine. Sonarr running in a docker on openmediavault, even after updating the docker container, is throwing jsonrpc errors trying to reach NZBGet. Radarr with the same settings is…
  • Currymunster -

    Replied to the thread OMV 4.x Folder Permissions.

    Post
    It seems to have fixed its self after a reboot and now all updates are done and finished. back to the folders and I still need to see the videos.
  • antipiot -

    Replied to the thread OMV 4.x Errors were encountered while processing: openmediavault-sickbeard.

    Post
    Hello! Thanks for your relply: In the meantime: fixed it using: Source Code (3 lines)
  • Currymunster -

    Replied to the thread OMV 4.x Folder Permissions.

    Post
    That worked a treat but threw up another fault. invalid rpc - error report below. Error #0:OMV\Rpc\Exception: Invalid RPC response. Please check the syslog for more information. in /usr/share/php/openmediavault/rpc/rpc.inc:186Stack trace:#0…
  • cskrat -

    Replied to the thread OMV 4.x Update RPI dependency issues with latest php7.0 7.0.30-0+deb9u1 (and their dependent packages).

    Post
    This is... ugly but seems to have worked. apt-get install php7.0-common=7.0.30-0+deb9u1 openmediavault openmediavault-flashmemory openmediavault-netatalk openmediavault-omvextrasorg php-bcmath php-cgi php-fpm php-mbstring php-pam php-xml
  • Eryan -

    Replied to the thread Openvpn as server and client.

    Post
    Quote from subzero79: “Yes. Just place the client config file at /etc/openvpn folder. ” My apologies for bringing back this thread from the dead, but I am facing a similar scenario but I am not sure that I follow your idea. First, when you refer to…
  • macom -

    Replied to the thread OMV 4.x Folder Permissions.

    Post
    It is a problem with DNS server. The server name cannot be resolved. The IP address of the router goes in gateway and in DNS server. Also add 1.1.1.1 to DNS server. Netmask is 255.255.255.0 Disable IPv6