openmediavault

The open network attached storage solution

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

News

  • New

    Hey guys,

    I wondered why there are two cron configs for my openmediavault-letsencrypt plugin. Is letsencrypt using the certbot and therefore dependent on this certbot cron config? Or is this just by accident one of them is redundant?
    I haven't installed the certbot actively.

    Shell-Script: openmediavault-letsencrypt

    1. @monthly root omv-rpc "LetsEncrypt" "generateCertificate" "{\"command\":\"renew\"}" >/dev/null 2>&1

    Shell-Script: certbot

    1. 0 */12 * * * root test -x /usr/bin/certbot -a \! -d /run/systemd/system && perl -e 'sleep int(rand(43200))' && certbot -q renew
    Hopefully someone knows!
  • New

    Hello board,

    I have the follwing setup:
    - a mergerfs pool
    - a sharedfolder Videos in this pool
    - this sharedfolder is used as a NFS share

    Then my emby server (in another VM) is relying on this NFS share. And my android Emby app is supposed to access in direct to the movie through the NFS share.

    My problem is: the nfs share doesn't work unless I reset the permissions (using the resetperm plugin) to pure POSIX rights.

    But somehow, every now or then (no idea of the frenquency yet - couple of hours maybe?), the ACL reappear and break the NFS share again. I have to reset the permissions and it instantly works again.

    Is there a way to debug this?

    Is there a permanent swith to disable the ACL and prevent them from reappearing once and for good?

    Thanks a lot!

    Edit: it may happen after one scheduled rsync job (local) is run.
  • New

    Hi I'm attempting a fresh OMV 4 install from scratch from a previous OMV 3.x updated install. I have an SSD for the OS and 5 HD's formatted with ext4 in the previous OMV version. Note no RAID. After the successful OMV 4 install I've noticed all drives are visible in the Physical Disks table but two drives are missing in the File Systems folder. No matter what I try, I can't get these drives in the file system and then mounted.
    I've tried:
    1. Multiple re-installs
    2. Manually created an entry in fstab and mounted successfully, but this vanishes with reboot
    3. "Create" file system: tried to recreate the file system wiping out all my old files. Formatting looks like it's working with Status=Initializing, but when done the entry vanishes again

    I'm out of ideas. Any guidance would be greatly appreciated.
    Thanks
    Kris
  • New

    Hello, I'm using for some months ARRAKIS beta (now 4.1.0-1) and it works good.
    I have installed also OMV-extras.org stable repo, plexmediaserver repo and some plugins.
    Now OMV 4 become stable (4.1.3 in this moment) so I'd like switch to stable version.
    I must change repositories? How is the correct way of doing the switch from beta to stable without loosing my data and my OMV configuration?
    Thanks a lot for the help

    Ciro
  • New

    hello there, so i was tinkering with setting up a Web File Manager/explorer in docker (with something called FilleRun) and i made a softlink of / in / (root?) and now when i try to login to OMV Web UI it gives me: Failed to connect to socket: Permission denied

    when i login to CLi through SSH and try to run a command with SUDO (say: sudo nano) it gives me

    Source Code

    1. sudo: /etc/sudoers is owned by uid 33, should be 0
    2. sudo: no valid sudoers sources found, quitting
    3. sudo: unable to initialize policy plugin




    what did i f*ck up? and is there a fix to this?

    sorry for wasting your time :)
    regards


    edit: i can still login through SSH with ROOT and my USER

    edit 2, after reebooted the system i got a white page with this when trying to access webUI

Unread Threads

Topic Replies Last Reply

Why is there a certbot AND letsencrypt config file in /etc/cron.d/certbot?

0

[HOWTO] Instal ZFS-Plugin & use ZFS on OMV

744

MasterChillerX

Raid5 will no longer mount - can't read super block

4

krimson

openmediavault-transmissionbt 3.0.9 rpc-password issue

5

Forgeron

Docker

8

subzero79

Recent Activities