Strange devices on File Systems and Volume problem on Shared Folders

    • OMV 1.0
    • Resolved
    • Strange devices on File Systems and Volume problem on Shared Folders

      Hello people,

      I need some help, appreciate the attention.

      After upgrade 0.5 to 1.0, the file system had a problem. Devices list shows in the fist two lines stranges devices with no label and status 'missing', one of them unable to delete:



      Also, on shared folders i was unable to create or edit folder because the volume field don't shows any volume option.



      I checked /etc/fstab and looks normal:

      Source Code

      1. # /etc/fstab: static file system information.
      2. #
      3. # Use 'blkid' to print the universally unique identifier for a
      4. # device; this may be used with UUID= as a more robust way to name devices
      5. # that works even if disks are added and removed. See fstab(5).
      6. #
      7. # <file system> <mount point> <type> <options> <dump> <pass>
      8. proc /proc proc defaults 0 0
      9. # / was on /dev/sda1 during installation
      10. UUID=9d364aa1-4a89-4b33-b7f4-cf49821e50ad / ext4 errors=remoun$
      11. # swap was on /dev/sda5 during installation
      12. UUID=57b00ca2-85b9-453d-8a35-3cc18f795384 none swap sw $
      13. /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
      14. tmpfs /tmp tmpfs defaults 0 0
      15. # >>> [openmediavault]
      16. /dev/disk/by-uuid/CE2AEBB62AEB99AB /media/CE2AEBB62AEB99AB ntfs defaults,nofail$
      17. /dev/disk/by-uuid/9E988DF7988DCDE9 /media/9E988DF7988DCDE9 ntfs defaults,nofail$
      18. # <<< [openmediavault]
      Display All


      I don't know if there is a relation, but when i do changes, some times the webgui shows to me the following error:

      Failed to execute command 'export LANG=C; apt-get --yes --auto-remove --purge remove openmediavault-owncloud 2>&1': Reading package lists... Building dependency tree... Reading state information... The following packages will be REMOVED: libcurl3* libmcrypt4* librtmp0* libssh2-1* openmediavault-owncloud* owncloud* php-xml-parser* php5* php5-curl* php5-gd* php5-intl* php5-mcrypt* php5-pgsql* php5-sqlite* 0 upgraded, 0 newly installed, 14 to remove and 0 not upgraded. After this operation, 100 MB disk space will be freed. (Reading database ... 43385 files and directories currently installed.) Removing openmediavault-owncloud ... Purging configuration files for openmediavault-owncloud ... Site configuration file 'openmediavault-owncloud' not found. dpkg: error processing openmediavault-owncloud (--purge): subprocess installed post-removal script returned error exit status 1 Removing owncloud ... Purging configuration files for owncloud ... dpkg: warning: while removing owncloud, directory '/var/www/owncloud/data' not empty so not removed dpkg: warning: while removing owncloud, directory '/var/www/owncloud/config' not empty so not removed Removing php5-curl ... Purging configuration files for php5-curl ... Removing libcurl3:i386 ... Purging configuration files for libcurl3:i386 ... Removing php5-mcrypt ... Purging configuration files for php5-mcrypt ... Removing libmcrypt4 ... Purging configuration files for libmcrypt4 ... Removing librtmp0:i386 ... Purging configuration files for librtmp0:i386 ... Removing libssh2-1:i386 ... Purging configuration files for libssh2-1:i386 ... Removing php-xml-parser ... Removing php5 ... Removing php5-gd ... Purging configuration files for php5-gd ... Removing php5-intl ... Purging configuration files for php5-intl ... Removing php5-pgsql ... Purging configuration files for php5-pgsql ... Removing php5-sqlite ... Purging configuration files for php5-sqlite ... Processing triggers for openmediavault ... Restarting engine daemon ... Processing triggers for php5-fpm ... Restarting PHP5 FastCGI Process Manager: php5-fpm . Errors were encountered while processing: openmediavault-owncloud Creating index of upgradeable packages ... Creating index of OpenMediaVault plugins ... E : Sub-process /usr/bin/dpkg returned an error code (1) Error #4000: exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --yes --auto-remove --purge remove openmediavault-owncloud 2>&1': Reading package lists... Building dependency tree... Reading state information... The following packages will be REMOVED: libcurl3* libmcrypt4* librtmp0* libssh2-1* openmediavault-owncloud* owncloud* php-xml-parser* php5* php5-curl* php5-gd* php5-intl* php5-mcrypt* php5-pgsql* php5-sqlite* 0 upgraded, 0 newly installed, 14 to remove and 0 not upgraded. After this operation, 100 MB disk space will be freed. (Reading database ... 43385 files and directories currently installed.) Removing openmediavault-owncloud ... Purging configuration files for openmediavault-owncloud ... Site configuration file 'openmediavault-owncloud' not found. dpkg: error processing openmediavault-owncloud (--purge): subprocess installed post-removal script returned error exit status 1 Removing owncloud ... Purging configuration files for owncloud ... dpkg: warning: while removing owncloud, directory '/var/www/owncloud/data' not empty so not removed dpkg: warning: while removing owncloud, directory '/var/www/owncloud/config' not empty so not removed Removing php5-curl ... Purging configuration files for php5-curl ... Removing libcurl3:i386 ... Purging configuration files for libcurl3:i386 ... Removing php5-mcrypt ... Purging configuration files for php5-mcrypt ... Removing libmcrypt4 ... Purging configuration files for libmcrypt4 ... Removing librtmp0:i386 ... Purging configuration files for librtmp0:i386 ... Removing libssh2-1:i386 ... Purging configuration files for libssh2-1:i386 ... Removing php-xml-parser ... Removing php5 ... Removing php5-gd ... Purging configuration files for php5-gd ... Removing php5-intl ... Purging configuration files for php5-intl ... Removing php5-pgsql ... Purging configuration files for php5-pgsql ... Removing php5-sqlite ... Purging configuration files for php5-sqlite ... Processing triggers for openmediavault ... Restarting engine daemon ... Processing triggers for php5-fpm ... Restarting PHP5 FastCGI Process Manager: php5-fpm . Errors were encountered while processing: openmediavault-owncloud Creating index of upgradeable packages ... Creating index of OpenMediaVault plugins ... E : Sub-process /usr/bin/dpkg returned an error code (1) ' in /usr/share/openmediavault/engined/rpc/pluginmgmt.inc:174 Stack trace: #0 [internal function]: OMVRpcServicePluginMgmt->remove(Array, Array) #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('remove', Array, Array) #3 /usr/sbin/omv-engined(501): OMVRpc::exec('Plugin', 'remove', Array, Array, 1) #4 {main}

      What do i do?

      Cheers!
      Images
      • SHARED-FOLDERS-NO-VOLUME-.png

        25.82 kB, 679×426, viewed 1,065 times
      • FILE-SYSTEMS.png

        39.53 kB, 1,074×289, viewed 1,121 times
      Rodolfo Peres Rodrigues
      Goiânia/GO - Brasil
    • First of all, do a Logupload. See my Signature for how to do that.

      The missing hard drives are probably removed by you without unmounting them first. Since 1.0 you can remove them nevertheless, if they are removed from the services before. So you have to go through all services and look where it may referes to your hard drive (actually it will refer to shared folders that are on that drives).

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • The filesystem listing issue will be fixed in openmediavault 1.0.32.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Thanks davidh2k, here it is: O8j2WzjY

      Just another detail, the folders i already shared are working properly on the net despite of the fact there is no data on 'Volume' column. See:

      Images
      • SHARED-FOLDERS-NO-VOLUME-COLLUM.png

        18.51 kB, 612×184, viewed 883 times
      Rodolfo Peres Rodrigues
      Goiânia/GO - Brasil
    • This filesystem issue is exclusively coming from NTFS drives, it will be fixed in the next release, as i've already tested the patch.
      If you're planning using those ones as permanent OMV drives, consider formatting those to a native linux file system . It will give you less problems with permissions and mounting.
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • 1.0.32 is out. Please update and report, if your problems are solved.
      Thx
      "Glowing days. Don't cry because they are over. Smile because they happened." - Confucius

      Server: 1x 32GB SSD (system) - 5x 2TB Data - 1x 2TB Snapraid-Parity - latest OMV 1.x
      No Support through PM
      Tutorials --- Howto install OMV-Extras --- Upgrade/Update-Problems --- If autoshutdown doesn' -work
    • Same Problem here

      Hello,

      I should surely post in wrong sub-forum, but I got the same problem. I m using a virtualized omv on Citrix XenServer. My volume is /dev/xvda. It's a VHD on LVM and it use ext4.
      For the instant I m configuring my share by hand, but it would be easier and faster with the webUI

      Thanks you for your help

      Tiki

      PS : here come my log ID : js1tgSzn . Not sure it ll work as i had a error message ( too long )
    • Ok.
      According to BugTracker( ty votdev), it's not a bug, it' a feature !
      The root filesystem is not accessible for data.
      So, I 'm using a NAS (ix2-200) with a nfs server. I created a mountpoint in omv/root filesystem ( like /media/nfs) and accessing by console ( ssh ). So i wanted to create share through omv and not using the builtin nas shares options.
      Without additionnal storages attached to my XenMachine, I ll have to find another way or make my shares manually.

      Thank you for your help.

      Tiki

      The post was edited 1 time, last by Tiki ().

    • If you can make a second partition on your drive, that'll work too.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Hi,

      Thank you. I already attached a second VHD to my omv machine and made my mountpoint on it.
      Now I ll search a way to install my 1TB hard disk extracted from my old physical server and add it to:
      - add it to my xenserver w/o data loss ( not too hard )
      - add it to omv still w/o datas loss

      But it ll be for another thread :D

      Tiki