Updating from 3.0 to 4.0

    • OMV 3.x
    • Upgrade 3.x -> 4.x
    • Updating from 3.0 to 4.0

      New

      Hi,

      I have finally made the decision to try to update from 3.0 to 4.0, I will take an exact copy of the OMV disk to be sure that I can go back.
      These are the plugins I have installed (the rest I have migrated to Docker):
      • openmediavault-backup 3.11
      • openmediavault-rsnapshot 3.12
      • openmediavault-transmissionbt 3.0.9
      • openmediavault-unionfilesystems 3.1.17
      • openmediavault-mysql 3.0.4
      • openmediavault-fail2ban 1.3.1
      • openmediavault-nginx 3.0.11
      • openmediavault-letsencrypt 3.4.5
      • openmediavault-resetperms 3.3
      • openmediavault-locate 3.4
      • openmediavault-cups 3.1.2
      • openmediavault-omvextrasorg 3.4.32
      • openmediavault-docker-gui 3.1.10


      I have found all these plugins in the OMV 4.0 Plugin list. Is there anything else I need to do to ensure it goes smooth?
      Or can I just update without the risk of breaking everything?

      Thank you!
    • New

      I went in to the Update Management section, and selected everything and pressed Update to prepare for the big upgrade to 4.0.

      It did update some of the stuff, but ended with 502 error, and now I cannot access the Web GUI of OMV. It seems to work in the background, but the GUI is unreachable.
      Checked omv-firstaid and the webgui-ports are correct.

      I get this error when trying to restart nginx:

      Source Code

      1. Restarting nginx (via systemctl): nginx.serviceJob for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details. failed!
      EDIT: Fixed this!

      The post was edited 1 time, last by joq3 ().

    • New

      joq3 wrote:

      Will it be safe to update without loosing anything from these plugins?
      The cups plugin on OMV 4.x is problematic. I would move cups, transmissionbt, and mysql to docker. Probably even nginx. The rest should be ok.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      ryecoaaron wrote:

      joq3 wrote:

      Will it be safe to update without loosing anything from these plugins?
      The cups plugin on OMV 4.x is problematic. I would move cups, transmissionbt, and mysql to docker. Probably even nginx. The rest should be ok.
      Removed Cups.
      Does Transmission, mysql and nginx have issues too?

      Moving these to Docker, is there any easy way to backup and restore from settings?
    • New

      joq3 wrote:

      Does Transmission, mysql and nginx have issues too?
      Not sure about transmission
      some people have issues with mysql because Debian 9/OMV 4.x uses mariadb not mysql. The root user behavior also changes.
      nginx doesn't really have any issue but it won't be ported to OMV 5.x in favor of using docker.

      forum.openmediavault.org/index…?postID=186122#post186122


      joq3 wrote:

      Moving these to Docker, is there any easy way to backup and restore from settings?
      No idea about transmission.
      mysql is easy in my opinion (use mysqldump) but not everyone would think that.
      nginx will be a bit of work.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      Just performed the upgrade.
      Got this error in the end:

      Source Code

      1. Restarting engine daemon ...
      2. Cannot create socket to [localhost]:2812 -- Connection refused
      3. Updating locale files ...
      4. Updating file permissions ...
      5. Purging internal cache ...
      6. Errors were encountered while processing:
      7. fail2ban
      8. E: Sub-process /usr/bin/dpkg returned an error code (1)


      But no worries, did a reboot, and was able to login to OMV.
      Then I got this error (right after logging in):

      Source Code

      1. Error #0:
      2. OMV\Rpc\Exception: Invalid RPC response. Please check the syslog for more information. in /usr/share/php/openmediavault/rpc/rpc.inc:186
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('UnionFilesystem...', 'getList', Array, Array, 3)
      5. #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      6. #2 {main}

      Pressed OK, and was able to disable fail2ban, if it was causing issues. Did not help.
      Then went to Update management, seemed to install most of it, but ended with an Error (no specific error, just text in the log).

      Went into OMV-Extras, to remove the Mono repo (as I don't use Sonarr/Radarr as a plugin any more). After deleting, and pressing Apply, I get this error:

      Source Code

      1. Error #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-mkconf omvextras 2>&1' with exit code '2': Warning: apt-key output should not be parsed (stdout is not a terminal)
      3. Executing: /tmp/apt-key-gpghome.kDSAFfcCI4/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 9dc858229fc7dd38854ae2d88d81803c0ebfcd88
      4. gpg: failed to start the dirmngr '/usr/bin/dirmngr': No such file or directory
      5. gpg: connecting dirmngr at '/tmp/apt-key-gpghome.kDSAFfcCI4/S.dirmngr' failed: No such file or directory
      6. gpg: keyserver receive failed: No dirmngr in /usr/share/php/openmediavault/system/process.inc:182
      7. Stack trace:
      8. #0 /usr/share/openmediavault/engined/module/omvextrasorg.inc(34): OMV\System\Process->execute()
      9. #1 /usr/share/openmediavault/engined/rpc/config.inc(168): OMVModuleOmvExtras->applyConfig()
      10. #2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      11. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      12. #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      13. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusVG...', '/tmp/bgoutputXX...')
      14. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      15. #7 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      16. #8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      17. #9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      18. #10 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      19. #11 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      20. #12 {main}
      Display All

      So right now there are errors left and right, and I have no idea why?

      EDIT: This is my repos:
    • Users Online 1

      1 Guest