HDD spin down doesn´t work. Please help a newbee.

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • HDD spin down doesn´t work. Please help a newbee.

      Hello guys,

      sorry for my bad english, but I hope you understand my problem. My native language is german, if anybody could give me a hint in german it would also be nice.

      Now to my problem. I installed OMV 5.2.2-1 on my raspberry pi3 and in combination with that I use a Western Digital 3TB My Book USB HDD as storage. The NAS should only store once a day pictures and videos from my wives and my own smartphone, so that the working time for the HDD is only a couple of minutes a day. After that the HDD should spin down or go to standy. For this reason I installed HD-Idle and configured it as good as I understood the online manuals. Now is my problem that the HDD sometimes go to sleep but after a while they wake up without any reason. Normally they should go to sleep after 30 minutes but sometimes it needs much more time. I have installed all these things sice two days and will observe it the next days but have anybody a hint how could I find out why the system wake up and how can I check if HD-Idle work correct?

      Thanky in advance.

      The post was edited 1 time, last by KaeptnBlaubaer ().

    • I think I found out that the HDD spin down but they wake up frequently. After I read some more threads I found these two commands in this thread.

      Shell-Script

      1. sudo systemctl disable smartd.service
      2. sudo service smartd stop

      I don´t know how and why but for the moment it seems to work. Only one little thing, I thought that I set the spin down time after 10 minutes but it seems to be after 20 minutes, but thot is no big issue for me if the rest works fine.
    • You set the spindown time using the WD setup software. It seems there is some management software that can be downloaded from WD. Try that. Check the WD support pages for the drive to find the downloads, I assume?

      Naturally you also need to ensure nothing use the drive for it to spin down. No media streamer software updating the database or scheduled SMART tests.

      It may shorten the life of the drive to spin it up/down often.
      OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4
    • Adoby wrote:

      You set the spindown time using the WD setup software. It seems there is some management software that can be downloaded from WD. Try that. Check the WD support pages for the drive to find the downloads, I assume?

      Naturally you also need to ensure nothing use the drive for it to spin down. No media streamer software updating the database or scheduled SMART tests.

      It may shorten the life of the drive to spin it up/down often.
      Thank you for your response. I only set the spin down time in HD-IDLE, I will try the WD software. I hope that it works with windows in combination with the EXT4 formatted HDD.

      I know that spin up and spin down will shorten the lifetime but at the moment will only spin up and down once a day. In future I will extend it to once or twice a week. The working time for the HDD is only a couple of minutes a day.
    • Adoby wrote:

      You set the spindown time using the WD setup software. It seems there is some management software that can be downloaded from WD. Try that. Check the WD support pages for the drive to find the downloads, I assume?

      Naturally you also need to ensure nothing use the drive for it to spin down. No media streamer software updating the database or scheduled SMART tests.

      It may shorten the life of the drive to spin it up/down often.
      I checked the WD setup software and with this it is possible to set a sleep time. Now I disabled the sleeptimer from the HDD and HD-IDLE seems to work pretty well. But now I am not sure which option is better, to spin down the HDD with HD-IDLE or should I use WD internal sleep timer. For me work both very well and I don´t know if there is one option better for the system.