openmediavault-docker-gui Testing

  • Got following error after installing both test and stable repositories.


    Error #0:exception 'OMVModuleDockerException' with message 'Error: "couldn't connect to host" - Code: 7' in /usr/share/omvdocker/Utils.php:63Stack trace:#0 /usr/share/omvdocker/Utils.php(125): OMVModuleDockerUtil::doApiCall('http://localhos...')#1 /usr/share/openmediavault/engined/rpc/docker.inc(145): OMVModuleDockerUtil::getImages('42005', true)#2 [internal function]: OMVRpcServiceDocker->getImages(Array, Array)#3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getImages', Array, Array)#5 /usr/sbin/omv-engined(500): OMVRpc::exec('Docker', 'getImages', Array, Array, 1)#6 {main}


    if i run "docker daemon" gives me below error
    Your Linux kernel version 3.2.0-4-amd64 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer

  • Your Linux kernel version 3.2.0-4-amd64 is not supported for running docker.

    You have to install the backports kernel (button in omv-extras) on OMV 2.x to use the docker plugin.

    omv 5.6.2 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • don't know what happened, but tried re-installing the backports and problem is solved. cheers ryecoaaron...


    just one question please.
    I have openkm running which uses the omv mysql plugin.
    i also have plexmedia plugin.


    - what would i use docker instead of the plugins?
    - as regards zoneminder which uses sql. wouldn't it be better to install outside of docker and use the existing mysql?

  • what would i use docker instead of the plugins?

    One of the best uses of docker is when you need libraries that are newer than what is available on the version of OMV you are using. You might also use it if you want the service in a jail so nothing on the host system could accessed (unless you allow it). For things that have a plugin and docker available, I guess it is just personal preference.


    as regards zoneminder which uses sql. wouldn't it be better to install outside of docker and use the existing mysql?

    You could use zoneminder in a docker and attach to mysql running on OMV.

    omv 5.6.2 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    I just had the problem, that after reboot, docker ps showed no images anymore.
    I went to the Web-Interface and found that it was complaining that it got no response at port 2375. That's a bit odd, as docker listens on port 2376.
    So, I corrected that.


    After applying the changes, I got:


    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; rm --recursive --force '/var/lib/docker/openmediavault' 2>&1' with exit code '1': rm: cannot remove
    '/var/lib/docker/openmediavault/btrfs/subvolumes/6b9a92b2ae4c362d47af7758d6508afe805e466266fab8fe2ec97f3d2b688875': Operation not permitted rm: cannot remove
    '/var/lib/docker/openmediavault/btrfs/subvolumes/6040cbfcf734b0c1cf58d9253898f4bc4fe47804e094e8e7ce57095448cf9696-init': Operation not permitted rm: cannot remove

    This is a problem in two senses:
    1) I do not think that anything should be deleted here.
    2) rm fails, as the subvolumes are actually btrfs subvolumes. Here, I think the plugin must distinguish between btrfs and aufs as file-system. In case of btrfs it should use btrfs subvolume delete instead.


    In any case: I do not know what caused my initial problem (no containers, even in the shell (docker ps))


    Regards,
    Hendrik

  • As soon as i click on "Docker" in the omv webgui i get this error:

    Code
    Fehler #0:
    exception 'OMVModuleDockerException' with message 'Error: "couldn't connect to host" - Code: 7' in /usr/share/omvdocker/Utils.php:63
    Stack trace:
    #0 /usr/share/omvdocker/Utils.php(179): OMVModuleDockerUtil::doApiCall('http://localhos...')
    #1 /usr/share/openmediavault/engined/rpc/docker.inc(352): OMVModuleDockerUtil::getContainers('42005')
    #2 [internal function]: OMVRpcServiceDocker->getContainers(Array, Array)
    #3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #4 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getContainers', Array, Array)
    #5 /usr/sbin/omv-engined(500): OMVRpc::exec('Docker', 'getContainers', Array, Array, 1)
    #6 {main}


    Got following error after installing both test and stable repositories.


    Error #0:exception 'OMVModuleDockerException' with message 'Error: "couldn't connect to host" - Code: 7' in /usr/share/omvdocker/Utils.php:63Stack trace:#0 /usr/share/omvdocker/Utils.php(125): OMVModuleDockerUtil::doApiCall('http://localhos...')#1 /usr/share/openmediavault/engined/rpc/docker.inc(145): OMVModuleDockerUtil::getImages('42005', true)#2 [internal function]: OMVRpcServiceDocker->getImages(Array, Array)#3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getImages', Array, Array)#5 /usr/sbin/omv-engined(500): OMVRpc::exec('Docker', 'getImages', Array, Array, 1)#6 {main}


    if i run "docker daemon" gives me below error
    Your Linux kernel version 3.2.0-4-amd64 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer


    I had the same probleme. Following helped me:


    Code
    $ sudo service docker restart
  • Have some leftover after removing this plugin:


    Code
    /srv/dev-disk-by-id-ata-SAMSUNG_HD753LJ_S13UJ1CQ804051-part1/docker /var/lib/docker/openmediavault none bind,defaults 0 0

    Can I just remove from the conf file?

  • I'm not sure what is going on, but I'm been having nothing but issues with OMV and docker. I had a previous setup with working docker using OMV image openmediavault_3.0.79-amd64.iso, but at the time I didn't have any storage setup. I wasn't actively using it, so the other day I started to play around with it again, and applied all the OMV updates, etc. And then setup some storage and tried to move the docker base to a shared folder, which ended up totally messing up my OMV install.


    So today I started fresh, with OMV openmediavault_3.0.86-amd64.iso, fully updated it. Installed OMV3-extras, installed Union FS, Snapraid, setup some shares (default settings - admin R/W/X, users R/W/X, rest others R/X). I then enabled Docker in the OMV3-extras plugin. Then installed the Docker UI plugin. Went to the docker UI plugin, set the base path to my docker share, clicked enable and the following happened:


    **********************************
    Initial setup in Docker UI upon enabling docker w/ base path to a shared folder
    **********************************




    **********************************
    Error when going to the docker UI tab on the left (after intial setup)
    **********************************



    Code
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; docker images 2>&1' with exit code '1': Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

    **********************************
    Details of previous error
    **********************************


    Code
    Error #0:
    exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; docker images 2>&1' with exit code '1': error during connect: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.29/images/json: read unix @->/var/run/docker.sock: read: connection reset by peer' in /usr/share/php/openmediavault/system/process.inc:175
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/docker.inc(1357): OMV\System\Process->execute(Array)
    #1 [internal function]: OMVRpcServiceDocker->getDockerRepo(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getDockerRepo', Array, Array)
    #4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'getDockerRepo', Array, Array, 1)
    #5 {main}

    **********************************
    Error when trying to uninstall the docker UI plugin
    **********************************



    **********************************
    Docker UI label still present on left side of screen after uninstall and reboot, even though the plugin page shows it as being uninstalled
    **********************************



    If anyone can help it would be appreciated, as I'm trying to evaluate OMV to see if it meets my needs for migrating from my current system... but so far it's been nothing but headaches. I'm not trying to do anything fancy, and haven't messed with out of box settings, etc, but nothing seems to work right...

    U-NAS NSC-800, Supermicro X10SDV-F-O, Xeon D 1540 (45W), 64GB EEC DDR4, LSI 9211-8i, Samsung XP941 M.2 SSD, ESXi 6.5

  • Hey guys,


    I could use some help.


    I'm trying to test a FreePBX docker image except I have no clue how the networking works.


    I have it setup in bridge mode but how do I forward my ports so I can connect to the docker image without losing my connection to OMV?

  • I'm trying to test a FreePBX docker image except I have no clue how the networking works.

    I would advise you to either start the container via CLI or use the macvlan network driver which is supported in the latest version of the plugin (released just a minute ago). This due to the fact that FreePBX uses lots of port ranges, which the plugin does not really support very well. I'm running FreePBX myself within a docker container and I've used the macvlan driver with good results.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!