Docker GUI plugin now stable

  • Additional note : I'll be busy for the next 6 months (maybe 1 year), I cannot patch anymore
    maybe other developer help


    Oh, it's a pity! You did a very good job especially with advancing and porting the omv-zfs to omv3.


    Thank you for all the work you investigated. ;)

    ---------------------------------------------------------------------------------------------------------------
    frontend software - tvos | android tv | libreelec | win10 | kodi krypton
    frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
    -------------------------------------------
    backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
    ---------------------------------------------------------------------------------------------------------------------------------------

  • @luxflow


    It's version 17.03.0-ce. Docker is running, and I tested it with docker run hello-world. However, the OMV plugin won't let me enable it or manage images from inside it. The plugin version i am using is 3.1.5.


    I also rebooted my OMV server a few times, but that didn't help.



    Code
    root@omv:~# docker --version
    Docker version 17.03.0-ce, build 60ccb2
    Code
    root@omv:~# docker run hello-world
    Unable to find image 'hello-world:latest' locally
    latest: Pulling from library/hello-world
    78445dd45222: Pull complete
    Digest: sha256:c5515758d4c5e1e838e9cd307f6c6a0d620b5e07e6f927b07d05f6d12a1ac8d7
    Status: Downloaded newer image for hello-world:latest
    Hello from Docker!
    This message shows that your installation appears to be working correctly.
  • Fixed. No reason to check for the numbers with a regex. New version uploaded.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • For information in OMV 2.X
    To fix the trouble, I've made these changes in the /usr/chare/openmediavault/engined/rpc/docker.inc file, in function : getSettings():


    PHP: docker.inc
    $cmd = "docker --version 2>&1";
    OMVUtil::exec($cmd, $out, $res);
    if (!preg_match('/^Docker version.*$/', $out[0], $matches)) {
    $dockerVersionInfo = "Docker not installed";
    } else {
    $dockerVersion = $matches[1];
    $cmd = "docker version";

    After that, a simple :
    service openmediavault-engine restart and it works !

  • Thanks. I guess I should've changed the OMV 2.x version when I changed the 3.x version. In the repo now.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • here is screenshot of my container setting
    I can edit transmission config file via OMV samba without issue


    check acl of sharedfolder using 'getfacl'
    and 'mount' to show mounting option..

    Guys, I'm asking you for help.


    For a long time, I can not run the transmission in a docker (linuxserver/transmission). The problem is that after restarting the container, the active torrents start downloading again, and those that are on pause keep progress.
    I'm trying to make it work on a virtual box


    That's what I'm doing :)


    1. create file system `data`


    2. create user `stan`


    3. create shared folder `media` with r/w for user `stan`


    4. enable smb/cifs and add share `media`


    5. create folders on `media` share



    6. create docker container
    http://imgur.com/EQwrxrM


    logs after start/restart container - https://pastebin.com/Z9TY3r2Y

  • Should i do anything on its container after i pulled the updated image?

    I don't know depends what you really want. Rarely images contain updates on their sw inside, sometimes they just polish the dockerfile for building the container, that triggers an automated build from github to dockerhub. Think about plex in linuxserver, you don't need to update the image as every restart checks for updates, same goes for mono based sw like sonarr, radarr or emby.
    If the image does really contain new sw then pull it, delete the old container and run it again. Modify button doesn't work for this

  • Hi, i´m need some help by my first try with Docker.


    I´m succesfully Activated the plugin and pull the headphones image. The host mode is "Host" and i´m just ad some Volumes from my OMV. So the webinterface sould be "xxx.xxx.xxx.xxx:8181" or did i mussundersud something?


    Beacuse under OMV IP:8181 nothing happens?!?

  • I just want to post here a TESTING version of the plugin with some new features on top the existing one.


    This new version includes


    * The full restart policy menu. No, always, unless-stopped and on-failure
    * Basic macvlan support, is a dropdown menu to select the network and to enter the IP field. The macvlan network still needs to be created at CLI
    * Now the modify button retains the extra options


    Feel free to test this in a VM or similar env.


    Edit1: Added clear log button for containers
    Edit2: The macvlan network menu now displays the corresponding subnet
    Edit3: The start, stop, restart button are all merged into one now for displaying the clear log button
    Edit4: fixed the incorrect variable parsing, thanks to @Symbiot for reporting this


    Thanks


    https://www.dropbox.com/s/7c8k….9_TESTING_amd64.deb?dl=0

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!