Docker GUI plugin now stable

  • Check if the image has a "latest" tag. The plugin tries to download that tag if nothing else is specified in the pull image dialog. I know that it won't work if the image doesn't have that tag... Also check the file size of the image. It could just take some time to download.

  • I was trying to use the repo included with the plugin. I gave it a few minutes and nothing changed. When I tried the sickrage repo you created it started showing things happening instantly.


    I tried adding tag of latest and nothing changed when I ran it. I do not know much about docker so I'm probably not giving very useful troubleshooting info.

  • yes, thank you.
    Now I was looking at the "run image" option and the fields are intimidating.
    From the docker page for the image it states:


    Exposed:


    Web UI ports: 80 and 443
    DHT UDP port: 49160
    Incoming connections port: 49161
    Downloads volume: /downloads
    rtorrent scratch files (watch and .session will be created automatically): /downloads
    ruTorrent ui config (config will be created automatically): /downloads/config



    What do I fill in for the fields? I'm guessing if I leave webUI ports 80 and dont change it will interfere with getting to openmediavault webUI.
    so do make host port: 80 and custom port: (something else) ?
    And volumes / bind paths would just be like my storage path and then whatever I want it to appear as within the container?

  • hey @ll:
    A very big thanks for the docker plugin. I'm very happy to use the plugin.
    But i have a question. Can i use a mysql database from omv mysqlplugin in a dockerprogram?

    omv 5.x | 64 bit | omvextrasorg 5.x | kernel 5.4
    used plugins: omv-extras | portainer | rsnapshot | antivirus
    used container: portainer/portainer | linuxserver/nextcloud | linuxserver/letsencrypt | linuxserver/mariadb | jellyfin/jellyfin | doliana/logitech-media-server | v2tec/watchtower | instrumentisto/coturn

  • hey @ll:
    A very big thanks for the docker plugin. I'm very happy to use the plugin.
    But i have a question. Can i use a mysql database from omv mysqlplugin in a dockerprogram?


    Glad you like the plugin!


    Sure, you can use the mysqlplugin with a docker Image (I do that myself). Just point the program in the image to your host IP/port of the mysql server and you should be set.

  • yes I read the guide but it wasn't as in-depth as I need for my own comprehension lol.


    I was trying to look at the attached images to get a idea of what I should be doing. I saw there was a host reference of 8081 and an exposed port of 8080.


    I believe Im on the right track as I was reading your readme on github for the same package and you had some detail in it.

  • @smudgeman if non of the ports pointed there are in use by your server then choose host.


    If those ports are in use (very common) then switch to bridge, and choose other ports for each container port requested there.


    You need to map only one folder, like to the left /media/uuid/downloads to the right /downloads press +


    and then start. Access on the port specified to the webui


    Inside the rutorrent configuration your download path, which is your communication path to the host is /downloads, you won't see /media/uuid

  • First, thanks for bringing Docker to OMV.


    I'm using the Kodi image from the repo. I get it pulling and running by myself, the Kodi web server is accessible by a browser.
    But the two addons I entered in the run dialogue don't work and Kodi failed to install them.


    There is a addons_install.log in the temp folder:


    Code
    Start searching for addon “metadata.universal...
    NOTICE: Addon “metadata.universal not found.
    Start searching for addon service.watchdog”...
    NOTICE: Addon service.watchdog” not found.


    Any ideas how to fix?


  • That was odd :-) I'm not in a position to look at this the next couple of days, but I have to assume that the URL for the addon repos has moved or changed it's layout somehow... If you look at the addons_install.php file in /root I think you should be able to find the issue quite easily.


    EDIT: I just tested the script and everything installed ok... There are errors reported regarding xbmc.metadata though which I think can be ignored. Test if you can reach the internet from within your docker container...


  • EDIT: I just tested the script and everything installed ok... There are errors reported regarding xbmc.metadata though which I think can be ignored. Test if you can reach the internet from within your docker container...


    You're right, that's the problem.


    Code
    # docker exec 952137bc7767 ping google.com
    ping: unknown host google.com


    This are my settings running the kodi container with. Have I missed or done wrong something?


  • Not sure if it is the right or cleanest way, but I've added the dns in my OMV /etc/resolv.conf in the /etc/default/docker.

    Code
    DOCKER_OPTS="--dns 192.168.178.1"


    And now the container has a connection to the internet:

    Code
    # docker exec kodi-watchdog ping google.com
    PING google.com (64.15.112.104) 56(84) bytes of data.
    64 bytes from cache.google.com (64.15.112.104): icmp_seq=1 ttl=59 time=20.8 ms
    64 bytes from cache.google.com (64.15.112.104): icmp_seq=2 ttl=59 time=18.8 ms
    64 bytes from cache.google.com (64.15.112.104): icmp_seq=3 ttl=59 time=18.7 ms


    Even wget with the xbmc mirror works:


    But I still get this error in /temp/addons_install.log:

    Code
    Start searching for addon “metadata.universal...
    NOTICE: Addon “metadata.universal not found.
    Start searching for addon service.watchdog”...
    NOTICE: Addon service.watchdog” not found.
  • You both are right, I'm using these " because of the screenshot in the guide. Removing them solves the problem.


    There are two problems left in the addons_install.log - the allready mentioned xbmc.metadata and this one:

    Code
    Start searching for addon xbmc.python...
    NOTICE: Addon xbmc.python not found.


    I think the watchdog addon using a python script and depends on this addon.
    How can I check if watchdog addon is properly running?


    Thanks for your help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!