Some docker containers don't like it when fstab is noexec

  • ## Scenario ##
    Some docker applications require the file system to have exec for a mount option. OMV by default sets the mountpoints to nonexec. I have had problems with plex + transcoding and also openvpn-as for docker when my 'APPhdd' is mounted as nonexec.


    ## Question ##
    1.)Is there a way to change the filesystem mount to exec and have it stay permanente? (after updates and reboots its back to nonexec)
    2.)right now i check every 7 days, or when plex doesn't transcode if fstab changed back to nonexec for my APPhdd. Are there any better options or alternatives or recommendation?



    Thanks!

  • Find the fstab entries you don't want with noexec in /etc/openmediavault/config.xml look at the mnent entries. Remove the noexec directive and run


    omv-mkconf fstab


    Reboot. If you want future attached disks the same you need to edit Omv environmental variables

  • Thank you for this info!! Was working on getting some post process scripts working in some apps inside Docker, and ran into this exact issue. This info helped save my night. Wanted to respond for anyone else getting permission denied for script processing from inside Docker containers, to check the mount options on your system. This helped me illuminate the common issue others had with remote locations being mounted with the no exec option. I wasn't realizing that OMV actually mounted the drives this way. Learn something new everyday!

  • Same- very useful.


    Unfortunately took me a while to find out why my Plex wasn't working, let alone finding this thread for a solution, so ended up rebuilding my Plex library about 5 times.


    Manual match fixing is not fun 5 times.

  • Find the fstab entries you don't want with noexec in /etc/openmediavault/config.xml look at the mnent entries. Remove the noexec directive and run


    omv-mkconf fstab


    Reboot. If you want future attached disks the same you need to edit Omv environmental variables

    Subzero... you really need to change your name to Superhero! Just finally got my set up running and ran into this issue. Your suggestion (and now knowing the location of that .xml file) got my library up and running! Now I can go on travel, which I do a lot, and binge my Star Wars (or what ever else I feel like)! Thanks for the quick and easy suggestion.

  • Helpful thread. Set up OMV with a plex docker on the same hardware a couple of times and everything worked fine. Transcode wouldn't work for some reason on a subsequent pass at reinstalling OMV again on that same hardware, and ended up here after ruling out every little nit thing I did different on this install round...


    EDIT: adding a follow-up comment that what I did different for this install was move the plex database to the harddrive instead of the SD card where the OS is for my Odroid HC2 board. THAT'S why I ran into the noexec problem on this latest install.

    OMV 5.3.9 set up for RAID5 with (3) WD Red 4TB using repurposed Asus P8P67 i5-2500K 16GB

    Edited once, last by klunkerbus ().

  • Find the fstab entries you don't want with noexec in /etc/openmediavault/config.xml look at the mnent entries. Remove the noexec directive and run


    omv-mkconf fstab


    Reboot. If you want future attached disks the same you need to edit Omv environmental variables

    thank you sir!
    also had the problem after switching from plex plugin to plex docker container.
    your solution seems to work permanent.


    wondering that i found so less about that topic. i'd think tons of ppl use the plex docker. but maybe they are all smarter than we are :D

  • wondering that i found so less about that topic. i'd think tons of ppl use the plex docker. but maybe they are all smarter than we are :D

    The search function in the forum is not especially good.


    The problem isn't limited to the Docker version of Plex. Any Plex installation that places the database on a drive other than the system drive will suffer the same problem. In fact, if you have any executable programs stored on a non-system drive, they will not run unless the drive is mounted without the noexec option.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Guys, this solution is still brilliant and valid. I was chasing down my issues with Plex transcoding for an hour until I found that solution!

    Really glad it still worked and thanks for all your support here, much appreciated.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!