[Howto] Install / Boot OMV on Intel SS4200

  • Copy from old forum hosted on SourceForge, so this post wil not be lost! :D
    Post from 26.11.2011, I hope it still works.


    First some hardware informations about my Intel SS4200:
    Processor: Intel Pentium Dual-Core E2220, 2x 2.40GHz
    Memory: 2GB
    Flash: Transcend 4GB DOM (IDE)
    HDD: 4x 3.5" (SATA)

    Bios settings:
    ATA/IDE configuration: Enhanced
    SATA configuration: AHCI, Behind PATA

    Before I installed OMV I disconnected all SATA HDDs from the board.
    After that I (successfully) installed OMV 0.2.5 (x64) on the 4GB DOM via USB drive.
    I booted from the DOM, but after "Loading, please wait..." the following error occurs:

    Gave up waiting for root device. Common problems:
    ALERT! /dev/disk/by-uuid/... does not exists
    Dropping to a shell!

    I read on an other site that this is a known issues and occurs also on FreeBSD 7 and Ubuntu amd64 with Intel SS4200. The problem is:


    It does not recognize the PATA port unless set in Compatibility mode in the BIOS, and "PATA before SATA".

    For testing I installed OMV 0.2.5 (x86) on the 4GB DOM, but the same error occurs.
    Then I set ATA/IDE configuration to Compatibility mode and PATA before SATA.
    Now OMV/Debian is able to find the device and boots up.

    But the next problem is when I set Compatibility mode, the bios recognize only the DOM and 2x SATA HDDs instead of 4.

    If I install OMV on a usb drive instead of the DOM it works out of the box with all 4 SATA HDDs.

    While I wrote the text above at the afternoon, I couldn`t login to this forum to post if anyone has any ideas how to solve this issue I described above. :shock:
    Many hours later I found a solution and maybe its interesting for some other people trying to get OMV working with Intel SS4200. :D

    The necessary kernel modules for ATA/IDE are not loading. To fix this you have to do the same as described here.
    Here a small summary and adaption for Intel SS4200:

    Regards :lol:

  • I tried this with my NAS, nothing seems to work. I've got the console defaulted to 1152008n1 and I can get into the bios and everything else. I can boot freenas fine. But when I try OMV I get the loading grub line, then the screen goes black, but I know it's loading as it stops flashing for a sec then starts again, but the box never comes up. I put the USB stick into an old computer and it boots fine and is immediately accessible via the web interface.

  • One trick I've learned on usb installs is try every usb port. How many usb ports does your machine have? It may not help but make sure you try on every port because if your machine has several ports it likely has more then 1 usb controller. If I had same hardware as you I'd help more.

    Good Luck

  • I know this would be for a debian OS, but for what it's worth I installed ubuntu 12.04 x64 mini on a Intel ss4200 to a 60g ide drive connected to the PATA port. With only the 60g IDE drive connected (and a USB CD-Rom boot/install disk) I went into the bios and configured the IDE mode as compatible (this mode will only display or access two PATA devices and the first two SATA ports). Install the OS as you normally would against the IDE drive and the reboot the system. So at least for the Intel ss4200 running 64-bit Ubuntu 12.04 I had to load the "pata_legacy" module to have the PATA port accessible in Ubuntu when the bios IDE mode is changed from compatible to enhanced mode. after adding, loading, the pata_legacy module and issuing the update-initramfs -u command I then rebooted the system and changed the bios IDE mode to enhanced and continued to boot the system off the 60g ide drive successfully. After that worked, I shutdown the system and added my 4 SATA drives and rebooted the system to see that all 5 drives were accessible to ubuntu while the bios is running in ide enhanced mode.

    hope this helps someone...

  • @carde and daifel, big THX from me. Helped me a lot.
    First of all I installed OMV but with this old Kernel it doesn't make a lot of fun with the SS4200. Now I have installed the Ubuntu 12.04 and it works like a charm. Another method than the installation over USB-Dongle or external CD-Drive is to connect the CF-Card with a PC and install the OMV or Ubuntu with VMware, after the installation and configuration you can put it in the SS4200.

  • Hi Folks,

    I'm converting my ss4200e to OMV. How did you guys manage to install the image ? I'm stuck at booting the USB stick. I loose all console information right after the boot. I tried switching the console speed to 9600N1 but still nothing appears on the serial console.

    Any suggestions other than installing a video card ?

    I'm using latest OMV 5.0.24.


  • Thanks so much for the info!
    I didn't want to bother w/ the serial console so I did a slightly modified method installing to a different PC and then just swapping the DOM into my SS4200:

    • Download OMV iso and burn to CD or install onto USB stick using http://unetbootin.sourceforge.net/
    • Install DOM in desktop. I disconnected all HDs just in case it didn't detect the DOM. I've seen Linux installers pick a drive automatically and wipe it when only detecting one possible install location.
    • Boot from USB stick or CD, install OMV on DOM following prompts.
    • Boot OMV from DOM (still on desktop).
    • login to root.
    • Type: echo ata_piix >> /etc/initramfs-tools/modules(press enter)
    • type: echo pata_legacy >> /etc/initramfs-tools/modules (press enter)
    • type: update-initramfs -u (press enter)
    • type: rm /etc/udev/rules.d/70-persistent-net.rules (press enter)
    • type: shutdown -h now to shutdown desktop.
    • Remove DOM & install into SS4200
    • Assign static IP to the NAS from router
    • Start up NAS. Login from any other PC using web interface & assigned IP. Done!

    Thanks very much for the help!

  • There have been changes for OMV ver 1.X (related to Debian "Wheezy") that affect installation on the SS4200

    The ide module is now called pata_legacy for Debian. Replace ide_generic with pata_legacy in all instructions above.

    The 64-bit debian kernel does not have pata_legacy. So, you have to use the 32-bit. I think it would be possible to compile your own custom kernel with the appropriate modules, but I'm not knowledgeable enough to do that.

  • I know this thread is old, but I'm hoping someone can help out. I have a ss4200 and I'm trying to re-purpose it to use omv. The unit has 2gb of memory and a e4700 cpu. I'm trying to install omv onto a 8gb DOM.

    When trying to install with enhanced pata mode, the installation doesn't see the DOM. When pata is set to compatible, it installs, but after reboot I'm greeted with a flashing _. I was using openmediavault_2.1_i386.iso as the installation media.

    Does anyone have any ideas as to what is causing this issue and if I should even bother.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!