OMV Fails to boot after power loss

  • Hello All,


    I've been running OMV now for about 2 years after coming over from FreeNAS. I had a power loss this evening which knocked down my network and my OMVnas. I rebooted everything and it all came back except OMVnas. I've attached a screenshot of what happens.


    I have done a forum search and found the subjects I added as tags for this post. I can type on the NAS but nothing happens, I cannot access the web interface. I have downloaded ubuntu 16.04.3 desktop amd64 lts and created an bootable USB using rufus 2.18.


    Can anyone confirm this is a problem with (as I suspect) the /etc/network/interfaces and that my best course of action would be to edit as in post 8 on this thread:


    [Resolved twice] Lost OMV on my network



    Thanks


    Update1 - have booted to the live usb and have access to the drives etc all seems fine hardware wise as I have an internet connection, I have attached the interfaces config file:


    -----------------------------------------------------------------------------------------------------
    # The loopback network interface
    auto lo
    iface lo inet loopback
    iface lo inet6 loopback



    # eth0 network interface
    auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp
    post-up /sbin/ifconfig $IFACE mtu 9000
    dns-search openmediavault
    iface eth0 inet6 dhcp
    pre-up echo 1 > /proc/sys/net/ipv6/conf/$IFACE/accept_ra
    pre-up echo 0 > /proc/sys/net/ipv6/conf/$IFACE/disable_ipv6
    -----------------------------------------------------------------------------------------------------


    The last time the file was altered was 26th August this year which ties in with me upgrading my switch to a 1gig I would have set the mtu to 9000 for jumbo frames.


    I have also attached the network connection info from the live ubuntu environemnt. To me this looks like it should work. If I don't hear anything I'm planning to rename the interfaces file .old and see if the system recreates a new version on restart.


    Update2 - tried to rename interfaces to .old had permissions problem. I'm calling it a night and starting fresh in the morning any advice will be much appreciated.

  • Looks like it isn't getting a dhcp address. Instead of altering the interfaces file, just try omv-firstaid. I would think about a static IP as well.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It should be getting a dhcp address as there is a static assignment in my firewall, but that said even if it didn't get an address why would that prevent it from going past that point and allowing access to the login prompt? The ANC.jpg is from the same pc with a livecd boot to check all the hardware is working.


    I would love to try omv-firstaid but I can't try omv-firstaid if I can't access the command line. Any thoughts on how to get there? I have tried ctrl alt F2 all I get is a black screen with a flashing cursor and then can't get back with ctrl alt F7.

  • If it's getting an IP address, maybe sshd is running too? Try connecting via ssh and see.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • If I turn off ipv6 forwarding on my firewall (as a test) would that have the same effect or do I need to remove the entries? I will try turning ipv6 off tomorrow reboot and see if it works I will edit the entries and remove it then reenabvle ipv6 forwarding in my firewall.


    Do you remember which config files needed editing?

  • I've finally had some time to do the work. I decided to get a spare hard drive and reinstall OMVnas. I disconnected power from all drive except the new one and installed. Did all the updates and then shutdown and reconnected power to my raid drives.


    OMVnas picked up the raid straight away, I am seriously impressed. Have recreated the shares and away we go. Thanks to everyone for their help above.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!