Probleme mit Raid10

  • hallo leute, ich bin komplett neu auf dem gebiet server-nas.


    jetzt habe ich seit einigen tagen-woche einen
    Dell t30 mit einer
    m.2 pci ssd
    4x3tb wd red


    habe es instaliert und so eingestellt wie ich es möchte.


    wenn ich jetzt ein raid10 erstelle, geht alles soweit gut. dauert ca 7 std das es es erstellt und resincygt
    danach steht Clear.


    unter dateisystem dann kann ich das raid nicht einhängen.
    wenn ich das versuche bekomme ich einen fehler, sowohl im webinterface als auch in der console.
    das ich es zuerst bereinigen muss.


    habe gegoogelt aber ich komme nicht weiter.


    habt ihr noch ideen?


    mdadm oder so hab ich auch paar sachen versucht. komme einfach nicht weiter.

  • Welcher Speed? Nutzt du 10 Gbit-Netzwerk? Wenn nicht ist dein limitierender Faktor das Gbit-LAN und nicht die Platten. Sicherheit bietet dir ein Raid auch nicht, nur Verfügabarkeit.


    Poste mal bitte die Fehlermeldung welche du beim Mount-Versuch des Raids bekommst


    Edit: macom: Dateisystem ist ein guter Punkt :D

    Chaos is found in greatest abundance wherever order is being sought.
    It always defeats order, because it is better organized.
    Terry Pratchett

  • Welcher Speed? Nutzt du 10 Gbit-Netzwerk? Wenn nicht ist dein limitierender Faktor das Gbit-LAN und nicht die Platten. Sicherheit bietet dir ein Raid auch nicht, nur Verfügabarkeit.


    Poste mal bitte die Fehlermeldung welche du beim Mount-Versuch des Raids bekommst


    Edit: macom: Dateisystem ist ein guter Punkt :D

    ok. speed nicht. aber sicherheit doch, da 2 genutzt und auf 2 gespiegelt wird, hat man im fall des falles ja auf 2 die spiegelung.


    wollte ihn gerade hochfahren, bekomme einnen fehler. siehe bild.
    hat sicher mit meinen einhänge versuchen über die console zu tun.


    wie löse ich das?

  • fehler: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v --source '/dev/disk/by-label/POOL1' 2>&1' with exit code '32': mount: mount /dev/md0 on /srv/dev-disk-by-label-POOL1 failed: Structure needs cleaning


    unter Details steht dann:
    Fehler #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v --source '/dev/disk/by-label/POOL1' 2>&1' with exit code '32': mount: mount /dev/md0 on /srv/dev-disk-by-label-POOL1 failed: Structure needs cleaning in /usr/share/php/openmediavault/system/process.inc:175
    Stack trace:
    #0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(720): OMV\System\Process->execute()
    #1 /usr/share/openmediavault/engined/module/fstab.inc(72): OMV\System\Filesystem\Filesystem->mount()
    #2 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleFsTab->startService()
    #3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
    #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #5 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
    #6 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(857): OMV\Rpc\Rpc::call('Config', 'applyChanges', Array, Array)
    #7 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
    #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #9 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('mount', Array, Array)
    #10 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('FileSystemMgmt', 'mount', Array, Array, 1)
    #11 {main}

  • ok, da er nach dem raid erstellen ihn automatisch in Dateisystem angezeigt hatte dachte ich das es so sein muss.


    habe einfach in dateisystem das laufwerk gelöscht und einfach ein neues erstellt.
    das läuft jetzt.


    also wieso auch immer.
    sollte jemand mal das problem haben, hier ist die lösung.


    also nach dem erstellen des raids, unter dateisystem darf nur der instalation ordner-hdd sein.
    sollte da mehr sein, ist es falsch und die andere löschen. und neu erstellen. dann läuft es.

  • speed nicht. aber sicherheit doch, da 2 genutzt und auf 2 gespiegelt wird, hat man im fall des falles ja auf 2 die spiegelung

    Quatsch. Im Fall des Falles hat man gar nix mehr, da alles auf beiden Platten zeitgleich futsch ist, siehe bspw. Destroyed file system?


    RAID ist totaler Quatsch, wenn man auf Datensicherheit aus ist. Aber ist ja schließlich Dein Datenverlust also spar Dir ruhig das Backup und setz auf das falsche Konzept. Viel Glück!

  • Besser, man hätte im Fall des Falles ein Backup...


    Quatsch. Im Fall des Falles hat man gar nix mehr, da alles auf beiden Platten zeitgleich futsch ist, siehe bspw. Destroyed file system?
    RAID ist totaler Quatsch, wenn man auf Datensicherheit aus ist. Aber ist ja schließlich Dein Datenverlust also spar Dir ruhig das Backup und setz auf das falsche Konzept. Viel Glück!

    nein am backup wird nicht gespart.


    täglicher backup auf eine ssd mit den wichtigsten daten. und wöchtenlich auf eine externe. oder beim anschliesen.


    so hatte ich es auf dem qnap. und würde das im t30 auch so weiter machen.


    gibt es im omv auch eine funktion wie zb: wenn festplatte xy angeschlossen wird backup machen.
    habe das noch nicht gefunden. oder normal backup auf die interne nach eingestelltem interwall?


    und auf jeden fall wird der qnap auch bleinben und auf dem weiterhin auch backups absichern.



    einmal sind mir 2 zugleich abgeschmiergt im raid1 und "alles" war weg, letzes backup über 4 monate her gewesen. seit dem 3fach abgescihert.


    was würdet ihr denn empfehlen?
    raid1 und die anderen 2 festplatten auch als backup?


    vorhanden ist ja neben denn 4x3tb, 2x 2tb externe 2,5" und (1xSSD mit 500gb und 2x3tb im raid1 im Qnap)


    soll lieber 4fach abgescihert sein als 2fach.
    sind wichtige daten drauf aus einem kleinen büro die täglich im gebrauch sind.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!