Docker 'Run Image' returns Error

  • OMV: 4.1.17-1 (Arrakis)
    Kernel: Linux 4.19.0-0.bpo.1-amd64


    What is Working:

    • Able to stop/start Docker Containers that are already configured with no errors.
    • Able to pull new images

    What IS NOT Working:

    • Unable to select a pulled image and click 'Run Image' without the following error popup

    Error #0:
    OMVModuleDockerException: Error: "" - Code: 0 in /usr/share/omvdocker/Utils.php:74
    Stack trace:
    #0 /usr/share/omvdocker/Image.php(138): OMVModuleDockerUtil::doApiCall('http::/images//...')
    #1 /usr/share/omvdocker/Utils.php(238): OMVModuleDockerImage->__construct(false, Array)
    #2 /usr/share/omvdocker/Utils.php(276): OMVModuleDockerUtil::getImage('4cc3c7db20c1')
    #3 /usr/share/openmediavault/engined/rpc/docker.inc(896): OMVModuleDockerUtil::getContainers()
    #4 [internal function]: OMVRpcServiceDocker->getVolumesFrom(NULL, Array)
    #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #6 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getVolumesFrom', NULL, Array)
    #7 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'getVolumesFrom', NULL, Array, 1)
    #8 {main}


    root@openmediavault:~# dpkg -l | grep dock



    root@openmediavault:~# systemctl status docker


    What other information would be useful and any nudges in the right direction are appreciated?

    • Official Post

    Clear browser cache?

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I have a similar issue: "Error: "Could not resolve host: http:" - Code: 6"


    Details:




    Clearing browser cache does not help..


    Any ideas?

  • Hi guys..


    I got the same error...


    what I did:


    I tried to update my nextcloud docker Image over the NC-Webgui which failed.. then i got stuck in "Update in Progress" when i entered the NC-webgui..
    After that error above appeared..


    any thoughts ?

    MSI B-250-DS3H-G4560 | some RAM | someTB WD red (snapraid) | OMV 5.x (latest) | DD Cine S2 V6.5

    • Official Post

    When I saw the word “stuck” in your first post it makes me think your issue is not related to the issue on this thread specifically. It does sound like a problem I and others had a month back. Look at this thread. I hope it helps.


    nexct cloud update problem

    System Backup Typo alert: Under the Linux section the command should be sudo umount /dev/sda1 NOT sudo unmount /dev/sda1

    Backup Data Disk to Backup Disk on Same Machine: In a Scheduled Job:rsync -av --delete /srv/dev-disk-by-uuid-f8814ed9-9a5c-4e1c-8830-426968c20ea3/ /srv/dev-disk-by-uuid-e67439d5-00a3-4942-bd5f-b84ab86aa850/ Don't forget trailing slashes, and BE CAREFUL. (HT: Getting Started with OMV5)

    Equipment - Thinkserver TS140, NanoPi M4 (v.1), Odroid XU4 (Using DietPi): PiHole

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!