Web-gui doesn't have login form after running omv-update

  • Hi there!
    After doing a omv-update and reboot, I tried to access the web gui and all I got was a blue background without the login form.
    I ran omv-firstaid and tried all the options to see if it would fix the problem to no avail.


    However, after running the first option it gives the following error:



    Code
    Configuring network interface. Please wait ...ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; monit monitor collectd 2>&1' with exit code '1': Cannot create socket to [localhost]:2812 -- Connection refused


    After that I lost access to the server remotely, and I haven't been able to restore it since.



    Since port 2812 is used by monit, running export LANG=C; monit -B summary 2>&1 gives:



    Code
    Cannot create socket to [localhost]:2812 -- Connection refused


    I tried to run omv-mkconf monit and systemctl restart monit which seems to fix monit, but I still don't have remote access.


    If I do configure network interface with omv-firstaid, I get the same error above and I'm back to square one.



    After restarting the whole network and the server several times, the monit problem went away. However, I still can't properly access the webgui, since it doesn't display the login form.

  • Have to ask the obvious..... have you emptied your browser cache and all cookies associated to your OMV box, and on next visit pressed Ctrl-F5 (on PC) or CMD-Shift-R (on Mac)? I've had the same thing happen, and that's what fixed it.


    If that doesn't do it, have you tried a different browser or computer to access it?

  • That's a pertinent question because it has happened to me before too.


    I've tried it on different computers, both firefox and chrome, and just to be sure even deleted the browser profile, not just empty the browser cache.


    I get the same result. A blue background with the OMV logo at the left bottom corner.

  • Is it on a static IP? If not when you rebooted it may have changed IP...

    HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 4.X
    HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 4.X
    and loads of other PC's and NAS... OMV by far the best....
    (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)

  • After restoring a previous system backup to a VM and compare it to my current setup I figured the problem out. Turns out that the file /usr/share/javascript/extjs6/ext-all.js was corrupted. Restoring it from a previous backup made the system work again.


    I suspect I may need to replace my system disk...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!