Techno dad tutorial on omv/docker/letsencrypt/duckdns/etc? Stuck with port forwarding.

  • Hi all,


    I'm following the techno dad video and I'm at this point:



    I've logged into my router
    Instructions for the router are here: https://support.netcommwireles…orwarding-Setup-Guide.pdf



    This is what my screen looks like below:. I'm completely stumped as to what to put in there. Techodad says to put a specific IP in, but where did he get that? Is mine different? I have no idea what my interface is meant to look like compared to his also.


    I'm sorry for the questions that for many of you will seem stupid but I've not done this kind of thing before and any advice would be highly appreciated.



    Thank you.

  • Thank you for the reply. Watching his tutorials now and using your image (thanks for that). I apply the settings as per your link and get:


    Code
    this port 80 is used to the Broadband Router HTTP server, Please choose other port.


    I'm .... stumped on what to do here. Should I research changing my router's port from 80 to something else? If I do that, will it affect any of my other setup services etc? I am a little hesitant here as I'm getting a little out of my depth (but this is how we learn I guess)

  • I'm not sure of any http server running from it? All I know is it has its admin panel where I can adjust settings etc.
    I had a good look through the admin panel just now and can't find anything.


    So...assuming I can change the port (I have this modem https://support.netcommwireles…-User-Guide-NC-R6B016.pdf )


    I can see the docs show this (image below). Do I just change the 80 to another number? Is there a recommended number to change this to? I'm a little confused as I wouldn't expect that the technodad video would expect people to change their modem/routers http port so maybe some info is missing in his video?


    Thanks for your time, I do appreciate it.


  • First of all thanks for all the instructions. They helped me a lot. :)

    I followed all the instructions from installing nextcloud etc. In general everything runs like a charm until it comes to the SSL connection. That's why I carried out your other tutorial 'Securely Login to Nextcloud Remotely on Openmediavault'. Now I face a problem. After generating the network, that worked fine, I tried to put the extra argues into the containers: --cap-add=NET_ADMIN --network my-net and --network my-net.

    When I confirmed this addings it comes to an error in nextcloud container as well as letsencrypt container. Any idea what runs wrong?


    This is the error:


    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker run -d --restart=always -v /etc/localtime:/etc/localtime:ro --net=bridge -p 0.0.0.0:91:443/tcp -p 0.0.0.0:90:80/tcp -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e PS1="$(whoami)@$(hostname):$(pwd)\$ " -e HOME="/root" -e TERM="xterm" -e DHLEVEL="2048" -e ONLY_SUBDOMAINS="false" -e AWS_CONFIG_FILE="/config/dns-conf/route53.ini" -e S6_BEHAVIOUR_IF_STAGE2_FAILS="2" -e PUID="1000" -e PGID="100" -e TZ="Europe/Berlin" -e EMAIL="schoepfner@yahoo.de" -e URL="duckdns.org,hopto.org" -e SUBDOMAINS="lallkopf" -e VALIDATION="http" -e ONLY_SUBDOMAINS="true" -v "/sharedfolders/AppData/Letsencrypt":"/config":rw --name="letsencrypt" --label omv_docker_extra_args="--cap-add=NET_ADMIN --network my-net" --cap-add=NET_ADMIN --network my-net "linuxserver/letsencrypt:latest" 2>&1' with exit code '125': docker: conflicting options: cannot attach both user-defined and non-user-defined network-modes. See 'docker run --help'.


    Fehler #0:

    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker run -d --restart=always -v /etc/localtime:/etc/localtime:ro --net=bridge -p 0.0.0.0:91:443/tcp -p 0.0.0.0:90:80/tcp -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e PS1="$(whoami)@$(hostname):$(pwd)\$ " -e HOME="/root" -e TERM="xterm" -e DHLEVEL="2048" -e ONLY_SUBDOMAINS="false" -e AWS_CONFIG_FILE="/config/dns-conf/route53.ini" -e S6_BEHAVIOUR_IF_STAGE2_FAILS="2" -e PUID="1000" -e PGID="100" -e TZ="Europe/Berlin" -e EMAIL="schoepfner@yahoo.de" -e URL="duckdns.org,hopto.org" -e SUBDOMAINS="lallkopf" -e VALIDATION="http" -e ONLY_SUBDOMAINS="true" -v "/sharedfolders/AppData/Letsencrypt":"/config":rw --name="letsencrypt" --label omv_docker_extra_args="--cap-add=NET_ADMIN --network my-net" --cap-add=NET_ADMIN --network my-net "linuxserver/letsencrypt:latest" 2>&1' with exit code '125': docker: conflicting options: cannot attach both user-defined and non-user-defined network-modes.

    See 'docker run --help'. in /usr/share/php/openmediavault/system/process.inc:182

    Stack trace:

    #0 /usr/share/openmediavault/engined/rpc/docker.inc(597): OMV\System\Process->execute()

    #1 [internal function]: OMVRpcServiceDocker->runContainer(Array, Array)

    #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)

    #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('runContainer', Array, Array)

    #4 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('Docker', 'runContainer', Array, Array, 1)

    #5 {main}

  • First of all thanks for all the instructions. They helped me a lot. :)

    I followed all the instructions from installing nextcloud etc. In general everything runs like a charm until it comes to the SSL connection. That's why I carried out your other tutorial 'Securely Login to Nextcloud Remotely on Openmediavault'. Now I face a problem. After generating the network, that worked fine, I tried to put the extra argues into the containers: --cap-add=NET_ADMIN --network my-net and --network my-net.

    When I confirmed this addings it comes to an error in nextcloud container as well as letsencrypt container. Any idea what runs wrong?

    Maintain --cap-add=NET ADMIN


    delete --network  my-net that do not work with recent version of dockers.


    instead, once your docker works as expected, you must go to docker webGUI and change network from webGUI ( first detach bridge and then atach to my-net).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!