Web Gui - stopped working - dial tcp: lookup omv on 127.0.0.1:53: no such host

  • Dear Sirs/Madams,


    I recently upgraded to version 4, and have had tons of problems with my mdraid.


    My raid is now ok (at least the 4 disk raid5 i originally had)


    But i have since added another 5 disks to my system, and that raid is visible locally on the omv box, but i cannot see that export on my remote systems


    so this morning i was going to check over my shared folder etc in the omv GUI, only to find out the we gui no longer works :(


    i only get this message in my browser :


    dial tcp: lookup omv on 127.0.0.1:53: no such host


    EDIT :


    Saw this error :


    Code
    nginx.service: Failed to read PID from file /run/nginx.pid: Invalid argumen

    And did this procedure :


    https://www.cloudinsidr.com/co…iled-read-pid-file-linux/


    Which removed the error message, but the webgui still wont display

  • Hi mrpg,
    are there any other interfaces available? It could be the case that the web server is offering its services ("listen to traffic") on another interface. IP 127.0.0.1 sounds like a loopback device.

    Many thanks fot your reply, sorry for my slow response, i have been to busy @ work.


    i input http://192.168.0.112 into my browsert on my laptop to access the omv web gui of my nas , which has that ip address.


    i still get that response in my browser.


    these are all the interfaces on my omv box :


  • Something is terribly wrong with this new version of omv.


    i have had zero problems for 2 years, and i thought, it would be cool with a new version, perhaps there are new useful features & even performance improvements.


    1 i stil have issues with my /dev/md127 device, its hangs the omv box if i list directories on certain folders
    2 i it hangs when i run :


    Code
    e2fsck -y /dev/md127
    e2fsck 1.43.4 (31-Jan-2017)
    pgnas2: clean, 361726/274702336 files, 2014285334/2197601280 blocks

    3 this threads subject, web gui no longer works


    is my machine dying? hw wise , i get nothing in dmesg or /var/log/messages or /var/log/syslog that is suggesting a hw problem.


    i have a new pc i could move my disks to, can anybody reckommend a step by step instruction for moving 4 disk mdraid5 & 5 disk mdraid5 to a new omv install without loosing data?


    these forums seems to be very inactive, i just want some help along the way.


    Br
    Patric

  • Something is terribly wrong with this new version of omv.

    I have no problems with it on four systems.


    is my machine dying?

    Seems underpowered or just not happy with the newer kernel. What system is it again?


    these forums seems to be very inactive, i just want some help along the way.

    80 posts a day seems decent to me. Personally, I just don't have much time to devote to the forum and even less since I am trying to port the omv-extras plugins to OMV 5.x.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi again @ryecoaaron


    I did not want to tag your name again, i can see that you are the absolute most devoted person to this forum, and i super appriciate your help.


    Can you help me downgrade, or fix, or move my disks to a new system? , i am getting a bit desperate for my wife to be able to use my nas again :)


    Br
    Patric

  • Can you help me downgrade, or fix, or move my disks to a new system?

    Sure but what is the new system? And using mdadm seems to be the biggest issue with your system. Why are you using raid? I hope you aren't using it as backup (since it is not).

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sure but what is the new system? And using mdadm seems to be the biggest issue with your system. Why are you using raid? I hope you aren't using it as backup (since it is not).

    I am using raid because
    1 it is more redundant then using a single disk
    2 it creates a big logical disk from several smaller disks.


    The new system is an i7 intel CPU with 32gb ram nvme disk for Inc


    I will also use this system to run virtual machines on.


    Sent from my SM-A505GN using Tapatalk

  • it is more redundant then using a single disk

    True but most home users don't need that kind of redundancy (I don't use raid). And it seems like your current outage isn't the end of the world :)


    it creates a big logical disk from several smaller disks.

    mergerfs/unionfilesystem plugin does that as well. You can't have a file bigger than a single disk but that usually isn't a problem. I use this plugin on quite a few of my systems.


    The new system is an i7 intel CPU with 32gb ram nvme disk for Inc

    That should work much better. You should be able to move your disks including the OS disk to the new system, set the OS disk to boot, and it just works. Since the network adapter will be different, you should run omv-firstaid to fix that. But other than that, the move is pretty simple.


    I will also use this system to run virtual machines on.

    cockpit works pretty well for that.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sounds good!


    So it does not matter that the sata cables are connected in a different port or different sata controller? Mdraid will pickup the member disks anyway?


    Sent from my SM-A505GN using Tapatalk

  • So it does not matter that the sata cables are connected in a different port or different sata controller?

    Nope.


    Mdraid will pickup the member disks anyway?

    It should.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sounds fantastic,


    i am on a work trip at the moment, but will build the new pc , hopefully next week.


    the /dev/md127 mdraid does not seem happy at all,


    it hangs if i try to fsck on it


    it hangs if i try blkid


    anything one can try to get that going again on this machine?


    Br
    Patric

  • ah bugger, i wont cry if i loose the data, but its 8tb of stuff

    I wouldn't assume that it won't work on the new machine. I think the array can be made to work on the machine but it might not want to assemble on every reboot.

    omv 5.5.5 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    looks like i need your expertise again @ryecoaaron


    i have finally had time to build my new pc.


    i am now suspecting either my sata controller card, or disks, i mean something is smelling quite fishy here,


    So i built a new pc :


    asus z390 mainboard
    intel u7 8700
    32gb ddr4 2666
    intel nvme disk for omv


    so far i have only added my 4x disk raid 5 to the system, i am waiting to connect my 5x ssd zfs raid.


    installed omv 5.05


    and i cant even open the web gui, its just telling me "loading please wait"


    i can login through ssh no problems, no load or disk activity..


    what is goiing on? , please help..

  • installed omv 5.05

    Since you are building a new machine why use 5 it's still in beta, 4 would be a better option at least it would give you an idea if the new hardware is going to play nicely and your raid is going to work. AFAIK debian stretch is lts until 2022.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!