Still clueless....

  • This is my 5th and last try to get OMV run....


    I have :


    - installed OVM
    - updated via ovm-update
    - installed the extra package
    - installed snapraid & union filesystem ( originally i only wanted to try snapraid )


    same Workgroup...checked



    create a folder ( Data ) and a user ( test / test ) member of the group users




    after that, i activated smb and create shared folder



    aaaaaaand......



    I can see the server in my windows network, but can not login.


    What was my mistake ???? ?(

  • i'm not sure if this is the ONLY issue but i think you have to be apart of the 'samba share' group also. and u can try to set open permissions so u don't need to log in every time unless u need it set like that to block other people in your home from accessing it

  • In Windows type this username for the network share:


    Datenschleuder\test


    That's OMV hostname + backslash + OMV username.
    The password is what you've set it when you've created the user in OMV.
    User does NOT need to be a member of the "sambashare" group on the OMV machine.

  • Can you try to create the network shared drive in Windows with these credentials:


    Username: Datenschleuder\root
    Password: <your OMV root password>


    The username should contain just the hostname ("Datenschleuder" from your first screenshot), and not the domain ("WORKGROUP" from your first screenshot) before the backslash.

  • root login did not work. same "wrong user/password"




    *öööhhhmmmm* :whistling:


    could it be a problem with capital letters ???




    #edit renamed the server to full capitals and restart it. problem stays the same

  • Windows shows hostnames of network neighbors in all caps. That shouldn't be an issue.
    Username is case sensitive, but the hostname (at least in my case) is not.


    But feel free to try this variant:


    Datenschleuder\test
    <your password>

  • I don't think that incorrectly set ACL would give you an "incorrect username/password" error.
    Something else is wrong here.


    Do you have a Linux desktop machine available?
    If so, could you open a file manager and type this at the address bar (of course, use your OMV machine's IP address):


    smb://test@192.168.100.100

  • i have no idea why, but my Network-ID is grey....

    The Network-ID setting doesn't matter. The button below it ( Change ) will let you change the workgroup name.
    ____________________________________________________


    You have two choices.


    Open permissions:
    Your permissions should work if your Shared Folder is set to Others Read/Write and the CIF/SMB network share set to Guests Allowed.


    switched to acl and created some new folders with acl rights.
    always the same result


    ...but the public folder works fine

    This is probably the root of the issue. Linux has two different permission types. Basic permissions (posix) and ACL's. Basic permissions are Owner, Group and Others. This is what you should be using.


    In OMV, when you create a user, the user is added to the "users" group. ("Users" is the actual name of the group.) When you create a shared folder, the users group is given read and write access to it by default. That's the first part of it.
    Where your windows client is concerned, you log onto the client with a username and password. For this example we'll say the user name if Fred and the password is pass1word
    If you want transparent access to a network share that has permissions enable, from that client, you need to create a user in OMV named Fred (caps and all - Fred is not the same as fred in Linux). The password should be the same as the client logon as well, pass1word


    _____________________________________________________


    If you get into ACL's (that's the upper right hand box where access can be set by username, etc.) mixed in with Basic permissions (the lower area where Owner, Group, and Others is set), good luck. The two can conflict. The real world effects of using both that can get complicated, real quick. Basic permissions; Owner, Group, Others has all the flexibility that a home NAS user would need.

  • In OMV, when you create a user, the user is added to the "users" group. ("Users" is the actual name of the group.) When you create a shared folder, the users group is given read and write access to it by default.

    that is exactly what i expected....


    when i create a public folder with r/w rights for guests....i can access it.


    when i create a user and a folder for that user with r/w rights, i see it in the network overview too.
    but i can't login. test ( created user / group users ), admin and root are not accepted

  • when i create a user and a folder for that user with r/w rights,

    This is the reason why I believe you're trying to use ACL's - not a good idea.
    ___________________________________________________________________________


    There's two levels of access consider:


    - Shared Folders:
    Owner, Group, Others
    (The Group should be set to users and Read/Write)
    - CIF/SMB:
    Without getting into the extra options, there's two useful permissions settings under "Public". "Guests allowed" and "No".
    If "No" is selected, SMB will use the file/folder permissions set on the shared folder.


    If you have the identical Username and password installed on OMV, that Windows client using the same username and password, gets access.
    ________________________________________________


    On the other hand, if you're using the permissions box in the upper right where there's a list of usernames and groups, that activates ACL's. (The red box in the pic below
    Advice: If you've checked boxes up there, uncheck them and leave it alone. (I'd recommend using Basic file and folder permissions, that are shown in the green box.)


    basic-acl.jpg



    If you want to go ACL route, I don't think the experienced users on this forum will want to help you. Mixing Basic permissions with ACL's opens a can of worms. It's too complicated to try to work on, from remote. You'd need to do your own research along those lines.
    ________________________________________



    For those reading this thread:
    If Guests Allowed in the SMB share is used, that will work with Others, Read/Write in shared folder permissions.)
    These settings allow anyone on the local network access to the share.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!