Samba error

  • Hi All,

    when apply configuration after to have enabled Samba I've this error:

    Errore #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run samba 2>&1' with exit code '1': /usr/lib/python3/dist-packages/salt/utils/ DeprecationWarning: Using or importing the ABCs from 'collections' instead of from '' is deprecated, and in 3.8 it will stop working if isinstance(values, collections.Hashable):debian:

    My version is 5.3.4-1.

    See the complete error report on attachment.

    Thank you!

  • Were you able to find a fix or update to this? I'm struggling with the exact same issue, and not sure how to fix this. Have spent a long time online looking for an answer but have had no luck. I would appreciate a fix was looking forward to using this software but unable to set this share up, rendering openmediavault useless for me because of this error.

    I've attached my error message. Hope to have a fix soon!

  • Hey guys, I tried installing OMV 4, instead of 5, which is the most stable version, and haven't had any issues... :)

    I still would love to see a fix for this though for OMV 5, i noticed this problem also occurs when trying to enable FTP.

  • I don't what changes, but my Samba service on Macbook is terrible.

    It very slow loading when I tried to access the shares, and it sometimes disconnected automatically.

    I've tried a few tweaks but no luck.

    I have no issue when I access the same shared folders on Nextcloud.

    Update: Clamav on-access scan was the culprit !

    OMV v5.0
    Asus Z97-A/3.1; i3-4370
    32GB RAM Corsair Vengeance Pro

    Edited once, last by tinh_x7 ().

  • Same problem here, same error message, Under openvediavault version 5.3.8-1(Usul).

    See attached SMB_CIFS_error.txt

    Under Dashboard/Services SMB/CIFS shows a green light under Running but no green light under Enabled.

  • Update:

    After reading over the error text, i found this entry:

    netbios name WIN-87JF1A9EGM4-OMV5 is not a valid netbios name

    ERROR: Invalid smb.conf

    I proceeded to change my Hostname under Network settings to a valid and shorter netbios name and guess what it work now!

    i hope this helps!

  • Hello, i hada the same problem: After reading the output from testparm, i see that my hostname was to long .

    So i change the hostname, restart the server and now Its WOTKING!!!!


  • Yeah I had that exact same issue.

    IMHO, the Network-General-Hostname section should either:

    A) Prevent you from setting a hostname that is longer than 16 characters or

    B) At the very least give a warning when the hostname is longer than 16 characters that there will be issues with enabling SMB/CIFS Shares

  • OMV5 has been a complete backward step from OMV4 - not recommended from my side.

    all things previously working, no long work. e.g. samba, nut, plex (is not even a plugin any more, not to mention mysql plugin is gone, etc)

    I got those errors as well when trying to enable via the gui.

    if i run systemctl start smbd it works fine.

    so basically, via the gui

    - you can't start samba

    - you can't turn off/quote quota

    - you can't install nut

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!