• Hi guys,


    Should /dev/zram0 log2ram show up in GUI as mounted?

    Please see attachment.


    Code
    lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 931.5G 0 disk
    └─sda1 8:1 0 931.5G 0 part /srv/dev-disk-by-label-HGST7K10001TB
    sdb 8:16 0 1.8T 0 disk
    └─sdb1 8:17 0 1.8T 0 part /srv/dev-disk-by-label-2TBWDRED
    mmcblk0 179:0 0 14.9G 0 disk
    └─mmcblk0p1 179:1 0 14.7G 0 part /
    zram0 252:0 0 50M 0 disk
    zram1 252:1 0 494.7M 0 disk [SWAP]


    Thanks,

    Kris

  • I am currently looking into ram logging on my rock64 running Armbian 5.4 Buster.


    Armbian uses armbian-ramlog that I think uses log2ram


    The OMV config I use has the folder2ram plugin enabled. I'm not sure both are needed and I have issues with logrotate at the moment.


    I have disabled armbian-ramlog and will see how things work over the next couple of days and report back.


    Is your NanoPi running armbian?

  • I use NanoPi M4 (Debian Buster with Armbian Linux 4.4.192-rk3399), the distribution of the memory looks like this:



    [LibreELEC @ 2x RPi3, CoreELEC @ S12 Octa Core]

    [ NAS OMV 5.xx (Usul) @ NanoPI M4 ]

    [ Nextcloud 18.0.4 @ ODROID C2 ]

    [ Motioneye @ RPi4]

  • I have disabled armbian-ramlog and will see how things work over the next couple of days and report back.

    the install script disables log2ram and armbian-ramlog - https://github.com/OpenMediaVa…/blob/master/install#L219. So, you shouldn't have any problems.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • ryecoaaron I use the install script and I don't think it is disabling armbian-ramlog. On rock64 buster with kernel 5.4 it is not disabling and I have done around 5 clean installs over the last month or so. I'm using the script below.


    https://github.com/OpenMediaVa…Script/raw/master/install | sudo bash


    I noticed this issue and after a bit of investigating, I have disabled armbian-ramlog manually and logrotate is working fine now.


    forgot to say that I used this thread to work out how to disable ramlog


    https://forum.armbian.com/topi…an-ram-logging-correctly/


    In summary, I did the following and then did a reboot


    systemctl disable armbian-ramlog

    systemctl disable armbian-zram-config

    changed the enabled flag to false in etc/default/armbian-ramlog

    changed the enabled flag to false in etc/default/armbian-zram-config

    commented out all lines in etc/cron.daily/armbian-ram-logging

  • I use the install script and I don't think it is disabling armbian-ramlog. On rock64 buster with kernel 5.4 it is not disabling and I have done around 5 clean installs over the last month or so. I'm using the script below.

    I'm quite sure the service will not run if it is disabled and stopped. I have Armbian installed on an odroid-n2, rock64, renegade, nano pi m4, odroid hc2, and rock pro 64 right now and none of them have armbian-ramlog running.

    In summary, I did the following and then did a reboot

    Disabling the service means the value in the default files doesn't matter. I guess I will disable armbian-zram-config and remove armbian-ram-logging cron job as well (script is not doing that now).

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Strange that the service does run on my clean install(s) of Armbian rock64 with OMV script. I am using latest Buster 5.4 image from the armbian website.


    Have you done a install using latest build?


    It is all fine now as I have disabled manually but it could affect others so I thought I would report it here.

  • Have you done a install using latest build?

    At least one is. The odroid-n2 is running Armbian_20.02.5_Odroidn2_buster_current_5.4.27. The unit file's name hasn't changed. So, systemctl disable should've worked. Maybe armbian package upgrades re-enable it? I can't explain why it is running.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Disabling the service means the value in the default files doesn't matter.

    I changed the values back to enabled in the default files and rebooted. After reboot the services do not start (as expected) but the armbian-ramlog does execute logrotate and this prevents OMV logrotate from working.


    Changed the enabled setting back to disabled and rebooted. Now everything fine again. So long story short is that you do need to do all of the following to fully disable armbian-ramlog


    systemctl disable armbian-ramlog

    systemctl disable armbian-zram-config

    changed the enabled flag to false in etc/default/armbian-ramlog

    changed the enabled flag to false in etc/default/armbian-zram-config

    commented out all lines in etc/cron.daily/armbian-ram-logging

  • Same here on HC2.


  • I already had this cron file commented out but it still ran armbian-ramlog


    The only thing that I have found to stop it is to change the enabled flag in the default files below...


    changed the enabled flag to false in etc/default/armbian-ramlog

    changed the enabled flag to false in etc/default/armbian-zram-config

  • I already had this cron file commented out but it still ran armbian-ramlog

    If the commands were commented out (just delete the file), it didn't run ambian-ramlog. Something else did and I think that should be found. Either way, I changed the install script to disable the two items.

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Understood. I have no idea what else could be triggering ambian-ramlog but something is and, therefore, the issue will persist for armbian builds.


    I'm just a noob with enough knowledge to be dangerous but happy to help if I can. Sorry if I am not being helpful.

  • Here is the real fix - https://github.com/OpenMediaVa…/blob/master/install#L236


    Found it with:


    root@odroidn2:/etc# grep -r armbian-ramlog *

    systemd/system/logrotate.service:ExecStartPre=/usr/lib/armbian/armbian-ramlog write

    systemd/system/logrotate.service:ExecStartPost=/usr/lib/armbian/armbian-ramlog postrotate

    omv 5.5.1 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello ryecoaaron,

    I'm using Ordoid XU4 (Raspbian). I installed a new fresh system today with OMV on top of it with your installation script. And now I don't have any /dev/zram device and also don't have any swap anymore. Went through latest changes and find that topic. Is it an expected behavior?

    Code
    root@odroidxu4:~# lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 5.5T 0 disk
    mmcblk0 179:0 0 29.1G 0 disk
    └─mmcblk0p1 179:1 0 28.8G 0 part /
    mmcblk0boot0 179:16 0 4M 1 disk
    mmcblk0boot1 179:32 0 4M 1 disk
    Code
    root@odroidxu4:~# free
    total used free shared buff/cache available
    Mem: 2043820 191824 1533760 28384 318236 1761480
    Swap: 0 0 0

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!