Mergefs folders

  • Hello!

    Don`t know if it is normal, but could not add "nofail" on mergefsfolders 5.0.3 from gui.

    If added when created, it shows error. If added after created, by editing from gui, it does not show on /etc/fstab.

    I had to manually add it in /etc/fstab file.

    Is this normal behavior?

  • There is no mention of "nofail" in the mergerfs documentation. Where are you getting this from?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • You would add "nofail" to the mount statement for the disk mount statement, not in the mergerfs mount statement.


    It's probably already there as a default. Have you looked in fstab?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Here is a part from fstab:

    Code
    # >>> [openmediavault]
    /dev/disk/by-label/hdd1part1 /srv/dev-disk-by-label-hdd1part1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    /dev/disk/by-label/hdd1part2 /srv/dev-disk-by-label-hdd1part2 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    /srv/dev-disk-by-label-hdd1part1/1:/srv/dev-disk-by-label-hdd1part1/2:/srv/dev-disk-by-label-hdd1part1/3 /srv/e93164c3-0afa-4475-968d-57112d83f945 fuse.mergerfs defaults,allow_other,cache.files=off,use_ino,category.create=epmfs,minfreespace=4G,fsname=Utilizator:e93164c3-0afa-4475-968d-57112d83f945,x-systemd.requires=/srv/dev-disk-by-label-hdd1part1,x-systemd.requires=/srv/dev-disk-by-label-hdd1part1,x-systemd.requires=/srv/dev-disk-by-label-hdd1part1 0 0
    # <<< [openmediavault]

    There is "nofail" on lines 2 and 3, but not on line 4.

    If booting this way, it does not reach to omv gui it hdd not connected.

    If adding "nofail" to line 4, it boots normally.

  • I don't know what to tell you other than "nofail" is not a valid mergerfs mount point option. This is why it is not available in any OMV mergerfs plugin. Read the mergerfs documentation yourself if you don't believe me.


    I suspect that your mergerfs mount statement (line 4) is improper to begin with. You have /srv/dev-disk-by-label-hdd1part1/3 in that statement but it does not appear in any other disk mount statement .

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Line 4 was added by OMV mergefs plugin gui, not manually.

    Manually would add "nofail" to boot withoud hdd. And it boots without hdd.

    Just because the plugin added line 4 doesn't make it correct. I pointed out that it contains a reference to a drive or partition not seen elsewhere in the fstab fragment you posted. You haven't had anything to say about that yet. This is where you should be looking.


    And for the last time, "nofail" is not a supported mergerfs mountpoint option. Using it may allow the boot to continue by ignoring errors that would have prevented getting further in the boot. But nofail can not and will not correct any errors it allows to be ignored.


    And for FYI, any manual edits to fstab within the openmediavault stanza are likely to be lost the next time OMV triggers a rewrite of the file.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Just because the plugin added line 4 doesn't make it correct. I pointed out that it contains a reference to a drive or partition not seen elsewhere in the fstab fragment you posted. You haven't had anything to say about that yet. This is where you should be looking.

    Please do not get mad at me!

    I am trying to merge 3 folders into one, share it using smb and them mount it as a drive letter on windows.

    The gui from mergefs folders is not working as is should, it does not open the browse window when the button is pressed (red arrow on attachment) and pasted paths is that window. This is what you were asking? Shoud I do it otherwise?

    And what hdd would this be?

    It is a 2.5 inch spinning, 500gb, 2 partitions: hdd1part1 and hdd1part2

  • Your link to some picture is dead.


    I don't use any mergerfs plugins here. But if the drop down list in the plugin doesn't work it's either because you did some operation outside the OMV GUI and it doesn't know about what you did, or you needed to define a shared folder first and didn't.


    And what about /srv/dev-disk-by-label-hdd1part1/3 where is this coming from? This is likely the source of all your problems.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Your link to some picture is dead.

    Reuploaded the picture.

    I don't use any mergerfs plugins here. But if the drop down list in the plugin doesn't work it's either because you did some operation outside the OMV GUI and it doesn't know about what you did, or you needed to define a shared folder first and didn't.

    It has the same behavior since first installed OMV 5. Not made operations outside OMV GUI.

    There are some shared folders defined, but the button does not work.

    And what about /srv/dev-disk-by-label-hdd1part1/3 where is this coming from? This is likely the source of all your problems.

    Copied the paths from a parent shared folder found in /srv and pasted in the mergefs folders gui.

    The parent folder is already shared.

  • Post your entire fstab file.


    If the file browser in the plugin is broken, try a different browser, make sure you have disabled any popup blockers, and remove and reinstall the plugin if it still doesn't work. If that doesn't fix it them paste the correct absolute paths to the folders into the box, one per line. Do not use sharedfolder paths.


    Are you manually creating Line 4 of your fstab or is OMV creating that for you?

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Code
    proc /proc proc defaults 0 0
    PARTUUID=738a4d67-01 /boot vfat defaults 0 2
    PARTUUID=738a4d67-02 / ext4 noatime,nodiratime,defaults 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that
    # >>> [openmediavault]
    /dev/disk/by-label/hdd1part1 /srv/dev-disk-by-label-hdd1part1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    /dev/disk/by-label/hdd1part2 /srv/dev-disk-by-label-hdd1part2 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
    /srv/dev-disk-by-label-hdd1part1/1/:/srv/dev-disk-by-label-hdd1part1/2/:/srv/dev-disk-by-label-hdd1part1/3/ /srv/26b47f43-0bba-4a25-bd4a-1b32ad55e8ed fuse.mergerfs defaults,allow_other,cache.files=off,use_ino,category.create=epmfs,minfreespace=4G,fsname=Utilizator:26b47f43-0bba-4a25-bd4a-1b32ad55e8ed,x-systemd.requires=/srv/dev-disk-by-label-hdd1part1,x-systemd.requires=/srv/dev-disk-by-label-hdd1part1,x-systemd.requires=/srv/dev-disk-by-label-hdd1part1 0 0
    # <<< [openmediavault]

    If the file browser in the plugin is broken, try a different browser, make sure you have disabled any popup blockers, and remove and reinstall the plugin if it still doesn't work.

    Tryed 3 browsers: Chrome, Firefox, Edge - same behavior. Firefox and Edge - no popup blockers - same. Reinstalled - same behavior.


    If that doesn't fix it them paste the correct absolute paths to the folders into the box, one per line. Do not use sharedfolder paths.

    Those paths are not to be found somewhere else. I think it is the correct ones.

    BTW, my /dev/disk/by-label folder is empty. fstab file reffers to it.

    Are you manually creating Line 4 of your fstab or is OMV creating that for you?

    OMV is creating it.


    Edit: don`t know if it is related to this, but now putty is not allowed to connect to OMV from windows.

  • This element in Line 4 of your ftsab, /srv/dev-disk-by-label-hdd1part1/3/, needs to be explained. What is in that directory and how did it get there?


    In line 4 you have this element three times, x-systemd.requires=/srv/dev-disk-by-label-hdd1part1 that can't be right.


    About all I can say is that the mergerfs plugin is misbehaving. I have no answers for that as I don't use it. I code my merged folders by hand in fstab.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Quote

    This element in Line 4 of your ftsab, /srv/dev-disk-by-label-hdd1part1/3/, needs to be explained. What is in that directory and how did it get there?

    There are folders and files in it.

    It got there from mergefs folders plugin. It is a folder on my hdd.

    Quote

    In line 4 you have this element three times, x-systemd.requires=/srv/dev-disk-by-label-hdd1part1 that can't be right.

    Maybe one time for each folder? Three folders merged.

    Quote

    About all I can say is that the mergerfs plugin is misbehaving. I have no answers for that as I don't use it. I code my merged folders by hand in fstab.

    How to announce the developer to have it fixed?

    I would like to use merged folders your way, not necessary by gui. Can you teach me?

  • It is a 2.5 inch spinning, 500gb, 2 partitions: hdd1part1 and hdd1part2

    OMV does not use partitions it uses the whole disk, you have created the above using something like gparted!


    My understanding of how the mergerfs folder plugin works, let's say we have 3 drives;


    hdd1

    hdd2

    hdd3


    The drives have been given the above labels and have an ext4 file system put on them


    On each of the three drives we create a folder media, media1, media2


    I have completed the above from a VM and I can confirm that the option to select the path in the plugin does not populate, but for reference this is my fstab on the VM

    ryecoaaron mergerfs folder plugin does not appear to populate when selecting the 'browse folder' in the paths

  • OMV does not use partitions it uses the whole disk, you have created the above using something like gparted!

    Yes, gparted before OMV. Is this a mistake?

    My understanding of how the mergerfs folder plugin works, let's say we have 3 drives;

    I am not an expert, but reading the plugin descripiton ("Makes it possible to pool folders under a single mountpoint with mergerfs.") makes me think that is made for joining folders into one.


    Waiting for an official explanation about how to use it correctly.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!