Upgrade OMV4 to OMV5 with Plex Media server installed

  • Hello,

    I would like to update OMV4 installed on my OdroidHC2 to OMV5 (using this script). But before I would like to be sure that my Plex Media Server won’t be broken.

    I installed and I maintain Plex Media Server on my machine directly from the command lines as root and not through the OMV web interface (neither plugin nor Docker).

    Before upgrading OMV4 to OMV5 it is recommended to uninstall OMV plugins, this is why I’m not sure about the script impact on my Plex Media Server installation.

    Maybe I should uninstall Plex before? If someone knows how to migrate securely OMV4 to OMV5 without broke Plex Media Server it could help me 🙂

    Thank you ✌️

    (Plex Media Server Version:

    Odroid HC2 - armbian - OMV5 ✌️

  • brnltn

    Added the Label resolved
  • Afternoon all/

    Hope this is the right place and I've broken no forum rules, I'm completely new to this.

    I've upgraded from OMV 4 to 5 this afternoon after upgrading from 3 to 4 a couple of days ago and then realising that 4 was eol'd as well!

    My hardware is an HP Micro server N54L AMD turion II I bought used off a colleague for £40 or so.

    It sits there running a raid of 4 x 1TB HDDs holding the local copy of the family photos and some tv and films accessed by the Plex media server plugin.

    I'm ssh'd from Linux Mint running on a ten year old SFF Acer PC!!

    I followed the notes in the OMV forum "OMV 5.0 - finally out! :) page #38"

    Here's the edited history of how this afternoon went, maybe it helps somebody;

    452 wget -O - https://github.com/OpenMediaVa…pt/raw/master/upgrade4to5 | sudo bash

    This script failed to finish on my machine.

    453 reboot

    471 apt-get purge openmediavault-omvextrasorg resolvconf

    Still broken, apt-get purge recommended to run the following apt --fix-broken command.

    472 apt --fix-broken install

    Said N to installing new versions.

    It fixed loads of stuff probably from previous upgrades and attempts and me thrashing around in the dark.

    473 wget -O - https://github.com/OpenMediaVa…pt/raw/master/upgrade4to5 | sudo bash

    This second attempt got a lot further than #452 but still failed at the very end but I thought a reboot was worth it.

    474 reboot

    475 apt --fix-broken install

    This did a few more fixes and looked hopeful so tried continuing;

    476 apt-get purge openmediavault-omvextrasorg resolvconf

    Didn't complete fully so tried this again;

    477 apt --fix-broken install

    And it fixed some more.

    478 apt-get purge openmediavault-omvextrasorg

    Completed without error.

    Ran the next command on the forum page.

    479 wget -O - https://github.com/OpenMediaVa…ckages/raw/master/install | bash

    Completed without error.

    480 apt-get update

    Completed without error

    481 apt-get dist-upgrade

    Completed without error but whinged about a load of unused packages and suggested running;

    482 apt autoremove

    Which removed them and completed without error

    483 reboot

    Logged in from web ok, cleared browsr cache and reported version omv 5.

    Did a couple of things and then got the dreaded 502 nginx message in the browser instead of the login screen.

    More googl-ing

    484 omv-firstaid

    Didn't fix anything

    487 omv-mkconf nginx

    Mis-direction, omv-mkconf doesn't exist in omv 5 apparently

    490 omv-salt deploy run nginx

    Didn't fix the web login

    495 dpkg -l | grep openm

    ii openmediavault 5.5.12-1 all openmediavault - The open network attached storage solution

    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive

    ii openmediavault-omvextrasorg 5.4.2 all OMV-Extras.org Package Repositories for OpenMediaVault

    ii openmediavault-plexmediaserver 3.8.2 all OpenMediaVault Plex Media Server plugin

    496 apt --fix-broken install

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

    So nothing to fix, hmm, what now? more googling.

    497 omv-firstaid

    Still didn't help.

    498 omv-salt deploy run phpfpm

    FIXED the web login and plex survived the upgrade and is still up and running - bonus.

    So got there in the end, thanks everyone for all the hard work and info..

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!