Quota Error when mounting XFS FileSystem

  • New NAS Running 5.5.12-1 (Usul). Wiped the Drive. Created a new XFS File System. Mount Drive. Get this Error

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color quota 2>&1' with exit code '1': helios64: ---------- ID: quota_off_no_quotas_e35288ac-2e6b-4730-8ddb-eae38f8f2011 Function: cmd.run Name: quotaoff --group --user /dev/disk/by-label/SDAParity Result: False Comment: Command "quotaoff --group --user /dev/disk/by-label/SDAParity" run Started: 21:48:05.765448 Duration: 19.6 ms Changes: ---------- pid: 11353 retcode: 2 stderr: quotaoff: Quota enforcement already disabled for group on /dev/sda1 quotaoff: Quota enforcement already disabled for user on /dev/sda1 stdout: ---------- ID: quota_off_no_quotas_ad59dd54-f620-4af2-95b4-26fb5b5033c6 Function: cmd.run Name: quotaoff --group --user /dev/disk/by-label/SDBData1 Result: True Comment: Command "quotaoff --group --user /dev/disk/by-label/SDBData1" run Started: 21:48:05.785679 Duration: 20.153 ms Changes: ---------- pid: 11355 retcode: 0 stderr: stdout: ---------- ID: disable_quota_service Function: service.disabled Name: quota Result: True Comment: Service quota is already disabled, and is in the desired state Started: 21:48:05.846727 Duration: 110.473 ms Changes: Summary for helios64 ------------ Succeeded: 2 (changed=2) Failed: 1 ------------ Total states run: 3 Total run time: 150.226 ms

    It seems to be something to do with quotas which I don't use. I've gone as far as disabling quotas for my entire OS but it's still happening. Any help would be appreciated.

  • I initially ran that command as I saw it in a previous post. Still had the problem so instead I ran

    sudo quotaoff -a

    which didn't work either.

    I ran it again just now for certainty Same Error though I'm afraid. Output below

  • I am having the same problem.. glad I am not the only one.

    I believe this is a bug related to a recent change in this pull request #802:


    The error is occurring when the following command is executed against my XFS filesystem. On EXT4 disks, its return code is 0, but on the XFS disk its return code is 2, which OMV is treating as an error. For some reason, the return value of this command is different depending on the filesystem type that is queried.

    quotaoff --group --user /srv/dev-disk-by-label-nas_data4

    It seems like there is a XFS blacklist check missing on the quotaoff command?

    UPDATE: I installed the openmediavault package version 5.5.9 and this bug went away! This is definitely a new bug related to the recent bug fixes made to the quota management.

  • This reverting in-place is likely not a "supported" method, but it has worked fine for me so far this evening. YMMV

    From a console on your NAS, you can manually download and install the old .deb file:

    wget https://github.com/openmediavault/packages/raw/f947c2428afabad4297bbf989c287bf35ccf575d/pool/main/o/openmediavault/openmediavault_5.5.9-1_all.deb
    dpkg -i openmediavault_5.5.9-1_all.deb


  • Another thank you for Kurgh; their fix worked for me.

    I just re-created my NAS in a Proxmox VM and all of my media drives are XFS. This downgrade makes my install functional with the sole caveat of remembering not to upgrade that package.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!