Dialog Windows Always Maximized

  • Just installed OMV5.

    Is it me or now by default every popup dialog window is always maximized?

    I flushed my cache, reset UI to defaults, tried private mode, different browser, clicked the small double arrow and repositioned the dialog to no avail: every time a new dialog opens it's maximized and covers the whole page.

    What's going on?

  • On Chromium, I see that but not on Firefox. It is a browser difference.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • It is something related to the whole system on my PC, just tried on a laptop and all is normal there.

    But on my PC any browser I try, Chrome, Firefox or Edge behaves the same.

    That's very strange, I'll try on a different user on the same machine.


    EDIT: just tried, it seems it's not related, even on a fresh user I get the same.

  • just tried on a laptop and all is normal there.

    so OMV is not to blame :)


    If a full de-install/re-install of browser doesn't cure the issue, the next step would be to re-install the PC from scratch or accept the annoyance and live with it

    omv 5.6.5-1 (usul) on RPi4/4GB with Kernel 5.10.x and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • EDIT: just tried, it seems it's not related, even on a fresh user I get the same.

    Check the DPI scaling, right click on the desktop and select display settings, check scaling and layout this should be set to 100%

    Raid is not a backup! Would you go skydiving without a parachute?

  • so OMV is not to blame :)


    If a full de-install/re-install of browser doesn't cure the issue, the next step would be to re-install the PC from scratch or accept the annoyance and live with it


    Well not really a solution is it? Especially when nothing apart from this is wrong with my system.

    And it's not about blaming anything, it's about reporting something that isn't working properly for no apparent reason.


    I suspect that there's some issue in how OMV5 detects if the device is mobile or not because I just noticed that this is the default behaviour on a mobile device (just tried on my tablet).


    Quote

    Check the DPI scaling, right click on the desktop and select display settings, check scaling and layout this should be set to 100%


    No issues there, I always set it to 100%.

  • In your image in #4 click on the double arrow next to the X I believe that is a 'docking' option

    Like I said in #1, already clicked there. The popup does return kinda to normal but is only temporary.

    As soon as I close it and reopen a new dialog I get the same maximization.

  • It's very odd, didn't have this on OMV4.

    And I don't have any issues for sure on any other site misbehaving like this between mobile or desktop css.


    Tried on a virtualized Win10 on the same machine, no problems there too.

  • This is an extjs issue detecting the browser. Since extjs hasn't been updated (no version for OMV to update to), this will be difficult to fix.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Well I guess it will not be a problem any more when extjs will be dropped in the new OMV6 UI then.

    Correct.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • PigCop

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!