Can't delete SMB shares after removing associated device

  • I had to delete a Union Filesystem because of some errors without removing the associated Samba shares first.


    Now the shares show no device referenced, and if I try to delete them and commit the changes through GUI, I get an error that TL:DR says it cannot find the device (because it no longer exists) nor save the changes.



    Can I manually delete those shares in any way?

  • manuel5cc

    Added the Label resolved
  • I ran into a similar issue, which I fixed by going into /etc/openmediavault/config.xml. However, when navigating using the file explorer, I still see an old folder that I cannot seem to delete.


    Is there an easy way to delete? I haven't put any files into the nas as I am new and just setting this up with an old desktop and harddrives I had lying around

  • I ran into a similar issue, which I fixed by going into /etc/openmediavault/config.xml. However, when navigating using the file explorer, I still see an old folder that I cannot seem to delete.


    Is there an easy way to delete? I haven't put any files into the nas as I am new and just setting this up with an old desktop and harddrives I had lying around

    Maybe you have to restart samba to see the changes.


    Also try to delete it via ssh using this command:

    sudo rm -rf /path/to/folder


    Note that this will recursively delete the folder and its content.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!