Plugins unavailable after reinstall

  • I had to reinstall OMV. I installed 5.5.1 and updated to version 5.6.1-4 (Usul). I noticed a lot of the plugins I had available for installation before were missing (I'm interested in SnapRAID and mergerfs/unionfs for now). I installed OMV-Extras, but although the extras are visible in the web interface, I still don't see a lot of the other plugins listed in the System -> Plugins tab. E.g., SnapRAID, mergerfs and the ZFS (although I don't need it ATM) are still not listed. On the other hand, some plugins such as openmediavault-tftp openmediavault-usbbackup are listed.


    I've installed OMV Extras via the wget -O - https://github.com/OpenMediaVa…ckages/raw/master/install | bash script, and after I still didn't see the plugins, I uploaded the .deb file which contains those plugins, but neither approach has enabled me to see the plugins I mentioned I need.


    What can I do to install SnapRAID & mergerfs?

  • crashtest

    Approved the thread.
  • Disregard.. the script should work no problem.. are you sure it's not a cache issue??

    As sure as I can be. I deleted Chrome's cache, still got the same problem. I just reinstalled OMV for a second time, and tried from a different browser - still the same.

  • What is the output of


    dpkg -l grep openmedia


    Any error message when executing the script?

    Output is


    Code
    dpkg-query: no packages found matching openmedia
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-==============-============-============-=================================
    ii grep 3.3-1 amd64 GNU grep, egrep and fgrep
  • That should be dpkg -l | grep openmedia Lost the pipe

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • That should be dpkg -l | grep openmedia Lost the pipe

    Here's the new output:

    Code
    ii openmediavault 5.6.4-1 all openmediavault - The open network attached storage solution
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-omvextrasorg 5.6 all OMV-Extras.org Package Repositories for OpenMediaVault
  • omv-extras is installed. What is the output of:


    sudo omv-salt deploy run omvextras

    sudo apt-get update

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • omv-extras is installed. What is the output of:


    sudo omv-salt deploy run omvextras

    sudo apt-get update

    sudo omv-salt deploy run omvextras:


    sudo apt-get update:


    Good news is that after executing these two commands, I can now see the 3rd-party plugins. I just now installed SnapRAID and mergerfs. Thanks a lot!


    If you have an explanation for future users, though, do share it, cause I was quite a bit perplexed.

  • Without seeing the output from your previous installation attempts, it is hard to say. omv-extras must not have installed correctly though because it actually performs the two commands I told you to run.


    The following will fix that warning as well


    sed -i '/security/d' /etc/apt/sources.list

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!