OMV6 : memory leak ?

  • Hello there,




    I did Install OMV6 6.0-17 (Shaitan) on a separate hardware:

    By the way, very nice UI improvements ! :thumbup:


    No docker app running except Portainer.

    I have let the system running (idle) for a few days and I noticed that the used memory in the Dashboard move from 5% to 10% in 1 week. (I have 16 GiB)


    Let me know if there are logs or other that will/could help narrow down the issue (if any)


    Kind regards


  • Linux uses memory for filesystem cache. What are you worried about?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • just trying to help ...

    And I'm not saying you shouldn't try to help. If you look at the output of top or look at Diagnostics -> Processes, you can see which processes are using what percentage of ram. You can also see the buff/cache amount in the MiB mem line. That amount can be reclaimed at any time for processes that need it. Even if Linux is 95% of the ram and most is in buff/cache, you have nothing to worry about. Linux works much different than Windows.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The system is really idle doing nothing...... (from my user point of view)

    If you have monitoring enabled, then collectd is constantly collecting data from your system and I could see that using a bit of filesystem cache.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • With monitoring turned off = Same thing: going from 5% just after reboot to 10% in less than a week.

    I just wanted to draw the attention to this point.

    It is up to you to decide if it is a real issue or just normal behaviour (as previously replied)
    I will now move on and add more software to the config so for me this closed


    Thanks for OMV: it is a great platform !!!

  • macom

    Added the Label resolved
  • macom

    Added the Label OMV 6.x (alpha)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!