Set FTP Server to Show File Modification Timestamps in Local Timezone instead of UTC

  • Hello all,


    I have noticed that ProFTPD shows modification timestamps for files in UTC instead of my local timezone. Does anyone know how to adjust this? I found in the documentation that setting TimesGMT off as a custom configuration entry should change this behavior, but it hasn't.


    I also found a supposed solution here that recommends setting the following:

    Code
    <Global>
    TimesGMT off
    SetEnv TZ :/etc/localtime
    </Global>


    I have tried to use this in the custom configuration with and without the <Global> tags, but nothing seems to work. The FTP client that I am using is FileZilla, if that makes any difference.

  • Sorry, I have never used ftp and really don't know much about proftpd.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sorry, I have never used ftp and really don't know much about proftpd.

    That's alright! Thanks anyway! I just assumed that you would know because it feels to me like you know all that their is to know about Linux. 🙂

    Try to add it to the extra options field in the ftp service in the GUI of OMV

    If you are talking about this box, then I have already tried it (see initial post), and sadly, it did not work.


  • That's alright! Thanks anyway! I just assumed that you would know because it feels to me like you know all that their is to know about Linux. 🙂

    If you are talking about this box, then I have already tried it (see initial post), and sadly, it did not work.


    This module is loaded by default: /etc/proftpd/modules.conf


    Code
    # the previous mod_sql.c module to use this
    #LoadModule mod_wrap2_sql.c
    LoadModule mod_dynmasq.c
    LoadModule mod_exec.c
    LoadModule mod_shaper.c
    LoadModule mod_ratio.c
    LoadModule mod_site_misc.c
  • This is partly correct, on Debian the required information is not in /etc/localtime, it's /etc/timezone; then it works. I will include the SetEnv TZ :/etc/timezone line in the next version.

  • votdev

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!