cannot remove aquota.user or aquota.group

  • good afternoon,


    I have a borked installation of plex on my .6 openmediavault.


    I have concluded that I will do a clean up and then resintall, however, having uninstalled the plugin etc I am left with a two files under /media/eaa2af40-6104-44bf-992a-f15702bd5535 that i cannot remove


    thus far i have tried


    chmod, chown, chattr -i all to no avail, all result in permission denied error on those two files.


    i have chmod -r on the parent directory and this makes no difference


    the two files in question are aquota.user and aquota.group


    what do i do now?


    thanks in advance,


    Dan

  • Why do you want to remove the aquota files? You can't remove them because they are in use by the quota service.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I have just installed Erasmus (previously I was on 2.2.13). My two data-only discs now have two new files on them, aquota.group & aquota.user.


    I don't know what quotas are but I'm pretty sure I don't need these files. I entered systemctl disable quota but I can't delete the files because the system will not grant me the permission.


    Can you please advise how to delete these files?

  • ...I can't delete the files because the system will not grant me the permission.


    I removed those two files as root without any problem.
    Actually disabling quota was an afterthought showed up long after the removal is done.


    Maybe you should edit fstab, disable quota on your two data drives & reboot, then try removing those files again?


    Edit: I hate formation tags.

  • aquota.group and aquota.user how to delete?

  • Did you stop the quota service?

    Code
    root@raspberrypi:/# systemctl stop quota
    root@raspberrypi:/# systemctl disable quota
    Synchronizing state of quota.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install disable quota
    root@raspberrypi:/#
  • So, can you delete the files now or not?

    No. :(




    Operation not permitted

  • The files should be 600 and owned by root:root. I don't understand why you would have a problem deleting them but I also don't understand why you care about them.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Does this user have the necessary rights?

    Yep because that user is in the sudo group. You really should create a new user instead of using the pi user though. Just make sure to add the user to the ssh and sudo groups.


    This looks bad

    It does? Part of the problem is that you are sharing the root of the drive. If you create a sharedfolder and move those current subfolders to the new sharedfolder, you wouldn't see stuff from the root of the filesystem.


    Otherwise (assuming this is a samba share), just add the following line to the share's extra options:
    hide files = /.*/aquota.*/

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!