Issues with Cloned Data Disk

  • Hi everyone,


    Just recently I have started to notice that one of my SSDs are showing bad sectors which is a sign of a disk starting to fail. It's not a large disk (250GB) and wanted to duplicate it to another 250GB SSD and just swap it within OMV.


    The disk is not a system disk and just stores my Plex server files and database. I have an external disk enclosure that can duplicate drives without connecting it with a computer. I have done this before with laptop drives and it has worked flawlessly. So I performed the duplication and took the new disk and placed it in the same location that the old disk was in within my OMV system. Booted up the system and it loaded OMV correctly.


    The issue from here is that the new disk and file system is visible within OMV. I can not navigate to the folder system within SAMBA and when I go to activate the Plex docker file (which points to the UUID of the new drive - which is also that same on the old disk due to it being dublicated) the system fails and won't read the data on the new drive.


    Am I missing any steps or did I do this correctly? Should I have unmounted the file system before I duplicated the old drive and inserted the new drive, then remount it? I tried to reset perms, but this did nothing.


    I played around with this for about an hour and couldn't get it to work. I inserted the old SSD (since it's still working - for now) and the system works great again. I would like to have the new disk in the system as a precaution.


    Any ideas or solutions would be greatly appreciated.

    Thanks

    • Official Post

    Whenever I cloned a drive with Clonezilla it worked as expected. I was able to just swap disks and it worked.


    You must not use both disks at the same time.


    The UUID must be the same of both disks. OMV identifies the disk by UUID.

    This sounds like the UUIDs are not the same.

    when I go to activate the Plex docker file (which points to the UUID of the new drive

    You can either set the UUID of the new disk to the same as the old disk. Or use Clonezilla to make an exact clone of the drive.

  • Just to clarify, I don't have both drives installed at the same time. I'm replacing the failing drive with a new one. The new one will be installed in the exact same place as the old one.

    I assume that I don't need to unmount the old drive before replacing/swapping for the cloned drive in it's place. OMV should keep the mount active (now with the new drive) and all the file systems associated with that drive?


    I will try and reclone the drive and try it again. I figured it should be a straight swap, but the issues I had above was confusing me. I will try it again and see if it was potentially an issue with the clone.

  • Yes they are exactly the same. I'm starting to think that it's a permissions/ share folder issue. Even though everything appears to be good, I can not access one of the shared folders through SAMBA. When I click on the shared folder in OMV admin and then click on The Access Control List icon I get this error message:


    Code
    Error
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export LANGUAGE=; getfacl --no-effective --access -- '/srv/dev-disk-by-uuid-673e2ffb-0aec-4f53-93fe-4b3ef987e8bc/Plex/' 2>&1' with exit code '1': getfacl: /srv/dev-disk-by-uuid-673e2ffb-0aec-4f53-93fe-4b3ef987e8bc/Plex/: Bad message

    The UUID is correct and I have removed the SAMBA shares and readded them and I can't seem to get past this error.

  • When I put the original disk back into the system, I can navigate to that share folder without issues. Based on that it looks like the bad sectors didn't affect the permissions and that ACL is probably needed.

  • Hello,

    I need to replace my data hard drive with another of the same brand and capacity. How can I clone my Openmediavault NAS disk identically in the best and safest way? I specify that the system is on another disk.


    Thanks for your help, I'm a beginner and don't know linux very well.

  • Hello,

    yes I saw that, but how do I use clonezilla on openmediavault?

    thanks

    You can't use clonezilla inside OMV. You need to boot from clonezilla. It is available in the kernel plugin to use as a boot option, or you can download it and write it to a bootable usb stick.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!