Upgrade to 1.0 did not work - "Welcome to Nginx"

  • Hi,


    I'm not able to access OMV via Webgui. Over HTTP I'm only getting a message with " Welcome to Nginx.." and over HTTPS theres no way to access webif ... here is the output for apt-get -f install :



    Please help :(

    • Official Post
    Code
    omv-mkconf nginx
    omv-mkconf php5fpm
    service apache2 stop
    service php5-fpm restart
    update-rc.d -f apache2 remove
    service nginx restart

    omv 6.0.46-5 Shaitan | 64 bit | 5.19 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.2.5 | mergerfs 6.3.3 | zfs 6.0.12
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Hello,


    I'm getting this error and still no WebGui:


    Restarting nginx: nginx: [emerg] invalid port in "[::]:" of the "listen" directive in /etc/nginx/sites-enabled/openmediavault-owncloud:2
    nginx: configuration file /etc/nginx/nginx.conf test failed


    chardignon

  • Hello,


    root@server:~# omv-mkconf nginx
    root@server:~# omv-mkconf php5fpm
    root@server:~# service apache2 stop
    [ ok ] Stopping web server: apache2.
    root@server:~# service php5-fpm restart
    [ ok ] Restarting PHP5 FastCGI Process Manager: php5-fpm.
    root@server:~# update-rc.d -f apache2 remove
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "nl_BE:nl",
    LC_ALL = (unset),
    LC_PAPER = "de_BE.UTF-8",
    LC_ADDRESS = "de_BE.UTF-8",
    LC_MONETARY = "de_BE.UTF-8",
    LC_NUMERIC = "de_BE.UTF-8",
    LC_TELEPHONE = "de_BE.UTF-8",
    LC_IDENTIFICATION = "de_BE.UTF-8",
    LC_MEASUREMENT = "de_BE.UTF-8",
    LC_TIME = "de_BE.UTF-8",
    LC_NAME = "de_BE.UTF-8",
    LANG = "nl_BE.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    update-rc.d: using dependency based boot sequencing
    root@server:~# service nginx restart
    Restarting nginx: nginx: [emerg] invalid port in "[::]:" of the "listen" directive in /etc/nginx/sites-enabled/openmediavault-owncloud:2
    nginx: configuration file /etc/nginx/nginx.conf test failed
    root@server:~#


    chardignon

  • You have an extra nginx configuration in sites-enabled producing errors (probably same port usage), move that configuration away from there. There should only be openmediavault there for now. Restart nginx and check if webinterface is back again.
    Report back please


    @tekkb this was eight hours ago, did you help him with TViewer before to pass the nginx error?


    What do I need to search for? A *.conf file?


    Update: Moved the file /etc/nginx/sites-enabled/openmediavault-owncloud so there was only "openmediavault-webgui" left in that directory. Rebooted and WebGui worked again!


    Update: After login to WebGui I can't save configuration: This Error:
    Error
    #4000:
    exception 'OMVException' with message 'Failed to execute command 'nginx
    -t 2>&1': nginx: [emerg] invalid port in "[::]:" of the "listen"
    directive in /etc/nginx/sites-enabled/openmediavault-owncloud:2
    nginx: configuration file /etc/nginx/nginx.conf test failed' in
    /usr/share/openmediavault/engined/module/webserver.inc:41
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/config.inc(180):
    OMVModuleNginxAbstract->applyConfig()
    #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array,
    Array)
    #2 /usr/share/php/openmediavault/rpcservice.inc(125):
    call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpcservice.inc(158):
    OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
    #4 /usr/share/openmediavault/engined/rpc/config.inc(224):
    OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
    #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array,
    Array)
    #6 /usr/share/php/openmediavault/rpcservice.inc(125):
    call_user_func_array(Array, Array)
    #7 /usr/share/php/openmediavault/rpc.inc(79):
    OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
    #8 /usr/sbin/omv-engined(501): OMVRpc::exec('Config', 'applyChangesBg',
    Array, Array, 1)
    #9 {main}


    chardignon


    @tekkb Samba shares are disabled, but I can't enable for now because of the configuration save error.

  • I am having the same issue - "welcome to nginx" displays, but no webgui.


    The steps indicated above by ryecoaaron did not work for me.


    I have my install log via ssh saved, and can display it here if that helps.


    Any help appreciated!

  • Hello all,


    I just tried to update to version 1.0 from 0.5.5x, and am running into this same problem.


    I followed the steps that ryecoaaron posted above and everything seemed to work fine, but for some reason it's still showing "Welcome to nginx!".


    Obviously I'm doing something wrong, but I'm not too sure what to do at this point. Any thoughts or suggestions would be appreciated.


    p.s. my other services seem to be working fine: smb shares, sickbeard, sabnzbd, etc. The only real problem seems to be the web interface.


    Thanks.

  • I have tried the above steps and still getting the "Welcome to Nginx" page.
    This is an update from 0.5.60 to 1.9.
    Here is my output of the apt-get -f install:



    The result is I only have the 'default' file in my '/etc/nginx/sites-enabled' directory.


    Any help would be appreciated.


    Thanks,

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!