ständiger Plattenzugriff

  • Hello,


    with

    Code
    cd /path/to/mountpoint
    fatrace -c -t -o outputfile.log



    you can create a log of all accesses to that directory and all subfolders while the tool is running.


    With


    Code
    awk '{print $1" "$2}' outputfile.log

    You can filter that log to remove duplicates. This way you can avoid guessing what is causing the spin ups/preventing spin down


    Greetings,
    Hendrik

  • Und wenn ich das Bild einfügen möchte (nicht hochladen), bekomme ich die Meldung, dass "nur" 10.000 Zeichen zur Verfügung stehen.

    Das scheint eine Eigenheit der Foren-Software zu sein, dass man Bilder (ab einer bestimmten Größe) nicht per Copy&Paste einfügen kann, sondern nur über die Hochladen-Funktion. Wenn ich mich richtig erinnere, dann gehe sehr kleine Screenshots schon. Bin mir aber nicht restlos sicher.


    Die Forenfehlermeldung mit der Fehlernummer, die hier niemanden interessiert ;) , bekomme ich auch gelegentlich. Ich warte dann immer schön 30 Sekunden und lade dann die Startseite des Forums erneut. <F5> vermeide ich, da damit der Post manchmal doppelt versendet wird.

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Hallo.


    Auch wenn es wirklich schon lange her ist, möchte ich den aktuellen Stand mitteilen. Vorab, ist hab die Ursache der Plattenzugriffe noch nicht gefunden.

    Was habe ich unternommen:


    Als root nach / gewechselt und dort mittels

    Code
    fatrace -t -o outputfile.log

    ein Log erstellt.

    Dieses grep nach sdb, sdc und md0 durchsucht. Ergebnis, nichts gefunden.

    Jedoch höre und spüre ich, wenn ich die Hand andas Gehäuse lege, in einem Intervall von ca.2 Sekunden, dass sich die Köpfe in den Platten bewegen.

    Wenn ich auf die Platten, z. B. über Samba zugreife, erscheint das im Log. sda ist die SSD, sdb und sdc die HDDs, md0 das daraus erstellte Raid 1.


    Kann ich noch irgendetwas unternehmen, die Platten direkt auslesen, eine neue Firmware aufspielen? Ich bin echt ratlos.

    Wie sollte ich das Powermanagement einstellen, damit die Platten nach 2 Stunden Nichtbenutzung sich abschalten?

    Und kann ich verhindern, wenn Windows / Linux die Platten als Freigabe eingebunden hat, dass diese bei Benutzung von Windows / Linux, ohne direkten Zugriff auf die Freigabe, die Platten geweckt werden? Z. B. durch einen Check der Freigaben durch das Betriebssystems, ob dies noch erreichbar sind.


    Könnte ich über ssh o. ä. die Firmware aktualisieren oder muss ich die Platten ausbauen und dann einzeln flashen? Wäre das überhaupt zu empfehlen? 2x WD RED 10TB.


    Diesen Befehl ist mir nicht klar? Was mach '{print $1" "$2}'?

    Code
    awk '{print $1" "$2}' outputfile.log

    Und letzte Frage, welchen Wert der HDDs muss ich beobachten, um festzustellen, ob da wirklich ein Zugriff erfolgt?


    Ich weiß, viiiel Fragen ... und vielleicht auch ein paar Antworten? :-)


    Einen schönen Sonntag

    Bodo

  • Hast du inzwischen auf APM 127 gewechselt, oder immer noch 128?

    Minimaler Energieverbrauch heißt maximaler mechanischer Stress für die Platten.


    Hast du mal geschaut, ob die Platten in den standby gehen? Sollen die das?

    Vielleicht mal alles im Power Management deaktivieren und hd-idle probieren, falls du die Platten in den Standby schicken willst.

  • Vielen Dank für die Erklärung.


    Laut Menü im OMV bedeutet "128 - Minimaler Energieverbrauch ohne Bereitschaft (kein Spindown)".

    Die Spindownzeit habe ich ebenfalls deaktiviert.


    Wenn ich es richtig verstehe, sollten die Platten nie "ausgehen". Bei der 127 hätte ich vermutet, dass die Platten abschalten und das für mehr Stress sorgt ... oder?


    PS: Automatisches Akustikmanagement steht auf: "Minimale Leistung, minimale akustische Geräuscherzeugung".


    Ich weiß nicht wie ich hd-idle am besten nutze. Habe zwar was im Netz gefunden aber könnte es zu Problemen durch "Überlagerungen" mit OMV-Einstellungen kommen?


    Kann es sein, dass die Platten sich selbst permanent "überwachen" und das zu den Kopfbewegungen führt?

  • Wenn die Platten1-2 mal am Tag hochfahren, ist das denke ich kein Problem.


    Persönlich würde ich nie 128 nehmen. Wenn die Platten schon nicht abschalten sollen, dann würde ich 254 nehmen. Vielleicht einfach mal die Leistungsaufnahme der NAS mit verschiedenen Einstellungen testen. Und dabei auch auf die Geräusche achten.

  • Hier die Übersicht:


    APM Level

    0 = Disabled

    1 = Minimum power consumption with standby

    2-127 = Intermediate power management levels with standby

    128 = Minimum power consumption without standby

    129-253 = Intermediate power management levels without standby

    254 = Maximum performance and power consumption


    Kannst du mir evtl. auch sagen, ob die Betriebssysteme die Freigaben checken und es dadurch zu ein "hochfahren" der Platten kommt?

    Du meinst, ob OMV regelmäßig auf die Freigaben schaut? Von Haus aus nicht.

    Hast du SMART konfiguriert?

    Unter General Settings gibt es "Check Intervall" und "Power Mode". Bei "Power Mode" sollte "Standby" eingestellt sein, damit die Platten nicht durch SMART aufgeweckt werden. Steht im GUI auch unter dem Auswahlfenster,

  • Hallo

    Ist schon ne Weile her mit diesem Post hier, möchte hier auch meine Erfahrungen hinsichtlich dieses Problems beschreiben.


    Ich habe also auch dieses Problem das die HDD "fühlbar tickt" also sich der Schreib/Lesekopf sich willkürlich bewegt, so ca. im 3 - 5 Sekunden takt. Habe kein Raid, es sind zwei WD red 8TB in Benutzung. Beide klackern und ticken fröhlich vor sich hin.

    Ich muss noch dazu sagen das ich diese Geräusche vorher nicht gehört habe. Die Platten waren in einem Mini Tower Gehäuse eingebaut das auf einem Teppichboden stand.

    Jetzt sind die Platten in einem Desktop Gehäuse untergebracht und das steht auf einer Holzplatte. Da werden die Geräusche halt besser übertragen, bessere Resonanz eben.


    Vieles getestet und einiges auch hier aus dem Post ausprobiert, zu guter letzt habe ich die Datenleitung gekappt, nur noch die Stromversorgung dran gelassen. Und weil ich gedacht habe das auch mein PicoPsu Netzteil der schuldige sein könnte habe ich noch die Platte ausgebaut und die Stromversorgung von einem PC mit einem 500W Netzteil geholt,

    Aber auch jetzt noch dieses fühlbare ticken. Also hat s nichts mit OMV zu tun, auch nicht von der PC Hardware. Das macht die HDD von sich aus. Und dagegen kann man meines Erachtens wahrscheinlich nichts tun.

    Ich habe hier noch eine 2TB WD red die nicht mehr genutzt wird aber noch vollkommen in Ordnung ist.

    Und diese Platte tickt nicht!


    Sollte man diese Verhalten einfach so hinnehmen ? Ist das also wirklich normal?

    Ich glaube nicht. Siehe die 2TB Platte.

    Allerdings weis ich auch nicht was man da tun kann, das übersteigt meinen Wissenshorizont. Möglicherweise haben die 8TB HDD's fehlerhafte Firmware? Könnte doch sein, wie gesagt, die 2TB HDD's machen diese Geräusche nicht.


    Aber wie gesagt, was man gegen dieses Problem tun könnte.... k.A.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!