Can't update repositories error

  • Hi since first install I do not getting update as I have error that repos are configured multiple times"


    Target Contents-deb (contrib/Contents-all) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list.d/openmediavault-kernel-backports.list:1


    my source list looks like that:



    that backport.list:


    Code
    deb http://httpredir.debian.org/debian stretch-backports main contrib non-free

    So yeah line 7 in first list looks like line 1 in second why?
    I downloaded OMV as per instruction, I check sdcard 4 times with tow programs (this is brand new Samsung Evoplus), what is wrong with that installation?


    Another error when I get OMV-extras repos update:



    Code
    W: GPG error: http://ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3028C3C96AD57103
    W: The repository 'http://ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease' is not signed

    Any suggestion please?

  • Remove the backports line from /etc/apt/sources.list. It was improperly added to the arm images.


    Not much we can do about the kyle1117 repo since it provides the cloudshell packages for the xu4. You can remove it if you don't have a cloudshell.

    omv 5.5.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thx, I did it finally I made small update/upgrade but only 2 packages, I still think that is something wrong with my installation. Please have a look at my syslog attached, log from armbianmonitor:
    http://ix.io/1qGf.


    I reckon my flashmemory plugin is not activated still but I did upadates. Tkaiser wrote that my install is a bit outdated. I di update and nothing.



    My fstab:


    Moreover I set up disk to not to go to sleep, but I can hear like disk woke up about every 2hrs is not use for a few minutes and goes to sleep again.



    Help please.

  • Thx, I did it finally I made small update/upgrade but only 2 packages, I still think that is something wrong with my installation.

    Not having updates doesn't mean something is wrong. Neither of the two "errors" you had would prevent your system from working.

    Please have a look at my syslog attached,

    Syslog won't have anything showing repo problems.


    I reckon my flashmemory plugin is not activated

    If it is installed, it is activated.

    Tkaiser wrote that my install is a bit outdated.

    Why two threads? That is just going to confuse things.


    My fstab:

    The flashmemory plugin doesn't put anything in fstab.


    Post the output of:
    apt-get update
    dpkg -l | grep openm

    omv 5.5.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sorry for misleading, I am just confuse, but:


    apt update


    Code
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0xb625b300>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0xb625b300>
    Traceback (most recent call last):
    File "/usr/lib/python3.5/weakref.py", line 117, in remove
    TypeError: 'NoneType' object is not callable
    Reading package lists... Done


    That python error is very stubborn but it is harmless as I read somewhere.



    Code
    ii openmediavault 4.1.12 all openmediavault - The open network attached storage solution
    ii openmediavault-docker-gui 4.0.1 all OpenMediaVault plugin for Docker
    ii openmediavault-flashmemory 4.1 all folder2ram plugin for OpenMediaVault
    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
    ii openmediavault-netatalk 4.0.7-1 all OpenMediaVault netatalk (AppleTalk Protocol Suite) plugin
    ii openmediavault-omvextrasorg 4.1.12 all OMV-Extras.org Package Repositories for OpenMediaVault
    ii openmediavault-transmissionbt 4.0 all OpenMediaVault Transmission (BitTorrent client) plugin.

    Looks alright to me, so maybe I am just overeating.



    However one more thing is worrying that hard drive is going to sleep (even that I left disable spin down in physical disk edit). How to prevent disk to go to sleep, this is NAS disk and I do not need it to stop every 15 minutes or so?

  • That python error is very stubborn but it is harmless as I read somewhere.

    To get rid of it:
    wget -O /usr/lib/python3.5/weakref.py https://raw.githubusercontent.com/python/cpython/9cd7e17640a49635d1c1f8c2989578a8fc2c1de6/Lib/weakref.py



    However one more thing is worrying that hard drive is going to sleep (even that I left disable spin down in physical disk edit). How to prevent disk to go to sleep, this is NAS disk and I do not need it to stop every 15 minutes or so?

    I assume you have not set any spin down time in the GUI of OMV:


    Which hardware are you using? On my HC2 the USB to SATA controller is spinning the drive down. Using the firmware of the controller the time can be adjusted or the spin down can be disabled.

  • Thx, it is a bit scary but I will make it, do you have idea what is max time in minutes to set in -t? I think to set it 720 minutes so if we go for holidays server will spin down. But I have also notice that there is some anacron job going every hour (it saves clock in case of power failure but I have my connected too ups so pretty safe, and it woke disk up, is this job necessary?

  • If the backports repo is already in the sources list, you can remove the backport.list as it contains the same line (see first post).


    However, if you feel uncomfortable with it, just leave it. It is just a warning and does not cause any problems.

  • No.
    We are talking about two files. sources.list and backport.list.
    It seems that the backport repo is listed in both lists. That is why apt is warning, that the backport is listed two times. To avoid this warning you can remove the backport line from the sources list. Or just put a "'#" in front of the line.

  • If the backports repo is already in the sources list, you can remove the backport.list as it contains the same line (see first post).

    Actually, you always want to remove it from sources.list since any repo change will regenerate the backports.list file. Removing it from sources.list also allows you to enable/disable backports from the web interface.

    omv 5.5.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • So remove and disable is the best way for a HC2?

    No. Just remove the backports entry from /etc/apt/sources.list. If you choose to enable or disable from omv-extras is you choice. I leave it enabled on all systems though.

    omv 5.5.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!