Can't login to complete install RPi 3 b+

  • The checksum of OMV image for RPI 3 b+ was confirmed after download.
    An 8 gb card was formatted with SD Card Formatter and burned with Etcher.
    Card was installed in RPi and booted with ethernet connection, wireless keyboard and mouse, and TV connected via HDMI as display.
    Boot displayed "typical" failures described as harmless in a previous post (Bluetooth, high performance system, etc.). Stops at "Raspberry Pi login:"
    At this point I've entered the ip of the RPi into a browser on a wireless-connected PC laptop on the private network but can't login using either "admin" or "root" with "openmediavault" as password. However, if the ip address is entered into Putty, the login prSCompt appears, I am able to enter "admin", am prompted for the password, but when "openmediavault" is entered and waiting momentarily the message "Access denied" is returned. I have also used "root" at the login prompt and again it prompts for the password but when "openmediavault" is entered the message "Access denied" is returned.
    I've tried with WinSCP with similar results.
    At a command prompt in Windows 10, I can successfully ping the RPi IP address.
    What am I doing wrong?

  • I haven't even gotten to the OMV login screen yet. I don't think the RPI has ever self-booted as described in procedures I've read. I've viewed the video and followed the procedure described, including a considerable waiting period of as much as two hours. I have been able to interact with the RPI ONLY by entering the ethernet IP into Putty or WinSCP.
    I have also tried re-flashing the card, but got the same results.

  • Hi Everyone

    I too have a Raspberry Pi 3+ and the same issue where via SSH I can not log in via root and the web interface is down.

    Looking at the startup events as it boots (plugged into a hdmi television and connected to the internet), the following don't start and listed as failed:
    [failed] to activate swap /var/swap
    [failed] to start realtek bluetooth
    [failed] to start zram swapping
    [failed] to start web server

    I am using the official power supply, a 16Gb memory card and the build: OMV_4_Raspberry_Pi_2_3_3Plus.img.xz that was written using etcher.

  • I just got done trying the installation without a wireless keyboard and mouse, but with an ethernet connection to the internet. No success there, either. I have an "official" power supply too with the same install image as identified by crizco-ok and it's still not working. I've tried this at least a dozen times with different hardware configurations and have waited and waited for a re-boot but with no success. I don't give up easily, so will keep trying.
    Forgot to mention the SD card passes the H2Testw, too. Also, this might be useful to others who have experienced this problem: How-I-fixed-Web-Gui-issue-and-DHCP-issue-on-Rasp-Pi-with-OVM-4. I don't have a usb keyboard, so I don't have the ability to see if that makes the difference.

  • I had read only the part of the link that describes how the writer got the Pi working with OMV. After your post, I read the other (many) pages of RPi issues. You're probably right, @crizco-ok, however I'd still like to get things working. It may be fast enough for my needs. I may try just putting the PI on the network as a Samba server with OSMC to serve media over the network. I still like the features of OMV, however, and might buy a USB keyboard if that's what it takes to install it. I'm not terribly concerned about Gigabit Ethernet speeds for my purposes.
    Can anyone confirm that a USB keyboard is required to install OMV on a Raspberry Pi 3 B+?

  • Can anyone confirm that a USB keyboard is required to install OMV on a Raspberry Pi 3 B+?

    No other peripherals than power cable and network cable (resulting in Internet access) should be connected to an RPi. Due to the choice of 'power connector' (the crappy Micro USB jack) those Raspberries are often underpowered and by adding USB consumers underpowering might get even worse (underpowering --> voltage drops under load).

    A machine that can't be powered reliably won't work reliable. You need something like the official RPi PSU with fixed cable able to hold stable 5V to power the board (the amperage stuff is more or less irrelevant, it's about undervoltage almost all the time).

    This is just a general recommendation and I didn't look into the issues described above since every second spent on trying to diagnose problems with the RPi is wasted. It's the worst choice possible for anything related to storage and/or network. Better variants: Which energy efficient ARM platform to choose?

  • Thank you for your confirmation that I don't need a USB keyboard to install RPi, tkaiser. I'm using the power supply sent with Canakits, so hopefully that's not the problem. There is one thing I haven't mentioned that I'm wondering about: the SD card. The SD card I have is an old one that is quite slow. I've also tried an old flash drive. Neither is a class 10, so I've ordered two Samsung EVO+ Class 10 32gb cards for the RPi. I should have them tomorrow, will install OMV on one of them, then report the results here. I've seen so many Internet articles about using an RPI with OMV as a NAS that I want to see first hand what it's like.
    Three years ago I installed the headless Ubuntu Server on an old PC, along with a few other programs, to use as a DLNA and Ethernet media server/NAS. I suppose it is quite slow compared with other alternatives (Fast Ethernet), but it worked well for my purposes. I still have it and can put a music CD into it to immediately start to convert the music to .flac and .mp3 files. So my requirements aren't that demanding. However, I intend to buy another small computer once I have learned about their capabilities and potential and will heed your advice to avoid the RPI. Thank you very much for your help!

  • I've ordered two Samsung EVO+ Class 10 32gb cards for the RPi

    Really good choice 2-3 years ago but today I would only buy A1 rated cards any more (info and more info).

    Anyway: please take care to check the SD card directly after purchase for fake/counterfeit with the appropriate tools, then use SD Formatter to do a 'quick format' (this will TRIM the card so this needs to be done after the h2testw or f3 run) and then use Etcher with verify to burn the uncompressed image.

  • Aha! Things are working now! The card was the problem. The Samsung EVO+ Class 10 32gb cards work well (after passing the h2testw test). Immediately after I flashed a new card with OMV, put it in the Pi and booted, things were different. The system boot log went past the Raspberry Pi login and eventually the Pi rebooted as described in the "official" video and other articles/forum postings I've read. Then I was able to login through a browser by entering the IP address of the Pi. So now I'm trying to configure OMV! Thank you all!

  • The card was the problem.

    Yes, that's one of the two main reasons why OMV (or any other OS image) doesn't work on Raspberry Pi (or any other SBC):

    • SD card issues
    • power supply issues

    Since users always have a hard time believing this we added an own section in Armbian forum collecting a 'best of'.

  • had the same issue /checking the sha1and MD5 from the mainpage with the downloded rar file - OK /no gui what so ever /what i did (suspect mmc ,browser firefox ,chrome ,adblocker ,power supply )

    first login with admin and pass openmediavault (terminal pi)
    changing password
    sudo apt-get update
    sudo apt-get upgrade
    waiting ......
    sudo reboot

    done /back in buisness -have gui support :)

    my pi is rpi 3 b+ i think was not sdcard faulty ...

  • first login with admin and pass openmediavault (terminal pi)

    Impossible. You can only login with admin in the web interface. At the local console only root would be possible.

    Which doesn't change a bit that all you need is to read the readme.txt at the download location…/Raspberry%20Pi%20images/ and follow the steps that are written there!

    Connect the board to network (working Internet connection!), fire it up, wait for the automatic reboot, enjoy!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!