Docker 'Communication failure'

  • It would appear that docker is something I am going to have to learn but I have struggled over the past few days to achieve anything because I just get errors popping up all the time saying communication failure.

    The 'pull' button does nothing, I put the address in and nothing happens, the actual dialogue even looks broken so I am not sure the docker plugin works at all?

    I tried installing the plex docker from the docker repo tab (this has worked on an off over the past few days), I have scraped through getting it running and it seems to do so but when I goto the ip/port of plex it just loads a bunch of text so clearly I am getting that wrong.

    First things first though what to do about this comms failure?

  • HI Macom

    I put this in


    IN safari it does not do anything in Chrome it does, it begins downloading stuff does this for ages inevitably it comes up with comms failure.

    The pull is not completing I can leave it for ages come back and it still says start/close, if I hit close and refresh the docker bit there is nothing there.

    I have 12 cores/24 threads, 48 gigs ram. The drive with OMV is an evo 1tb job. Network is otherwise fine copy to and from 100MB/s plus, my internet is 360mbs Virgin media.

    I might just upgrade to OMV 5 on the basis the current plugin architecture appears to be going, will I have any more luck with 5 do you think?

  • HI.

    Its updated in terms of V4.

    But I wonder if I have gone around this right? I got the docker plugin from the OMV extras? All I did with flick the button to on and the docker plugin option opened and I was able to install it.

    I have a lot to learn but the instructions here seem a bit out of date, I have never used docker before. I am only using it because I read that Plex plugin is being stopped and I noticed the great plugin that allows me to remote in to a simple desktop environment no longer installs.

  • All I did with flick the button to on and the docker plugin option opened and I was able to install it.

    You need to do two steps

    • enable the docker-ce repo in omv-extras | repo
    • install the openmediavault-docker-gui in plugins --> tick the box and click install

    I assume that is what you did.

    You can have a look at the user guide that is linked in my signature.

    Its updated in terms of V4.

    So in update management there is nothing shown if you click "check"

    Have you enabled the backports kernel in omv-extras | Repos --> Backports?

  • I am not sure what communications failure means. i.e if its a network failure all I can think is I have the onboard ethernet but also a separate intel twin nic. However the intel is not set up within OMV.

  • I have been fighting it all afternoon and with the backports enabled and uninstalling and reinstalling its sort of doing something. I can get some pulls downloaded.

    I am try to fire up plex, but I dont know, I am struggling to understand why I would want docker, I guess from a developer perspective here, the onus now becomes the users to make this stuff work. In OMV for instance you install OMV extras turn on the plex button and install and boom you have plex running. From a users perspective thats fantastic. But I do understand someone has to maintain that.

    Docker seems to be far harder for the average Joe to get his head around, I cannot get plex running. Apparently I might have to do some terminal code to register ports or something and get a token for plex and blah blah. I installed the RDP one, something happened because I can RDP to a basic login area but it does not recognise my root password etc etc, super easy with the plugin architecture, install in and log in boom.

    I guess I have been spoilt with how easy it has been in OMV, but I dont think Docker is for me, for this amount of effort I may as well install ESXi and run some virtuals.

    Thank you for your help though, for what its worth it sort of working!

  • Did you solve the problem? Because I got the exact same problem even though I have a fully working plex running as a docker.. I keep trying entering the Docker tab but keeps geting the communication error. After a lot of tries I finally enter.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!