Nextcloud docker container not updating to newer version? OMV4

  • OMV version: 4.1.26-1
    Docker version: 19.03.4
    Nextcloud version: 16.0.4

    I have installed Nextcloud, mariaddb and letsencrypt by using this docker-compose guide by macom: [How-To] Nextcloud with Letsencrypt using OMV and docker-compose

    To keep the containers up to date I have also installed watchtower by following Techno Dad Lifes how-to video on youtube. The problem is that my Nextcloud docker container does not update to the to newer version and I'm stuck with Nextcloud version 16.0.4. The "CREATED" date in the docker repository list does update from time to time so watchtower is doing something but for some reason the nextcloud version does not change?

    I also tried completely deleting the nextcloud docker (I did not touch mariaddb and letsencrypt) and reinstalling it with "docker-compose up -d" but that didn't help either, the NC version is still 16.0.4 even after the reinstall...

  • Did you update nextcloud inside the container using the gui? Because updating the docker does not necessarily update the nextcloud version within.
    Also the linuxserver images are recreated every week even if there is no change in the code.

    Thanks for the reply, I have tried updating NC via the webGUI but I always get this error: "Check for expected files - Parsing response failed. File not found." so that does not work...

    According to the NC docker page the update to 16.0.5 should already have been available on the 26th of September. The most current docker version should be NC 17.0.0 if I'm understanding the page correctly?

  • My Nextcloud in docker is also on 16.0.5. Updated using the update button in Settings in Nextcloud. 17 is not offered, yet. I assume rollout will take some time. I probably could change the channel to update to 17, but I will just wait.

  • Could someone, who is also using NC in a docker container, please check their Nextcloud version? I'd like to know if others are also having the same issue, I'm still stuck on 16.0.4...

    so i'm having the same issue. did you find a solution?

    Hi jackster,
    I'm running NC 16.0.5 in a docker container.
    I never update the container itself. I use the update script ("updater.phar") from the command line within the container.


    is this the how you upgrade?
    Nextcloud update

  • I'm still on 16.0.4, I never got the 16.0.5 update and I haven't received 17.0.1 either... The NC WebGUI update does not work, I can open the updater but as soon as I press 'Start update' I receive this uninformative error:

    Would be nice if it would say which file isn't found so that I could try and do something about it...

    Like I said earlier I also tried completely removing the Nextcloud container in the Docker GUI and I then reinstalled the container with "docker-compose up -d" by following the instructions in this thread https://forum.openmediavault.o…g-OMV-and-docker-compose/ . But that didn't help either because the version that was installed was still the old 16.0.4.

    And I have Watchtower enabled but it doesn't seem to update NC either so I'm guessing that the problem is that the container image "linuxserver/nextcloud" still has not been updated?

  • I also tried completely deleting the nextcloud docker (I did not touch mariaddb and letsencrypt) and reinstalling it with "docker-compose up -d"

    Maybe try this again, but delete the image (not only the container) to make sure a new image is pulled.

  • Just a theory :
    I think the problem lies somewhere in your static files, which are mounted as bind to mounts. Updating the container won't change it.

    Anything useful when you login as admin and look under logging?

    There are these PHP errors which seem to be permission issues:

  • I have not had time to look into the issue, as I have the same problem.
    But I did find an article about the update feature not knowing the directory to look for the downloaded update.
    The fix was to add the directory path to the end of the url. I posted the results in my post.
    I was then given the option to manually add the secret hash manually from my config file.
    It did not work, invalid secret.
    I'm now thinking permission issue are probably the issue.
    I also have watchtower installed, maybe watchtower is messing with permissions?
    As that's something else we have in common.

    Sent from my S10 using my thumbs, with tapatalk.

  • In order to diagnose the issue further I logged in to the NC container shell and searched for all *.log -files, but none of these had any helpful information:


    Not even updater.log, which at least I at first assumed would contain something useful, has anything relevant...

    So I guess I'll try deleting the NC container again and also delete the image and then reinstall. It won't solve the actual problem with the "File not found" error but at least then I should get the newest version.

    EDIT: How exactly do I delete the old NC image? I tried again killing the container in the Docker GUI after which I deleted the "Repository" in the GUI and then re-installed with docker-compose up -d but I again got version 16.0.4. I followed the install and the installer said that it was pulling the image and I witnessed it downloading a ~130Mb file but I am still getting the same old 16.0.4 ?(

  • Ok so I tried troubleshooting the issue further and I think it has to do something with the webGUI updater searching for the NC install in the wrong folder and not with the permissions being wrong. The upgrade process fails immediately with the message 'File not found' after I press the update -button and there is no record of the upgrade actually starting in the updater log. If it would have found the files then the next step would have been the write permissions check and it never got that far.

    Anywho, I did now manage to upgrade my NC to 17.0.1 by running the installer from the container shell with the command: sudo -u abc php /config/www/nextcloud/updater/updater.phar

    Everything went smoothly with the CLI install and it immediately found all the files. Why the GUI updater looked for the files in some other location I don't know. Remains to be seen if I'll still have the same issue when a newer version than 17.0.1 will be available.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!