I can no longer log into OMV via SSH

  • Hi guys!


    For some days I have had a big problem: I can no longer access OMV via PuTTY and / or WinSCP !!!

    With both programs I get the following error: Network error: connection timed out.


    OMV works smoothly via web shell, but I have no response via PuTTY and / or WinSCP.


    Nothing has been changed and previously everything worked regularly.

    Windows settings have not been changed and SSH is regularly enabled on OMV.

    Shared folders are seen regularly and I can also transfer files inside them on Windows...


    Anyone have any idea how I can fix this?

    Davide


    Admin and webmaster of
    logo_JQITA.png

  • weird.


    1. Is the SSH server running (check the webUI under SSH and make sure it is enabled)


    2. Are you trying to log in via IP address, or host name? If you're trying by IP, try hostname. If you're trying by hostname, try IP address.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • OK, did you set up something that took port 22 by chance? (maybe a docker container or something?)


    Try changing the port in the webUI (say, 26)... Save and restart the service.


    ssh root@ip -p 26 (that's how you'd do it on Linux.. not sure about Putty or Winscp)

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited once, last by KM0201 ().

  • 1. SSH server is running (view attach)

    Check in the dashboard if it is showing as enabled and running.


    You could check the log files if there is anything related to sshd.

    Or in the authentication log, if you are banned (not sure what the error message would be in that case)

    Are you able to connect a display and terminal?

    You could also install docker and wetty to have a terminal to investigate what is going on (e.g. confirm that sshd is running with

    systemctl status sshd

  • KM0201 no services take port 22.
    Changing port to 26 and restart service: now SSH work... =O=O


    macom ssh is enabled and running (view screenshot in attach) .

    No banned warning in Authentication log.

    On terminal systemctl status sshd returns:

  • The problem seems to be port 22.
    But recently no new components have been installed on OMV that take this port.


    I think the problem, at this point, lies in the settings of the router (which I never changed ...) since nothing has changed on the Win10 PC with which I have always connected.


    I just can't understand... :huh:

    Davide


    Admin and webmaster of
    logo_JQITA.png

  • The problem seems to be port 22.
    But recently no new components have been installed on OMV that take this port.


    I think the problem, at this point, lies in the settings of the router (which I never changed ...) since nothing has changed on the Win10 PC with which I have always connected.


    I just can't understand... :huh:

    It could be the router..


    If it were me I would do two things:


    1. have you tried to SSH the server from another device? Maybe a Tablet, Phone or another computer? This would narrow down it being a client or server issue.


    2. Check if you have a software firewall on your PC that is not allowing you out on Port 22.


    If all that checks out OK... then I have no idea what to suggest other than just dealing with it and leaving it on 26.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • The router settings have never been changed.

    The settings of the firewall software (Kaspersky) have never been changed.


    I have checked both and there is no restriction on port 22.

    I will change the port from 22 to 26.


    All this remains a mystery... :/:/:/


    Thanks macom and KM0201 for your support ;)

    I close the topic, if possible.

    Davide


    Admin and webmaster of
    logo_JQITA.png

  • shecky66

    Added the Label resolved
  • That is certainly possible.. it could have easily been a cache issue that was showing the service "green" or enabled (thus why command line is always better to get this info, or make sure your browser is refreshed).


    I'd personally be extremely curious on why this is happening. If it's not allowing connections out from the client, I guess that is better than just allowing anything in.. I suspect it is something with Windows or his security settings...


    A super easy way to test that, would be to boot a Linux live USB on the client (Ubuntu, Mint, whatever).. and try to SSH the server from the Live session. If it works, you know it's something with Windows. It is the router (assuming the live session and Windows have the same IP address) or he's accidentally closed off port 22 on his server somehow (maybe a setting in Kaspersky?)

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Hi macom.
    Hi KM0201 .

    I changed again SSH to port 22 and, by Powershell, I check it with Test-NetConnection command.
    Check result is:


    When I set SSH port to 26 again, check result is:

    Code
    Test-NetConnection -ComputerName 192.168.xxx.xxx -Port 26
    ComputerName : 192.168.xxx.xxx
    RemoteAddress : 192.168.xxx.xxx
    RemotePort : 26
    InterfaceAlias : Ethernet
    SourceAddress : 192.168.yyy.yyy
    TcpTestSucceeded : True


    P.S.:
    For your information, with the same command I check all other port available (service enable, docker containers, ecc...).
    All ports respond correctly, except for 22 (SSH), 88 and 443 (http / https for LetsEncrypt container , however not used)

    Davide


    Admin and webmaster of
    logo_JQITA.png

  • Again, I don't know how far you want to go into trying to figure this out...


    I'm still of the believe this is either something with your security software, or some setting in Windows. Have you tried my suggestion to boot a Linux Live CD/USB (Ubuntu, Mint, just about anything).. and seeing if you can ssh the server from it? If you can SSH from the Live session, then you know it's either your security software on Windows, or a Windows setting. If you can't, then it's something in your router or a setting in your server (which seems unlikely at this point)


    That will absolutely narrow it down.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Thanks, KM0201 !


    I try ASAP and reply ;)

    One other thing.. while it's improbable it's not.. Make sure the Live CD is pulling the same IP from the router as Windows is. If it's pulling a different IP address than Windows, it's possible it could be getting around a Router setting.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!