Error messages: Check updates in Web GUI

  • Hello,


    I received the following error messages when I do an update via the Web GUI.

    Can someone help me on this?


    Thanks8)

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

  • That means you haven't updated since February. I would try to update more regularly.

    Yes, that's unfortunately correct! :)

    Guess the recommendation would be to upgrade to OMV 5?!

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

  • Thanks!

    I think i will first of all start with OMV 5. Or is there any benefit to switch directly to OMV6?

    Is there any option to update automatically every month?

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

    • Official Post

    I think i will first of all start with OMV 5. Or is there any benefit to switch directly to OMV6?

    Is there any option to update automatically every month?

    You have two options.


    Option 1. Upgrade your system to OMV5. Solve the problems that arise. To breathe. Upgrade your system to OMV6. Solve the problems that arise. To breathe.


    Option 2. Disconnect your hard drives. Do an OMV6 installation. Connect your hard drives. Enjoy.


    It's up to you.


    Updates are semi-automatic. The security ones are applied automatically. Others do not. Getting used to entering your server once a month and spending 5 minutes can be a healthy habit that will save you spending much more time than those 5 minutes later.

  • I updated now to OMV 5 through the upgrade script but still have an error message when I want to do an update:

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

  • Also I receive the following error messages when I want to activate FTP:

    Guess anything went wrong with the update ;(

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

  • You messed with the apt sources. What is this ppa:

    Quote

    Err:13 http://ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3028C3C96AD57103

    Reading package lists...

    W: GPG error: http://ppa.launchpad.net/kyle1117/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3028C3C96AD57103

    Can you remove it?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • unfortunately not.

    Go to the directory /etc/apt/sources.list.d

    Find the file which defines this repository

    Edit this file and put a # before the line.


    rerun update script

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Thanks, I see those files in /etc/apt/sources.list.d


    Code
    armbian.list             openmediavault-kernel-backports.list
    armbian.list.disabled         openmediavault.list
    armbian.list.save         openmediavault.list.save
    kyle1117-ubuntu-ppa-cosmic.list  openmediavault-local.list
    omv-extras-org.bak         openmediavault-os-security.list

    How can I edit these files?

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

  • This is the culprit: kyle1117-ubuntu-ppa-cosmic.list

    Someone installed something on you OMV server which does not have an update available.


    I do not know of an easy way to find out what has been installed from this repo, but from googling it could be cloudshell.


    Check if cloudshell ist installed

    dpkg -l | grep cloudshell


    Remove the packages by apt-get remove <package_name> (<package_name> is the second column in the result of the command above)

    Remove the file kyle1117-ubuntu-ppa-cosmic.list by rm /etc/apt/sources.list.d/kyle1117-ubuntu-ppa-cosmic.list 


    Update and re-install whatever you uninstalled und still need

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Sorry but there is no feedback from the command:

    dpkg -l | grep cloudshell


    But I see some old plugins. Is this maybe the reason for the error message?

    Code
    dpkg -l | grep openm
    ii  openmediavault                                              5.6.21-2                            all          openmediavault - The open network attached storage solution
    ic  openmediavault-backup                                       4.0.6                               all          backup plugin for OpenMediaVault.
    ii  openmediavault-flashmemory                                  4.2.2                               all          folder2ram plugin for OpenMediaVault
    ii  openmediavault-keyring                                      1.0                                 all          GnuPG archive keys of the OpenMediaVault archive
    ii  openmediavault-omvextrasorg                                 5.6.5                               all          OMV-Extras.org Package Repositories for OpenMediaVault
    ii  openmediavault-usbbackup                                    5.0.9-1                             all          openmediavault USB/eSATA backup plugin

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

    Edited once, last by ChrisBuzz ().

  • Remove the file kyle1117-ubuntu-ppa-cosmic.list by rm /etc/apt/sources.list.d/kyle1117-ubuntu-ppa-cosmic.list

    It is there, but not used any more I guess.


    the update.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • Sorry, but I don't know what to do.

    Already installed omv-extras for OMV 5.

    How can I move that to GitHub?

    :!: Odroid HC2 - OMV 5 - 3TB Hard Drive :!:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!