Help needed with creating restricted shared SMB folder

  • Hello fellow community members,


    a couple of weeks ago i thought i would give OMV 6 as my local network storage a try and installed it on my raspberry pi 4. For initial setup i decided to follow the new user guide on this website https://wiki.omv-extras.org/. So far this went pretty well and i was able to configure a public share for my network that i and a couple of other ppl now actively use.


    Now i want to create another share on the same omv server but this time want to restrict access with a username + password.

    For this i first created another Shared Folder in OMV where i set the permission to "Administrator: read/write, Users: read/write, Others: no access". Second, i created another SMB share, referenced the newly created shared folder and set the option "Public - No". After this, i was able to see the newly created shared folder on my windows machine but obviously couldn't connect to it.

    So the next thing i did was creating a new user with a password in OMV with the option "Disallow account modification". I also left the user with the default groups.

    I then modified the created users shared folder privileges to "Read/Write" on the newly created shared folder and repeated the same thing on the Shared Folder itself for "Privileges" and "Access control list".


    If i know try to connect from my windows machine to the shared folder and enter the username + password of the new user i get the following error:


    It pretty much says "Can't access server. You probably don't have permission to access the network resource. Please contact your network administrator. Several connections to one server or a shared resource from the same user with different usernames are not possible ...".


    I would be really glad if anybody could help me solve the problem or point me to the right direction as i don't really get the error message.


    Kind regards

    RedPanda

  • macom

    Approved the thread.
  • Maybe this helps:



    and do not mess with ACLs. Privileges is all you need for now.

  • macom Thanks for the fast reply. I read through the linked guides, recreated the second shared folder and added the username + password in the credentials manager. Weirdly enough i still can't connect to Shared Folder and still get the same error message provided above. It also seems that i'm now unable to connect to the "Public" Shared Folder too.

    To me it seems like there is a problem with windows and needing to connect to two network shares on the same server, but once without a user and once with a user.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!